1. biggeno313's Avatar
    I have had my tablet for about a month or so now. And I'm having a problem with the Micro SD Card Slot. The actual card(fairly expensive 32 gb variety) wont stay put in the slot. I'm assuming the mechanism that holds the card in place is damaged..but what do I know. Anyway, I'm sending it back today for the second time for this same issue. Anyone out there with this same issue??
    03-16-2012 09:16 AM
  2. pkcable's Avatar
    I am not having that issue. Definately sounds like a hardware issue.
    03-16-2012 06:50 PM
  3. biggeno313's Avatar
    Yes unfurtunately. Its such a shame because otherwise I love this device!! But like I said this is the second time I'm sending it back for that same issue.
    03-17-2012 12:00 PM
  4. DaWeav's Avatar
    When you get the Galaxy, do not do the autoupdate from Android version 3.1 to version 3.2 because those infamous Google (idiots) changed the way Honeycomb accesses the external microsd card in version 3.2 which makes pretty much 'READ ONLY'. There are a few threads over on XDA general Galaxy Tab forums about it with a root hack to change 3.2 back to 'READ/WRITE'. Can't blame Samsung for this one! Go figure...

    Sent from my iPad using Tapatalk
    03-18-2012 09:29 AM
  5. biggeno313's Avatar
    Wow..Thanks. Definately news to me.
    03-19-2012 06:19 PM
  6. pkcable's Avatar
    Hopefully the ICS update fixes this, IF they ever get it out to us!
    03-21-2012 08:19 AM
  7. biggeno313's Avatar
    True indeed Pk..tired of checking 15 times(at least) a day.
    03-21-2012 04:57 PM
  8. DaWeav's Avatar
    From what I've Google'd and read, it seems this is going to be by design for Google Android even in ICS. Guess we won't know for sure until the update comes out.

    Come on Google Android programmers, if I wanted a tablet that can't be expanded via the microsd, then I would have visited the Apple store!
    03-24-2012 09:56 AM
  9. k_t_b's Avatar
    Maybe this is a silly question.

    Have you tried using a pin, paperclip or another micro SD card to push down on the micro SD card which you are inserting/ejecting?

    In my experience, the micro SD card slot in this tablet is too far recessed in the case to be able to insert or eject a card with just your fingers. If you tried this, it might appear that the card "wont stay put in the slot," but you may simply need to push the card farther into the slot in order for the mechanism to catch or release.

    I hope that helps.
    hangzhouharry and DamselKat like this.
    03-24-2012 12:11 PM
  10. Androman1's Avatar
    Double check how your inserting the card, I find that the slot is so recessed that you can't insert the card into the slot properly without using a tool. Its recessed very deep, feel for the spring catch when you push it in.
    hangzhouharry likes this.
    03-27-2012 09:21 AM
  11. biggeno313's Avatar
    First of all..thanks for your help. It's appreciated a great deal. Whats weird is that the card will stay put and read for like the first couple hours after I insert it. I often check my storage to see if its still reading and what do you know? No sd card. It only shows my internal storage. When I lift back the little tab to see if the card is still inserted it immediatley pops or 'springs out". After that, I can no longer get it to stay inserted. Strange right? And no...I'm not making this up.
    03-27-2012 05:43 PM
  12. cbill's Avatar

    Have you tried another card? Sounds to me like you might have a card problem. It is rare that you would get two bad gal 7 + phones with this same problem. I think yours is the first I have heard of.

    03-28-2012 09:13 PM
  13. biggeno313's Avatar
    Its the same device. I sent it in for repairs and had the same problem once I got it back. I will, however try a different card. Especially since Im using that card in my smart phone now. I should be recieving my otherwise wonderful tab back tomorrow from the fine folks at Samsung. Wish me luck!!!
    03-29-2012 04:18 PM
  14. DamselKat's Avatar
    You are the Ace tonjght. No one need send in their tablets this solved it for me in 2 seconds. I should have guessed, I had a Nook that did the same until I used another micro sd card to push it all the bway in. Thank you!!
    09-05-2015 07:34 PM
  15. bigkoll's Avatar
    I have same problem with my galaxy tab 3 and mine is just over 12 months old gonna cost me £35 to have it repaired
    12-12-2015 03:04 PM