1. Just As I Am's Avatar
    I have a Samsung Galaxy Tab Pro (SM-520). It has been working perfectly.

    Now, all of a sudden, when I plug in the usb cable, it does not show up in the "My Computer" section of my Windows 7 system. It gives the familiar "ding" sound when I plug it in, and it charges using the same cable, but now I cannot drag files across to it anymore.

    Ideas?
    01-21-2015 10:44 PM
  2. B. Diddy's Avatar
    On your tablet, is there a USB connection notification? If so, tap it, and make sure it's set to MTP.

    If there is not USB connection notification, try using a different cable. If a different cable doesn't help, then make sure there isn't any debris in the tablet's microUSB port.

    On the computer, open the Control Panel and go to Device Manager. Can you find the device listed there? If so, Remove it, unplug the device from the computer, then plug it back in again, and see if the Plug and Play process finds it and reinstalls it.
    01-21-2015 11:06 PM
  3. Just As I Am's Avatar
    Thank you for the quick reply.

    There is a USB notification, and it is set to MTP. I have tried several cables and get the same results (note: I have no problem charging the tablet with these same cables). I checked the Device Manager and the device was not listed. I plugged it in and I get one entry under "Asus Android Device" (Samsung Android ADB Interface). After deleting that reference, unplugging my tablet, and then re-plugging it back in, it re-installed the it and it shows up in the Device Manager.

    However, it still does not show up in "My Computer".

    I just noticed in the Device Manager, under "Portable Devices", there is a reference to my tablet with a ! next to it.

    When I reinstall the software for it, I get an error stating that it encountered an error "This Device Cannot Start (Code 10)".

    Ideas?
    01-22-2015 02:57 PM
  4. B. Diddy's Avatar
    Try installing the latest USB driver here: Support - Wi-Fi Tabs SM-T520 | Samsung Galaxy Tab
    01-22-2015 11:08 PM
  5. Just As I Am's Avatar
    TY for the quick reply. The solution was a complete reboot of the tablet.
    B. Diddy likes this.
    01-23-2015 02:50 PM
  6. MidnightRuby's Avatar
    Thank you this worked for my tab 4
    07-23-2015 02:33 PM
  7. yuepc000's Avatar
    I had exactly the same problem with my Galaxy Tab Pro 8.4. It disappeared from the Windows File Explorer screen. I tried all that was suggested here. The driver was reinstalled successfully and the device showed up in the Device Manager as working. It still didn't show up on the explorer screen until I finally rebooted the tablet. Thanks to all.
    01-18-2016 07:18 PM
  8. Steve Swift's Avatar
    I had a similar problem with my Galaxy Tab S2. I went into Device Manager and under Portable Devices, I deleted the device (I forget what it was).
    Then, when I reconnected the Tab S2, windows re-installed the driver and now I have "Galaxy Tab S2" under "Portable Devices" and my USB drives are back.
    Please note, I had to find "Device Manager" the old-fashioned way. The new funky Windows 7 "Devices and Printers" knows nothing about portable devices.
    I have a strong suspicion that the loss of the USB drives was caused by installing and then un-installing Samsung Kies. That's the only relevant change I've made since the last time I saw my USB drives...
    05-16-2016 02:35 PM

Similar Threads

  1. Replies: 7
    Last Post: 01-22-2015, 04:30 PM
  2. Default Dialer Not Sticking/Lollipoop
    By Leon Stevens in forum Moto X (2014)
    Replies: 5
    Last Post: 01-22-2015, 02:50 PM
  3. How can I transfer audiobooks to my Samsung Galaxy S4?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-22-2015, 10:44 AM
  4. Why won't my Samsung Galaxy Tablet charge?
    By Kiana Vaughan in forum General Help and How To
    Replies: 1
    Last Post: 01-21-2015, 11:12 PM
  5. Replies: 1
    Last Post: 01-21-2015, 11:02 PM
LINK TO POST COPIED TO CLIPBOARD