1. JackDouglass's Avatar
    So my google play store was acting up and wouldn't let me download certain things. I could download all my updates for my apps, but when it came to downloading new apps, the google play store would either crash, or let me download the app. It was so weird and there was no "big changes" that I recently did to my tablet. So then I decided to download some apps through the google play store in my browser (google chrome), and to my surprise everything I tried to download resulted in a "download unsuccessful" notification. I had tried every solution on the internet that I could find for both problems. So today I finally resorted to my last option which was a factory reset. (I backup all of my data of course) But now I can't even get past the setup! When I get to the part where I need to select my WiFi. I put in the password move onto the next page and then I stuck at a page where it says "checking for updates" and nothing ever happens. So I then go back to the page where I need to select my WiFi, I skip it, continue with the setup, and then I'm stuck at a page where it says "Just a sec..." and again, nothing happens! I've looked up solutions for these problems, and tried everything. I've factory reset 5 times now! Any help would be gratefully appreciated.

    ::Some other information: I'm rooted (I don't know if factory reset removes root, but I think it doesn't), I'm running Android lollipop 5.0.2, I've had this tablet for over 2 years without any issues)::



    EDIT: I've fixed my problem, I flashed my tablet with its official stock firmware using Odin. I guess i'll leave these here if anyone else has the same problem and finds this post.
    FF22 likes this.
    05-22-2016 03:11 PM
  2. Tisha Vassel's Avatar
    I am having the exact same problem right now.
    My device is rooted too but the issue I was having at first was with my Google Play Store.
    The error "Unfortunately, Google Play Store has stopped." started appearing after I've downloaded an unknown App onto my device.
    I deleted the app (that started this issue), I wiped all my data from my Google Play Store Service and cached it.... NOTHING WORKED.
    The only option I had left was to Reboot/Hard Reset my device so I did exactly that... BIG MISTAKE because now I am stuck on the initial setup page and I STILL HAVE THE GOOGLE PLAY STORE ERROR SHOWING UP EVERY 2MIN.

    My Samsung tab s 8.4 has been stuck on "Just a sec..." for days.
    Or sometimes when I reboot it again for the 100th time, it stays on the page that says "Checking for software updates".

    Now you said you've solve the problem with ODIN firmware flash-drive or whatever..... what is that?? What am I suppose to do?
    I do not have an OTG usb cable either... How much will it cost me for all of that to fix my problem?
    08-28-2016 09:42 PM

Similar Threads

  1. Settings app crash after tapping google account
    By SiL3NT_252 in forum Samsung Galaxy S4
    Replies: 13
    Last Post: 08-05-2016, 09:59 PM
  2. What is the typical/ideal battery drain rate?
    By blaze53 in forum Moto 360
    Replies: 3
    Last Post: 05-25-2016, 07:32 AM
  3. why is my back speaker not working while playing music
    By Mani Kanth Reddy in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 05-23-2016, 04:34 PM
  4. How do I set up voicemail on Samsung GalaxyS2?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-22-2016, 03:39 PM
  5. Settings app crash after tapping google account
    By SiL3NT_252 in forum General Help and How To
    Replies: 1
    Last Post: 05-22-2016, 02:56 PM
LINK TO POST COPIED TO CLIPBOARD