1. sta18ff's Avatar
    I installed Disney plus on my phone and it works fine. On my S3, I tried downloading movies over night, and when I tried playing them from SD card this morning the video was laggy, and tablet kept freezing up and even force restarting the whole tablet. Anyone else having issues?
    11-17-2019 01:45 PM
  2. mustang7757's Avatar
    Might be a issue with your sd card
    milleniumdroid likes this.
    11-17-2019 04:58 PM
  3. milleniumdroid's Avatar
    Might be a issue with your sd card
    Probably too slow of an SD card... OP should get one of the 100MB/s Samsung EVO 64GB cards and enjoy. They aren't pricey either.
    mustang7757 likes this.
    11-18-2019 03:34 AM
  4. sta18ff's Avatar
    I first thought it was the SD card also, but it tests fine. it is a Samsung EVO 64GB card. To rule that out I did a factory reset, and installed a brand new Samsung 128GB card. Everything worked fine until got to about the 5th movie I was downloading (downloading all the Star Wars movies) and then the whole tablet starts lagging (not just the Disney+ app). Tried rebooting and force closing app, but problem comes back. It seems like something can't manage the amount of memory in storage in the card.
    11-18-2019 03:06 PM
  5. sta18ff's Avatar
    I should have been clearer in original post that the app is causing the whole tablet to lag and freeze. When I first downloaded the app the Play Store show "May not be optimized for your device", but after factory rest and reinstalling everything, that message was no longer there.
    11-18-2019 03:09 PM
  6. mustang7757's Avatar
    I should have been clearer in original post that the app is causing the whole tablet to lag and freeze. When I first downloaded the app the Play Store show "May not be optimized for your device", but after factory rest and reinstalling everything, that message was no longer there.
    Gotcha , also can uninstall and reinstall the Disney+ app see if it helps if it happens again
    11-18-2019 03:27 PM
  7. sta18ff's Avatar
    Tried reinstalling twice, which is when I noticed the "not optimized" message went away. Lagging is slightly less, but still a pain
    11-18-2019 05:12 PM
  8. mustang7757's Avatar
    Tried reinstalling twice, which is when I noticed the "not optimized" message went away. Lagging is slightly less, but still a pain
    I'm not sure what to suggest as you have a old phone and software version , that might be another issue
    11-18-2019 05:18 PM
  9. milleniumdroid's Avatar
    I'm not sure what to suggest as you have a old phone and software version , that might be another issue
    The Tab S3 has Pie. What is probably the case like with many such apps is that it was intended for phones. Sadly, Google does not put the ye olde "designed for phones" indicator anymore as they assume we users are dumb.
    mustang7757 likes this.
    11-18-2019 05:22 PM
  10. mustang7757's Avatar
    The Tab S3 has Pie. What is probably the case like with many such apps is that it was intended for phones. Sadly, Google does not put the ye olde "designed for phones" indicator anymore as they assume we users are dumb.
    My bad , thought was s3 lol
    milleniumdroid likes this.
    11-18-2019 05:24 PM
  11. sta18ff's Avatar
    The S3 is not as old as my Droid Z Force, and the S3 is running Pie.
    11-18-2019 05:26 PM
  12. mustang7757's Avatar
    The S3 is not as old as my Droid Z Force, and the S3 is running Pie.
    For lag try in safe mode it will disable 3rd party app
    11-18-2019 05:28 PM
  13. me just saying's Avatar
    for a test, try downloading and play at a lower quality and see if you have the same problems.
    milleniumdroid likes this.
    11-18-2019 05:29 PM
  14. burrzoo's Avatar
    OK, I just installed Disney+ on my wifi Tab S3 & downloaded Revenge of the Sith. Took me a 1/2 hour. I had selected high quality in the settings for DL. I saved the video to a SanDisk Ultra 200gb.
    Only played 10 minutes of the movie but it played without any glitches whatsoever.
    I don't have a ton of apps installed & only D+ was being used when watching the video.
    11-23-2019 06:32 PM
  15. sta18ff's Avatar
    It's weird, because if I only download 1 or 2 movies (or stream them) it is fine. it is when I tried to download all 7 that I had issues. Seems to start around the point where I have 4-5 movies downloaded.
    12-04-2019 07:37 PM

Similar Threads

  1. [solved] Disney+ / gUDP / "loyalty gold"
    By dookie. in forum Verizon
    Replies: 3
    Last Post: 12-03-2019, 11:41 PM
  2. Disney+ Phone not compatible
    By rosend99 in forum Samsung Galaxy Note 10 & Note 10+ (2019)
    Replies: 68
    Last Post: 11-25-2019, 11:33 AM
  3. Galaxy A50 not compatible with Disney+?
    By Grifter73 in forum Samsung Galaxy A50
    Replies: 6
    Last Post: 11-19-2019, 10:12 AM
  4. Disney + not supported
    By jweimn in forum Google Pixel 4 & Pixel 4 XL
    Replies: 22
    Last Post: 11-16-2019, 06:34 PM
  5. Why wont Disney plus let me log in onto my lg smart tv?
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 11-16-2019, 12:44 AM
LINK TO POST COPIED TO CLIPBOARD