1. Gail Gurman's Avatar
    I have a relatively low data limit, so I keep my data usage turned off except when I'm away from home, and then only when I really need it. I also use the options in Settings to set a warning level and an artificial limit. Yesterday, I reached that limit, and my tablet (Tab E) turned data off, as expected.

    The problem is that, in the Notification list (the one you get when you swipe down from the top of the screen), there is a non-removable notification that says:

    Mobile data turned off
    Tap to enable.

    Is there any way to get rid of this without turning on data usage or turning off the warning level and limit?


    TIA
    09-23-2016 10:41 PM
  2. alwright1980's Avatar
    I RESEARCHED IT TO MY LIMITS TONIGHT! IT SHOULD BE VERY SIMPLE IF I ONLY KNEW THE NAME OF THE SYSTEM APP THAT GOVERNS MOBILE DATA USAGE AND RESTRICTIONS THEN I COULD DISABLE ITS NOTIFICATIONS.


    THAT SAID THERE IS AN OPTION OR 2 THAT ARE SLIGHTLY LESS ANNOYING.

    ONCE YOU REACH YOUR DATA LIMIT THEN YOU CAN RESTRICT BACKGROUND DATA. THIS WILL MAKE ALL PROGRAMS RUNNIGN IN BACKGROUND ONLY USE DATA ON WI-FI. tHEN BE VIGILANT OF NOT USING ANY DATA UNLESS YOU ARE ON WI-FI

    aNOTHER METHOD IS THIRD PARTY APPS. i READ OF TWO .GO SPEED AND ANOTHER BY SOMEONE NAMED INDIANA REDMOND I BELIEVE WHICH IS A WIDGET


    THE BEST ONE THOUGH I THINK FOR AN OPTION IS ONCE YOU REACH YOUR DATA LIMIT SWITHC ON AIRPLANE MODE. ALL IT SHOULD DO IS PUT A SMALL AIRPLANE IN YOUR BSAR NEXT TO YOUR BATTERY ICON THEN RE-ENABLE YOUR DATA AND SET YOUR USAGE LIMIT A HAIR HIGHER THAN YOUR WARNING LIMIT WHICH SHOULD BE SET ONLY 50MB OR SO ABOVE THE PREVIOUS USAGE LIMIT. THIS WOULD BE JUST IN CASE SOMETHINL WONKY GOES ON. IN ADDITION TO THIS YOU MIGHT RESTRICT BACKGROUND DATA AND NETWORKS. BUT NONE OF THE WONKY NOR THE RESRTICTIONS SHOULD BE NECESSARY AS AIRPLANE MODE SHUTS DOWN ALL MOBILE DATA BUT ALLOWS FOR WI-FI AS FLIGHTS ARE NOW EQUIPPED WITH SUCH SERVICES.
    09-23-2016 11:49 PM
  3. Codybraithwaite's Avatar
    Figured it out. Iv got the galaxy s7. Open ur Mobile data. Turn on mobile data. Switch the set data limit to off. Then turn your data back off.

    I then got a data usage warning notification. Swiped left, it disappeared and no more notifications 👌
    Why0hWhy likes this.
    10-28-2016 09:45 PM
  4. androider2016's Avatar
    Thank you worked perfectly for my LG phone.
    11-09-2016 05:39 PM
  5. selw0nk's Avatar
    That does not work for me when I try that 🙁
    12-11-2016 06:58 AM
  6. jaeladarling's Avatar
    I know this is an old post, but in case anyone else comes across this, I thought I might as well add this here.

    My Samsung Galaxy S6 Edge+ just updated, and I was having this same issue. Here is how I solved it.

    This is the message I was getting:


    20170411_234550.png


    If you do a slow right swipe (took me a couple tries to get it), you'll get this:


    How to remove "Mobile data turned off" notification from the notification list?-20170411_234525.png


    Tap the widget on the left, and you'll get:


    How to remove "Mobile data turned off" notification from the notification list?-20170411_234437.png


    Tap On lock screen / Show content, and you'll get:


    How to remove "Mobile data turned off" notification from the notification list?-20170411_234416.png


    Tap "Do not show notifications"


    Done!
    04-11-2017 11:58 PM
  7. Whitepupper's Avatar
    Thanks, a mixture of this and what codybraithwaite said worked for me
    Turn on data, go back to data usage and then to bill cycle, turn off the limit option, then it finally let me set app notifications to "do not show notifications".

    I really wish Google would cut this crap of trying to think of ways for people to always stay connected to data. I will NEVER just stay connected to data no matter how difficult you make it, all it does is make me absolutely despise Google/android, and Samsung phones, to where I'll just never buy them again. I swear every Android update my phone makes me do adds in something for no reason that, almost anyone else that I see discuss it, agrees is unwanted and annoying.
    Why0hWhy likes this.
    05-08-2017 03:55 PM
  8. CraibEmma's Avatar
    Was a. While ago you posted but I have switched mine off

    Settings, notifications , apps , carrier default app. Tap on the mobile data status , tap on importance and select low . It will disappear 😁
    blackmauser95 likes this.
    09-26-2017 04:09 PM
  9. blackmauser95's Avatar
    Was a. While ago you posted but I have switched mine off

    Settings, notifications , apps , carrier default app. Tap on the mobile data status , tap on importance and select low . It will disappear 😁
    I don't have anything that says mobile data status, or any importance list that I can set to low. also what do you mean by carrier default app?
    09-27-2017 02:18 AM
  10. leeofwestover's Avatar
    If you turn mobile data off through the data usage setting panel's cellular data switch rather than the mobile network setting then you don't get the notification. Even if you turned mobile data on through the mobile network setting panel, as long as you turn it off with the cellular data button in the data usage setting panel you will never get the message.
    01-19-2018 02:03 PM
  11. Why0hWhy's Avatar
    I agree with Whitepupper. I will (except in very unusual circumstances) Never Turn On Mobile Data Usage. Unfortunately, 3 times this year an update has done so in the background without informing or giving me the option not to. Resulting in all my phone credit being used up in a couple of days without my knowledge or permission. iow, google owes me $150! I have little money and so use a long life plan which only needs topping up once every six months. I do however have 24/7 access to wifi with unlimited download. Google has made it harder to accidentally disable mobile data, fair enough, but it uses all your mobile credit first before it starts using your unlimited already paid for wifi. They have also made it harder to turn mobile data off completely. It's like they are in cahoots with the telcos to make us spend even more or our hard won money.

    Apparently at least part of the intention of this update was to save on battery life. What I find drains battery life the most is that even when connected to a network the phone continues to search for other networks in the background indefinitely. There doesn't seam to be a way of stopping it form doing so. The battery lasts about 2 and a half to 3 days with wifi disabled, but only 1 day with it enabled. Being able to disable background wifi network scanning would save a lot of battery life. End of Rant ))

    FYI; Codybraithwaite's solution was the only fix which worked for me.
    06-29-2018 11:09 AM
  12. Jolie Cole's Avatar
    1. Go to settings

    2. Go to data usage

    3. Set limit higher than where it's at

    4. Change the apps that can use data in the background. Make sure apps can only use data over wifi unless it's necessary like text messages and phone calls.

    5. Make sure wifi calling is enabled
    The notification will not appear anymore
    08-14-2018 05:10 PM

Similar Threads

  1. Notifications
    By Mr.Mcgoo in forum Samsung Galaxy Note 7
    Replies: 12
    Last Post: 09-29-2016, 07:05 PM
  2. Android phone has all content hidden from lock screen
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 09-28-2016, 01:32 PM
  3. Replies: 2
    Last Post: 09-28-2016, 07:36 AM
  4. Opps turned off fast charging, need help
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-24-2016, 02:47 AM
  5. Is it legal to root a samsung galaxytab 4 10.1 in Canada
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-23-2016, 09:47 PM
LINK TO POST COPIED TO CLIPBOARD