1. AC Question's Avatar
    I'm on a Galaxy Tab 4, recently went to update Facebook, and it downloaded the update but never finished installing. Just said "installing" forever and then gave up. I wouldn't be concerned (there was still a working version of Facebook on the tablet), but after this happened it randomly rebooted in the middle of watching a YouTube vid, took forever, and then gave me an "Optimizing app 1 of 1" screen for 5 minutes before starting. Now every time I restart the tablet it does the same thing.

    Things I've tried:

    - Uninstalled Facebook through Settings, restarted and got "Optimizing app" screen. When the tablet started, Facebook was back (non-updated).

    - Tried clearing app cache and app data and then uninstalling FB & restarting. Optimizing app screen and FB was still there.

    - Tried wiping cache partition and then uninstalling FB & restarting. Optimizing app screen and FB was still there.

    - Tried uninstalling FB and NOT restarting, app won't re-install. Eventually got a "-504" error message saying app can't be installed.

    I've only found one person who had the same exact issue as me and they had no solution (on reddit). Thanks for any help!
    06-22-2016 03:06 PM
  2. Javier P's Avatar
    Welcome to the forums. Wow! You've tried everything on the book with no luck. It seems that some file got stuck in your phone after the failed update. You could try a couple of things.

    Boot into safe mode, go to settings - apps - select Facebook - force stop - clear data - uninstall and reboot.

    If no go download this a app

    https://play.google.com/store/apps/d....thedarken.sdm

    Then repeat force stop - clear data - uninstall and before rebooting open SD Maid and run the Corpse Finder option.

    Tell us how it goes.
    06-22-2016 03:26 PM
  3. Scanderoon's Avatar
    Okay, so booted in safe mode, cleared data & uninstalled. When I restarted, no more "Optimizing app" screen, and FB remained uninstalled - progress!

    However, re-installing is still unsuccessful. It's been sitting here "installing" for about 15-20 minutes now.
    06-22-2016 05:51 PM
  4. Scanderoon's Avatar
    Will attempt to install SD Maid. Right now it won't stop installing FB, so I may have to reboot again.
    06-22-2016 05:53 PM
  5. Javier P's Avatar
    Another thought. Do you have Facebook Messenger installed as well? If so, uninstall it. I remember reading some reports about this app giving problems when trying to install or update the main FB app..
    06-22-2016 06:14 PM
  6. Scanderoon's Avatar
    Aha, this also seems to be an issue.

    Rebooted, installed SD Maid, ran Corpse Finder which did find two facebook related items. Attempted to re-install FB, no dice. When I looked at Messenger in the App Manager, it wouldn't load the info about how much space it was taking up, and is currently stuck trying to un-install it.

    Oh, as I type it finally succeeded. Took a long time! Running Corpse Finder again, which has come up with another FB item. Deleted, will reboot for good luck and see what happens!
    06-22-2016 06:27 PM
  7. Scanderoon's Avatar
    Sigh. Messenger and Facebook are both uninstalled and Corpse Finder has taken care of leftover files. Tablet will start without the "optimizing app" screen, which is nice... but facebook will not install.
    06-22-2016 06:38 PM
  8. Javier P's Avatar
    It looks like Facebook released a bad update, one more I'd say Many people are having lots of problems with this app and I'm not sure what else to suggest mate. Maybe try with the Lite version or access your FB account from a browser until they release another update.

    And by the way, thanks for registering and welcome as a new member!
    06-22-2016 07:09 PM
  9. Scanderoon's Avatar
    Thanks for all your help! I guess I'll just do browser until the next update.
    Javier P likes this.
    06-23-2016 06:12 PM
  10. stestardi's Avatar
    I'm having exactly the same problem, but can't figure out how to get into Safe Mode. I've followed the steps here (How do I start my Samsung Galaxy Tab 4 in Safe Mode?), but the "Android is starting..." banner always displays and the device eventually shows the lock screen after ~5 minutes but it's not in Safe Mode. Do I have to hold the volume Down button the whole time "Android is starting..." is displayed?
    06-29-2016 02:35 PM
  11. stestardi's Avatar
    A little more detail on what I've tried.

    ​1. Uninstalled Facebook, Facebook Messenger and Pages Manager using Play Store.
    2. Force Stopped Play Store and cleared cache.
    3. Rebooted. Still got "Optimizing App 1 of 1." message.
    4. Reinstalled Facebook from Play Store. Noticed reinstall happened immediately without any download.
    4. Rebooted. Still got "Optimizing App 1 of 1." message.
    5. Tried uninstalling Facebook using User Apps page in ES File explorer. got a popus saying "Facebook Uninstalled", but the icon was still there when the screen refreshed.
    6. Rebooted. Still got "Optimizing App 1 of 1." message.
    7. Cleared Cache Data using the Settings app. Got a popup that said "Security policy restricts clearing of this apps cache", but the storage taken by the cache reduced from 550MB to 125MB.
    8. Rebooted. Still got "Optimizing App 1 of 1." message.
    9. Cleared Cache Portion using the Tab 4 recovery menu (see http://www.digitaltrends.com/mobile/...-mode-android/). 10. Rebooted. Still got "Optimizing App 1 of 1." message.

    Would appreciate any tips.

    Thanks!

    Steve
    06-29-2016 04:36 PM
  12. stestardi's Avatar
    Thanks for all your help! I guess I'll just do browser until the next update.
    Facebook has released a couple of updates since you had this problem -- have you been able to successfully install any of them?
    07-07-2016 11:30 AM
  13. B. Diddy's Avatar
    See response in your other thread as well: http://forums.androidcentral.com/sam...ml#post5255202
    07-08-2016 02:52 PM
  14. amaples93's Avatar
    I had the same issue for 5 months until today. Try disabling Google+ and then updating or installing. My phone took a long time and then it froze and closed out of Google play but when I went to try again I found it had updated!! I got the idea from another site.
    stestardi likes this.
    09-14-2016 11:46 AM
  15. stestardi's Avatar
    Thanks, @amaples93. How do I disable Google+?
    09-14-2016 12:01 PM
  16. stestardi's Avatar
    OK, I found out how to disable Google+ (https://www.androidpit.com/forum/590...oogle-plus-app for those who want to give it a try), but the problem persists.
    09-14-2016 02:03 PM
  17. LeSaint's Avatar
    Sorry but... Up?
    02-01-2017 06:59 PM
  18. cmjt's Avatar
    I am having the same trouble with Facebook on my Samsung tab 4
    It keeps showing download complete tap to install.
    Nothing I do will clear this. It finally installed version 113.......but then says it's out of date....but I can't update.
    Is this a Facebook problem or a Samsung problem?
    I wrote to fb and they won't reply.
    Would a factory reset help?
    It's 8/25/2017
    08-25-2017 10:03 AM
  19. SandieL's Avatar
    Factory reset won't fix it don't think or at least it didn't on mine. I'm having trouble with Facebook on my Samsung Tab 4. It keeps showing download complete tap to install. But won't update and now is saying no carrier for SM-T330NU. I did have FB until they made all these updates.
    09-02-2017 10:30 AM
  20. Jose Luis Arrieta's Avatar
    Been having the same problem for months now, only solution I could find is uninstall Facebook and then reinstall it after downloading the apk from any trusty repository. However next thing I'm doing after so much trouble with this tablet and the amount of bloatware it has even after factory reset is rooting it and wiping the Samsung ROM and getting a new more efficient running android OS
    11-03-2017 08:38 AM

Similar Threads

  1. EMUI 4.1 update for Huawei P8
    By andy_from_ireland in forum Huawei P8
    Replies: 4
    Last Post: 07-25-2016, 01:44 PM
  2. Replies: 2
    Last Post: 06-25-2016, 08:57 AM
  3. Marshmallow update live on Vodacom South Africa
    By jesade_reddy_q10 in forum Samsung Galaxy Note Edge
    Replies: 6
    Last Post: 06-23-2016, 02:41 PM
  4. Play store- won't open, any suggestions?
    By AC Question in forum Google Play Store
    Replies: 1
    Last Post: 06-23-2016, 01:19 PM
  5. How to copy text from .txt file and paste to another app?
    By Lili_K in forum General Help and How To
    Replies: 1
    Last Post: 06-22-2016, 03:48 PM
LINK TO POST COPIED TO CLIPBOARD