1. polo939's Avatar
    Hello,
    I recenly bought Samsung Galaxy watch and I decided to change default watchface. So I bought one from "Samsung Galaxy apps". I successfully installed this watchface, but it doesnt show the weather (temperature). So, I started investigation where can be the problem. After 3 days I gave it up. I am desperate, and I would like to ask you for help.

    Here is what I found out during the investigation... When I set some face, which was defaultly in watch, so weather (temperature) is displayed correctly and updated automatically. But when I switch to face (it doesnt matter which) from Galaxy apps, so weather (temperature) can not be updated (watch face shows still empty space). I set update interval for wether on 60 minutes.

    So, the conclusion is: weather (temperature) generaly works, but watch faces from Galaxy apps doesnt.


    I also tried to restarted phone and watch, but without success. I already dont see the light at the end of tunnel Could you please provide at least direction how to fix this issue?

    Thank you very much for your contribution in advance.

    OS: Android 6.0
    Phone: Huawei P8 Lite
    Smartwatch: Samsung galaxy watch (Tizen)
    Facer version: 4.6.4_98702
    09-28-2018 01:15 PM
  2. nofaithineli's Avatar
    Have you checked permissions under application settings for the problematic watch face? I had an issue where steps and heart rate were showing blanks and the "sensors" permission was toggled to off. Don't use a face with weather but wonder if it's a similar issue... maybe lacking a location permission?
    09-28-2018 05:40 PM
  3. polo939's Avatar
    Yes, I checked permission for watchface app. There is necessary to have permission to location - this is set ON.
    09-28-2018 06:39 PM
  4. Beempje's Avatar
    I had the exact same issue. After some searching, I figured it out. The weather on the watch face only uses the current location, not the preset ones you may have set. So in the setting of the weather app on your phone, you have to set it to use your current location, and it needs to have access to your phone's location services (GPS) to determine said location. Only then will it show up on the watch face.

    At least, that was the issue on mine. Hope this helps.
    10-02-2018 07:12 AM
  5. polo939's Avatar
    Hi,

    thank you for post. My weather app has access to GPS, so when I travel, so my current location is automatically updated. But this is still not enough Weather on non default watchface is not updated.


    I had the exact same issue. After some searching, I figured it out. The weather on the watch face only uses the current location, not the preset ones you may have set. So in the setting of the weather app on your phone, you have to set it to use your current location, and it needs to have access to your phone's location services (GPS) to determine said location. Only then will it show up on the watch face.

    At least, that was the issue on mine. Hope this helps.
    10-02-2018 08:15 AM
  6. MarineDawg's Avatar
    Have you tried a different face that also displays weather info? I had a Facer watch face on the S3 that didn't update but others that had no problems doing so. Essentially try and determine if this specific to that face only.
    10-04-2018 02:46 PM
  7. polo939's Avatar
    Yes, I have. I installed various faces from Facer and even from Galaxy apps.... without success.
    10-05-2018 06:05 AM
  8. jasonb725's Avatar
    Same problem here. I was able to do the following:
    Go into Galaxy Wearable app on phone
    Select Settings
    Select Apps
    Look for Weather and touch the "cog wheel" next to it
    Go into Settings
    Select Auto Refresh.

    Mine was set to never. I set it to the lowest increment available which is every hour.

    Hope this helps someone.
    01-04-2019 02:12 PM
  9. HowieDuck's Avatar
    BINGO, THAT'S the answer! I tried everything else but this is the only one that worked. Mine was set to never as well.
    Nostromo79 likes this.
    08-31-2019 02:32 PM
  10. Bob31464's Avatar
    Same problem here. I was able to do the following:
    Go into Galaxy Wearable app on phone
    Select Settings
    Select Apps
    Look for Weather and touch the "cog wheel" next to it
    Go into Settings
    Select Auto Refresh.

    Mine was set to never. I set it to the lowest increment available which is every hour.

    Hope this helps someone.
    I just got my watch today and came across this, I would've been pulling my hair, thanks for saving what little I have left!
    08-31-2019 06:13 PM

Similar Threads

  1. Replies: 1
    Last Post: 09-29-2018, 07:43 PM
  2. Replies: 5
    Last Post: 09-28-2018, 02:56 PM
  3. AT&T users, update today
    By fwaits in forum LG V30
    Replies: 1
    Last Post: 09-28-2018, 01:48 PM
  4. Samsung galaxy 8s camera replies out?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-28-2018, 12:58 PM
  5. Samsung Verizon Update 2 days ago
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-28-2018, 11:47 AM
LINK TO POST COPIED TO CLIPBOARD