1. Android Central Question's Avatar
    this has been a problem on other samsung watches as well. you answer a phonecall and the watch is automatically the primary speaker and microphone, so it pretty much answers on speakerphone. the s3 had an option in the settings, but the galaxy watch doesn't seem to have any such option.

    there is an option after you have answered the phone call to then take the call on the phone, but since talking to your watch is almost never desired - I don't want to even have to quickly press the (take call on phone) button on the watch.
    01-23-2019 11:18 PM
  2. B. Diddy's Avatar
    I moved this to the Galaxy Watch forum for more specific traffic.
    01-23-2019 11:52 PM
  3. NIckkr's Avatar
    this has been a problem on other samsung watches as well. you answer a phone call and the watch is automatically the primary speaker and microphone, ....
    That's kind of the point of the watch ! If you pick up the call via the watch the logic assumes that is the method you are going to use to facilitate the call. Why would it be otherwise?

    HOWEVER .... I don't really like using my watch like some kind of latter day Dan Dare so when a call comes in and the watch displays the incoming call I invariably just answer it on my phone.
    Similarly when a call comes in whilst I'm driving I just elect to pick it up on the in car system.
    It all seems to work seamlessly.
    01-24-2019 01:16 AM
  4. chrisprattmt2's Avatar
    That's kind of the point of the watch ! If you pick up the call via the watch the logic assumes that is the method you are going to use to facilitate the call. Why would it be otherwise?

    HOWEVER .... I don't really like using my watch like some kind of latter day Dan Dare so when a call comes in and the watch displays the incoming call I invariably just answer it on my phone.
    Similarly when a call comes in whilst I'm driving I just elect to pick it up on the in car system.
    It all seems to work seamlessly.
    but even if I answer the call from my phone, the watch bluetooth is chosen as the default handset as soon as you answer the call. you have to manually change it EVERY SINGLE TIME you answer the phone.
    01-24-2019 12:14 PM
  5. watchki's Avatar
    If you pick up the call via the watch the logic assumes that is the method you are going to use to facilitate the call.
    01-25-2019 01:44 AM
  6. nofaithineli's Avatar
    but even if I answer the call from my phone, the watch bluetooth is chosen as the default handset as soon as you answer the call. you have to manually change it EVERY SINGLE TIME you answer the phone.
    That sounds like a pain and is abnormal. Unfortunately I don't know how to solve your problem never having experienced this issue myself.
    01-25-2019 08:57 AM
  7. steve cooper's Avatar
    you can do it by going into the Bluetooth settings for Galaxy watch on your phone and uncheck phone audio. that's how I did it in my s3 and now my GW
    01-27-2019 12:13 AM
  8. PMenzies's Avatar
    I just tried that as well, but the connect is then lost. As soon as re-connect, phone audio is back on
    Bababenny likes this.
    02-14-2019 05:52 AM
  9. Berne van Rooyen's Avatar
    I just tried that as well, but the connect is then lost. As soon as re-connect, phone audio is back on
    Have you come across a fix for this yet? I have the same issue and it's super annoying!!
    I have thew Note9 and in my Bluetooth settings the Icon for the watch is a bluetooth earpiece and not a watch?!
    Bababenny likes this.
    05-09-2019 07:09 AM
  10. Whyze's Avatar
    Have you come across a fix for this yet? I have the same issue and it's super annoying!!
    I have thew Note9 and in my Bluetooth settings the Icon for the watch is a bluetooth earpiece and not a watch?!
    Same here. I thought for sure this was a basic setting I was missing, but after spending a fair amount of time digging around settings it seems there's no way to just stop this silliness.

    This is on my Galaxy Note 8.

    I don't want/use my watch for anything phone call related. I use it for activity tracking and notifications primarily.


    A similar (but perhaps unrelated) issue with with connecting to bluetooth speakers. Sometimes (but not always??) the music will stop playing if I walk out of range of my phone (the phone is near/connected to the bluetooth speaker and within wifi range). Sometimes it starts again when I get back in range, but usually not. Super annoying when I'm doing yardwork and have the speaker loud enough to hear for a good range but out of bluetooth range.

    I don't mind the idea of being able to control music from the watch, I just want it to not automatically stop music based on the watch's connection to my phone.
    07-29-2019 03:03 PM
  11. Mathrania's Avatar
    For me, if i answer through watch, the speaker on watch works, but if i answered via phone, i use the phone to speak, nothing is heard on the watch....
    08-02-2019 11:52 AM
  12. Rotemshi's Avatar
    For me, if i answer through watch, the speaker on watch works, but if i answered via phone, i use the phone to speak, nothing is heard on the watch....

    Same here with Samsung watch active 2.
    I cannot make calls, every time I call I don't hear a thing, both phone and watch doesn't make sound.
    So frustrating.
    10-16-2019 03:52 AM
  13. Rohit Kottamasu's Avatar
    Same here with Samsung watch active 2.
    I cannot make calls, every time I call I don't hear a thing, both phone and watch doesn't make sound.
    So frustrating.
    I have a fix for this. Go to settings-> Appsand notifications -> App permissions -> Telephone permissions

    After going here disable galaxy wearable permission. Then try re connecting your watch. Now you get notifications on watch and if you address them on the phone it will automatically set to phone. When you answer in the watch it will automatically be set to Bluetooth. Job done.

    Hope this helps
    Cheers
    10-17-2019 12:49 PM
  14. shleeven's Avatar
    I have a fix for this. Go to settings-> Appsand notifications -> App permissions -> Telephone permissions

    After going here disable galaxy wearable permission. Then try re connecting your watch. Now you get notifications on watch and if you address them on the phone it will automatically set to phone. When you answer in the watch it will automatically be set to Bluetooth. Job done.

    Hope this helps
    Cheers
    This DOES NOT work. At least on S10+, there is no "telephone permissions", there is "phone" which is the phone app itself. If you go to the Galaxy Wearable app in the permissions and toggle off the Phone permission, it will simply tell you that you can't use the galaxy watch any more until permissions is fixed.

    My problem is similar to others in this thread but a little different. If I have my Galaxy Watch connected, and I turn on my bluetooth headset, in the bluetooth menu my watch will be set for "calls" and my headset will only be set to "media" and it will not allow me to move the slider to the on position for calls. I can fix this by unpairing the watch and the headset, then pair the headset and it will default to "calls and audio(which is what it should ALWAYS do), then I connect my watch, and it will also show "calls" in the bluetooth menu, but if I answer a call on the watch, it will send the audio to the headset, which is ABSOLUTELY how it should work.. However, then if I turn my headset off and back on, it go back to showing only media audio in the bluetooth menu and won't let me turn on calls, forcing me to unpair and repair both devices. This is EXTREMELY annoying on my headset(Sennheiser Presence) which is made to easily turn on and off, end/answer calls, etc. by sliding the mic boom, which now doesn't work. Really hoping someone has a working fix for this.
    12-16-2019 05:11 PM
  15. adegbenroagoro's Avatar
    this has been a problem on other samsung watches as well. you answer a phonecall and the watch is automatically the primary speaker and microphone, so it pretty much answers on speakerphone. the s3 had an option in the settings, but the galaxy watch doesn't seem to have any such option.

    there is an option after you have answered the phone call to then take the call on the phone, but since talking to your watch is almost never desired - I don't want to even have to quickly press the (take call on phone) button on the watch.
    Could this be of any help?
    Attached Thumbnails Samsung Galaxy Watch: how to prevent watch from taking calls by default-4544.jpg  
    12-18-2019 02:32 AM
  16. EScahill's Avatar
    this has been a problem on other samsung watches as well. you answer a phonecall and the watch is automatically the primary speaker and microphone, so it pretty much answers on speakerphone. the s3 had an option in the settings, but the galaxy watch doesn't seem to have any such option.

    there is an option after you have answered the phone call to then take the call on the phone, but since talking to your watch is almost never desired - I don't want to even have to quickly press the (take call on phone) button on the watch.
    I am having the same problem with the HTC 10. It's so annoying. It didn't do it when I first set everything up. But I toggled the bluetooth connection settings on my phone for phone audio to try and get my bluetooth headphones to work better with the other two devices and ever since I've toggled the settings back I have this problem with the watch.
    01-18-2020 06:54 AM
  17. JoelSandler's Avatar
    Has a solution been found? I have a Pixel 2 and when I have a call in a call (call waiting) and I answer the second call, it opens on my watch
    02-04-2020 04:07 PM
  18. Dazr33's Avatar
    I had this problem on my Galaxy S10 5g, and couldn't for the life of me work out how to stop it. I even had a tech support chat with Samsung in which they couldn't help.

    I solved it by doing a factory reset on my phone and watch (which is a pain in the arse setting everything up again, as i didnt want to drag old phone data from a backup, so started everything like new). Anyway its working properly now, and call is made on whatever device you called from/answered with. Hope this helps.
    02-08-2020 10:50 PM
  19. mdezrin's Avatar
    This seems to be a new issue. No, resetting my phone is out of the question. I've had my Active 2 paired with my Pixel 3 for over 2 months with no problem. This problem started today.

    The issue is your watch has become the priority "speaker" even when you answer the call on the phone. Prior to today, answering the call via the phone kept me on the phone or a bluetooth enabled headset or the car and answering on the watch kept the watch as the priority. Now, the watch always has priority.

    I don't want to block the watch from calls as it is ok to see the call coming in on the watch and then decide to take it or not take it. I just want the watch to not be the priority.
    Bababenny likes this.
    02-09-2020 05:51 PM
  20. QWKSNKE's Avatar
    maybe reboot the watch. I restart mine every few weeks
    mdezrin likes this.
    02-21-2020 09:00 PM
  21. mdezrin's Avatar
    I closed the watch app, rebooted the phone and it seemed to go away.
    02-22-2020 10:52 AM

Similar Threads

  1. How do i stop android tablet from locking when it detects physical keyboard detaching
    By Android Central Question in forum Samsung Galaxy Tab S4
    Replies: 3
    Last Post: 03-10-2019, 02:49 PM
  2. Will "Android One" phones work with USB to HDMI adapters?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-24-2019, 12:52 PM
  3. No calls or data activate
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-24-2019, 02:02 AM
  4. Unable to update any apps from google play store
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-24-2019, 02:01 AM
LINK TO POST COPIED TO CLIPBOARD