1. Marioawe's Avatar
    Hello!
    Despite my efforts, my Gear Live watch is refusing to turn on. I've gone through customer support and achieved no success (obviously, that's why I'm here) except the offer to pay a fee and send it back which I might take up that offer but I would like to see if anyone else has the same problem or any solutions before I shell out money for that.

    So far I've:

    -Let it sit on a wall charger for 3 hours
    -let it sit connected to my laptop for about the same amount of time
    -cleaned off the charger and contact points on the back of the watch, no corrosion to either (in fact, the watch is in nearly new condition minus my numerous fingerprints :P)
    -tried three different cables and wall chargers
    - opened up the watch, reseated the battery, put it back together and tried again, still to no avail
    - opened it again, took out a multimeter, got nothing the first time charging it, second time after charging it, it showed 3 volts.

    I'm at a loss as it looks as if it were just bought from the store, no damage or anything to the watch anywhere and it didn't seem to show damage from water or sweat. Any help is appreciated, thanks!
    02-14-2017 08:50 AM
  2. B. Diddy's Avatar
    Moved to the Gear Live forum.
    02-14-2017 10:54 AM
  3. Marioawe's Avatar
    Didn't know this forum existed, thank you very much, hopefully someone knows what's up with my device here.
    02-14-2017 10:57 AM
  4. Marioawe's Avatar
    Got a reply from a different forum, said the initial charge can take over a day, I'll update this post if anything else happens.
    02-15-2017 02:20 PM
  5. Marioawe's Avatar
    After 24 hours...nothing, so I took apart, measured it again, still getting .3 volts, which would translate to 300 mAh, the maximum capacity for the watch, so its not a battery problem, leading me to believe something on its motherboard(?) has a problem, possibly. Anyone have any thoughts?
    02-15-2017 08:21 PM

Similar Threads

  1. Replies: 1
    Last Post: 02-23-2017, 11:34 AM
  2. Replies: 2
    Last Post: 02-21-2017, 08:21 AM
  3. No more metadata using google music or Amazon Prime music
    By rdjr74 in forum Motorola Droid Turbo 2
    Replies: 2
    Last Post: 02-17-2017, 11:22 AM
  4. Why can't i control my Gear Fit 2 remotely?
    By sheepbeautiful2 in forum Samsung Gear Fit 1 & 2
    Replies: 1
    Last Post: 02-14-2017, 10:55 AM
  5. Can not reply or send sms?
    By hoan nguyen1 in forum Samsung Gear S2
    Replies: 0
    Last Post: 02-14-2017, 07:08 AM
LINK TO POST COPIED TO CLIPBOARD