1. Oj467's Avatar
    So I had an all day meeting today at Nemacolin resort (Southern PA near the WV/OH border) - yes I know poor me.

    Anyway I'm on VZW and my S2 is the 3G version and I didn't realize it must have been searching for a cell signal the whole time (VZW coverage in that area is apparently pretty poor) and was almost dead by lunchtime.

    Is there a way to turn off the cell feature but still get the BT notifications on it? Seems like airplane mode turns everything off.

    Thanks.
    10-20-2016 07:15 PM
  2. Smith 001's Avatar
    hi,could you find the working frequency?in settings,just disable it.
    EDIT:in developer settings,I disable the unusual working frequency on my D5+.Anyway its battery life seems a bit longer.
    10-20-2016 09:15 PM
  3. johna22's Avatar
    I had this happen to me the other day too when I was in a building and couldn't get signal. If you go into Settings, Connections, Mobile Networks you should be able to switch Gear Network to Auto Switch instead of Always On. This should turn off your cell radio as long as you are connected to Blue Tooth and help save battery when you are in a bad cell area.
    skatergirl likes this.
    10-26-2016 01:40 PM
  4. skatergirl's Avatar
    I had this happen to me the other day too when I was in a building and couldn't get signal. If you go into Settings, Connections, Mobile Networks you should be able to switch Gear Network to Auto Switch instead of Always On. This should turn off your cell radio as long as you are connected to Blue Tooth and help save battery when you are in a bad cell area.
    The gentleman in this video suggested the same thing

    http://forums.androidcentral.com/sam...e-gear-s2.html
    11-03-2016 08:15 AM
  5. Bob31464's Avatar
    You might also check the watch face you're using. Normally after 12 hrs I still have about 45% left, today I used a different watch face and was down to 8% in less than 9 hrs. Btw, mine is the BT only version.
    skatergirl likes this.
    11-04-2016 08:33 PM
  6. Aaron_Jones's Avatar
    I have the stand alone version and I get 2 1/2 days on my S2. I followed the direction of a youtube video and it made a world of difference.

    I turned my screen brightness to 2
    Turned off WiFi
    Turned off NFC
    I keep apps closed and not running in the background
    after these adjustments I get way more battery life. You may need some of these things turned on that I keep off so it may not work for you. I turn on my WiFi when I need it and turn it off when I don't. I dont use NFC at all. I see very well with brightness at 2. I work in a factory so this is ideal for me. I have found some really cool apps to use with my S2 as well. I mostly use it for notifications for text and emails. I get alerts all day long and still have great battery life. Oh yeah, my volumes - ringtone 0, media 15, notification 0, and system 0.

    11-08-2016 08:13 PM
  7. Aaron_Jones's Avatar
    I charge my watch when I get home from work about 8pm in the evening so it is ready to record my sleep and it takes about a little less than an hour to charge to 100% from down toward 10 to 15%. After going through the night and the next day I'm at 68% around 9pm.
    11-13-2016 11:48 AM

Similar Threads

  1. where to find pink?
    By ansa82 in forum LG V20
    Replies: 3
    Last Post: 10-21-2016, 11:45 AM
  2. Replies: 2
    Last Post: 10-20-2016, 11:29 PM
  3. Can't Connect to Hidden SSID
    By Cainamzak in forum Motorola Droid Turbo 2
    Replies: 1
    Last Post: 10-20-2016, 07:30 PM
  4. Replies: 0
    Last Post: 10-20-2016, 05:06 PM
  5. Trying to boost Volume on Samsung Galaxy S3
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-20-2016, 05:05 PM
LINK TO POST COPIED TO CLIPBOARD