1. koojo's Avatar
    Hey everyone, I have the S2 bluetooth version and since the newest update came out recently, I've been having issues loading it to the gear. The update downloads fine on the phone eand loads the file onto the watch, but when the watch starts to process the file and counts up the % from 0 to 100, it will reboot every time it gets to 14%, never completing the update. I've tried the process at least 15 times. Did a factory reset numerous times, with and without restoring my data, as well as tried to download and install the update from another phone. Nope, always gets stuck at 14% and reboots. I brought it to Best Buy and the Samsung rep couldn't figure out what to do and told me to call Samsung service line again. I'm guessing they're going to have me send out the device, so I'd rather not do that if avoidable. Otherwise the watch works great without the update. Any ideas?
    12-20-2016 07:59 PM
  2. Stephen Cooper2's Avatar
    Hi i am having the exact same problem and tried everything. Have you found a fix??
    02-21-2017 11:04 PM
  3. koojo's Avatar
    I had to send the watch to Samsung service. They ended up replacing the battery, the screen, and updated the watch.
    02-22-2017 05:30 AM

Similar Threads

  1. Samsung Pay not available on my S3 or gear manager
    By Fasttrak2010 in forum Samsung Gear S3
    Replies: 17
    Last Post: 12-26-2016, 07:32 PM
  2. Replies: 3
    Last Post: 12-23-2016, 09:56 AM
  3. Unable to upgrade my HTC 826 to Android M via OTA updates
    By prateek23 in forum Android 6.0 Marshmallow
    Replies: 2
    Last Post: 12-22-2016, 03:14 AM
  4. I hope the Nouget Update fixes Dim Photos you use with the Always On Feature
    By catloverplayer in forum Samsung Galaxy S7 edge
    Replies: 2
    Last Post: 12-20-2016, 06:21 PM
  5. Not receiving beta update 7.1.1 for Nexus 6
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 12-20-2016, 05:04 PM
LINK TO POST COPIED TO CLIPBOARD