1. FF22's Avatar
    Suddenly last week they seemed to have lost their connection. Not sure what happened and I might have over-reacted. The watch wound up rebooting and lost everything. What's interesting is that I seem to have recovered a memo or two.

    Now when I reboot, I get a screen with Accessibility or ? (question mark). If I follow the prompts, it wants me to choose language but I don't get beyond that. I can't exit out of that screen/mode using either of the two buttons.

    If I choose ? then I am able to set up the watch without connecting to phone. I can setup wifi. If I use settings to connect to the phone I'm back on the English language loop - which I've now done about a dozen time (not kidding).

    I lost my favorite watch face and can't seem to find it on their site.

    Ideas on re-pairing. At least, I can now see the time, weather and heart rate!!!

    Oh, I have done both the reboot and gotten the Menu series including Recovery and about 3 other choices. Nothing has worked there either.

    Oh, and accidentally enabling the screen reader almost drove me over the edge - I wanted to stomp on the watch. Took forever to undo that mistake!
    10-15-2021 01:19 PM
  2. B. Diddy's Avatar
    Did you already try doing a factory reset of the watch?
    10-15-2021 05:08 PM
  3. FF22's Avatar
    Did you already try doing a factory reset of the watch?
    Yes. I still get stalled at the Language prompt. It will not move out of or beyond that screen.
    10-15-2021 11:23 PM
  4. FF22's Avatar
    Watches say the darnest things...

    I figured I'd come back. Every time I swiped right on the watch I'd get a prompt - do you want to connect to your phone. Yeah, yeah, that's what I got three weeks ago. But today I figured what the ...

    So I acknowledged the prompt. Ran Samsung Wear on the phone this time it connected. No language prompt or other crap like that. I did take a series of hoops but suddenly I was back in business. I even went to far as to reinstall Samsung Pay. That took another half dozen hoops and a call with my credit card company.

    I don't know what planets aligned today but.... It seems to be working. (fingers crossed)
    B. Diddy likes this.
    10-29-2021 11:42 PM

Similar Threads

  1. Google Maps navigation with screen off no longer works
    By Gary02468 in forum Samsung Galaxy S21 & S21+ & S21 Ultra
    Replies: 9
    Last Post: 11-30-2021, 06:50 AM
  2. Just received 3 in today..2 Classics and a Watch 4
    By Ranjen617 in forum Samsung Galaxy Watch 4
    Replies: 8
    Last Post: 10-27-2021, 11:39 AM
  3. SIMs, GPS Errors, and Proprietary Apps
    By Jeremy Crockett in forum Ask a Question
    Replies: 2
    Last Post: 10-16-2021, 08:04 PM
  4. Galaxy S4 mini and Covid-19
    By Android Central Question in forum Ask a Question
    Replies: 6
    Last Post: 10-15-2021, 05:04 PM
  5. where can i buy a s21 ultra with snapdragon?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-15-2021, 03:53 PM
LINK TO POST COPIED TO CLIPBOARD