1. NeverBenFamous's Avatar
    Hi, I have a Galaxy S7 Edge and a Gear S3 Frontier on AT&T. The Contacts app in the watch shows only myself under "My Profile" and no other contacts. I have plenty of contacts on my phone throughout various accounts. I can't figure out how contact sync to the watch is controlled... There seem to be no options for it in the Gear app.

    Anyone know how to get my contacts to sync over?
    01-03-2017 12:18 PM
  2. jackstrap1's Avatar
    Yeah same issue here.

    I can't see sms or contacts via watch, but all on phone. I can see emails though.

    Anyone have an ideas?
    02-19-2017 04:11 PM
  3. Jaycemiskel's Avatar
    I can see mine. Are your contacts stored on your sim or on your phone? That's the only thing I can think of. Mine are stored on my phone.
    02-21-2017 02:32 PM
  4. afblangley's Avatar
    Contact syncing is somehow tied to our Samsung account. If that's not correct, the watch will pair via BT but contacts will be empty. Try doing a soft reset on the watch (settings -> connect to new phone). This erase apps and make the watch do a fresh pairing with the phone, including re-login into your Samsung account.
    02-23-2017 06:13 PM
  5. Kfkopacz's Avatar
    I have a S6 phone and the S3 frontier. I have been trying weeks to get my contacts and calendar to sync. I did a factory reset on the watch and repaired the phone today with no results. The Gear 2 had no issues. Any help? I checked my google account and everything is set to sync.
    02-25-2017 02:58 PM
  6. jackstrap1's Avatar
    I tried a soft reset and a hard reset of the gear s3 and the contacts are still not showing.

    The phone (s7) has the Samsung account linked and the phone has contacts set to sync.

    No idea why this is not working.
    02-26-2017 06:24 PM
  7. afblangley's Avatar
    I haven't experienced this problem, so I'm just throwing out ideas... If you have access to a spare phone, try pairing the watch to it.
    02-26-2017 09:03 PM
  8. Blademarceyz's Avatar
    I got my contacts to sync by going into the samsung messages app (the one that is default on the samsung phones) and allowing it to access my contacts (giving permission) you don't have to select it as your default messaging app so if you tap "no" you can still get into the app and it will ask permission to access your contacts tap "allow" and then disconnect your gear with the gear app and then reconnect. Worked for me.
    08-16-2017 06:15 PM
  9. Janus Dimitri's Avatar
    I had the same problem until i tried opening phone instead of contacts, then everything synced
    11B1P likes this.
    08-18-2017 11:43 AM
  10. zsfulep's Avatar
    I had a similar problem recently after I updated software both on Samsung Gear S3 watch and on my phone Huawei P Smart - Samsung Wearable app. My contacts disappeared from the watch.
    To be on the safe side I made a backup of the watch with the Samsung Wearable app before the update. My plan was that after the update I can restore my watchfaces and screens automatically.
    When I finished the process my watch showed only 2 out of 300 of my contacts.
    I tried to reset and pair again the watch with the Huawei phone and restored again from backup. Same wrong result.
    I tried to pair with my Apple iPhone 5S - I was able to see all of my contacts. Strange.

    Then I realised that I did not do the restore from iPhone as I did not make a backup before on it.
    So next time I paired the watch with Huawei phone again and SKIPPED restoring configuration and tada: I can see all of my contacts. However I have to set up again my watchface and screens from the scratch.

    So as I can see backup/restore function of Samsung Wearable is not properly working when restore a backup prepared with a former version of the app. Funny but I was expecting that a backup can be used to migrate my configuration to new versions. So it isn't.

    I hope it helped for others having similar problems.
    P.S: check permissions for reading contacts and phone calls when it is requested.
    02-26-2019 05:16 AM
  11. Barry Shrum's Avatar
    This problem starting happening to me after the last update to my watch. It is a Samsung issue that needs to be updated. Prior to the update, I did not have this problem. I've tried resetting the database (in Galaxy Wear), opening Messaging, all of the suggestions (except for a hard reset). If anyone (who is actually experiencing the problem) comes up with a real solution before Samsung fixes the problem, please alert us.
    03-04-2019 04:59 PM
  12. HaRDKNoC614's Avatar
    Settings, Accounts and Backup, Samsung Cloud

    Backup contacts

    Open contacts

    Delete all contacts

    Go back to samsung cloud and restore contacts

    Thank me later!
    03-08-2019 07:06 PM
  13. Philipmom's Avatar
    Well it fixed it but not before my watch went into a boot loop and forced reset and now waiting until Monday to reset Samsung pay with my bank. But it does show contacts again. Odd that I did a reset prior to this and synced all my contacts and it didn't work that time. Finicky thing lol.
    03-09-2019 08:48 AM
  14. lyingfromyou's Avatar
    I had recently got the S10+ and after setting everything up, the Gear Wear app said Update needed before it could connect to my watch.. I did that and it forced a reset on my watch..

    I am also having the same issues with my contacts.. I have a few, but it doesn't match up with what my phone shows. The weird part is everything was working fine until the Gear Wear app updated!

    I have tried the methods above and they did not work for me
    03-09-2019 09:14 PM
  15. Behzad Shabrandi's Avatar
    It works! Tnx
    Settings, Accounts and Backup, Samsung Cloud

    Backup contacts

    Open contacts

    Delete all contacts

    Go back to samsung cloud and restore contacts

    Thank me later!
    04-08-2019 10:45 AM
  16. laxd17's Avatar
    I had the same issue after an update. Samsung told me to do a reset and when that didn't work they told me I had to send my watch in for repair.

    I figured it had something to do with the permissions getting messed up after the last update, not something that needed to be repaired. So after hours of trying to figure this is out what worked for me was uninstalling and then reinstalling the Samsung Wearable app but the key is that after uninstalling the app you have to dig into your phone and uninstall the Gear PluggIns as well.

    I tried resetting the watch numerous times (which at this point I'm not sure is necessary for this to work) as well as uninstalling and reinstalling the app a number of times. Nothing changed, every time I reinstalled the app it reconnected as though it had never been uninstalled. The last time I tried I went through and uninstalled the Gear PlugIns before reinstalling.

    When I reinstalled the Samsung Wearable app it prompted me to allow a number of permission (as it did the first time I installed it). After allowing all of the permission and logging into my Samsung account all of my Contacts were loaded to my watch again.

    It's very frustrating that this seems to be caused by the Samsung update and then Samsung support just defaults to 'reset...if that doesn't work send it in to be fixed' but the key for me was uninstalling the Samsung Wearable app and uninstalling the Gear PlugIns on my phone, reinstalling the app and then allowing the permissions the app prompts for after the reinstall, which included allowing access to contacts.
    04-11-2019 01:22 PM
  17. pizza_pablo's Avatar
    I have one particular contact that periodically falls off of both my Gear S3 and my Gear Sport. Sometimes a watch reboot foxes it. Aubergine I have to do the Samsung Cloud contacts backup > delete > restore.
    Usually, I just wait a day or two and he comes back. Odd behavior.
    10-06-2019 06:05 PM

Similar Threads

  1. Wifi permanently on
    By Blessedwalnut in forum Samsung Galaxy S7
    Replies: 3
    Last Post: 01-09-2017, 10:59 AM
  2. how do i text a photo on my zenfone
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-04-2017, 02:26 AM
  3. My max pro 4x will not turn on
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-04-2017, 02:22 AM
  4. Replies: 0
    Last Post: 01-03-2017, 10:34 AM
  5. In theme chooser, fonts are not getting applied.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-03-2017, 10:33 AM
LINK TO POST COPIED TO CLIPBOARD