1. jeffgus's Avatar
    I tried to use the Sprint Navigator on my Moment this evening. It kept telling me to turn because it thought I wasn't on the freeway. I also have a Pre and it seemed to be working just fine. Is there possibly something wrong with my Moment? Has anyone else had issues with the GPS function?
    11-11-2009 04:34 AM
  2. artsd's Avatar
    I also had issues using Sprint Nav. I was traveling on an interstate (divided highway). The system thought I was on a parallel road that was at least 100 feet away. Eventually it figured it out. Once I got off the interstate, it actually did better on the surface streets.
    11-11-2009 10:40 AM
  3. jeffgus's Avatar
    My Pre doesn't have this problem. The Navigation program usually right on. I am just trying to figure out if my Moment is broken or if Moments suffer from bad GPS reception.
    11-11-2009 02:01 PM
  4. jeffgus's Avatar
    Okay... something is really wrong here. Half of the time Google maps just puts the marker in the center of the default map. I have to talk outside to get anything close to an accurate reading. Inside a car it is almost useless since the accuracy is off enough to make the GPS think I am on the wrong street.

    Is there something I am missing here?
    11-11-2009 03:47 PM
  5. jeffgus's Avatar
    I found the problem! Android 1.5 does not support AGPS (assisted GPS) on CDMA networks. The Moment runs.... Android 1.5! So this is going to be a problem until Samsung updates the firmware. Hopefully sooner than later because without AGPS, Sprint Navigation is almost useless unless the phone is right up against the car window.

    Sprint Community : Samsung Moment not reporting correct...
    11-11-2009 07:11 PM
  6. dannzeman's Avatar
    I just tried using gps for the first time today and it was really bad. I tried using it with Google Maps and Waze. Google Maps was horrible, it wasn't even close to getting my position. It would put me up to 2-3 streets off at some points. Waze wasn't nearly as bad, it always had me on the correct street but with both apps it seemed like it took forever for the gps to update my location.
    11-11-2009 08:28 PM
  7. ranman's Avatar
    Yes it wont work in the 1.5 version tech told after several inquiries ..properly needs 2.0
    12-23-2009 10:03 PM
  8. dpc111's Avatar
    My Pre doesn't have this problem. The Navigation program usually right on. I am just trying to figure out if my Moment is broken or if Moments suffer from bad GPS reception.
    Ditto! I have a Moment and a Pre and the Pre is spot on. The Moment can't even find the damned sats.
    12-25-2009 08:55 AM
  9. rd2kdreams's Avatar
    lol, i had this same problem as i was traveling home for the holidays..GPS picked up everything else but the highway i was on.
    12-27-2009 10:46 PM
  10. flexxor's Avatar
    It *might* be a little wait for an update, you may have seen last week Sprint released that they would be updating to 2.1 for the Hero and Moment, but the time frame was vague saying the first half of 2010. (I really hope it's sooner than June).
    12-28-2009 11:12 AM
  11. SirThale's Avatar
    Sprint released an update today for the Moment, with part of the update being GPS functionality. It's not Android 2.1, but it might help. You have to take the phone to a Sprint store to get the update though.
    01-15-2010 11:51 AM
  12. brijahn's Avatar
    Sprint released an update today for the Moment, with part of the update being GPS functionality. It's not Android 2.1, but it might help. You have to take the phone to a Sprint store to get the update though.
    How would one know if their phone needs the update? Is there a version number to reference?
    03-18-2010 06:16 PM
  13. arwild01's Avatar
    I expect the original poster was referring to the CL14 update... which recent phones have been shipping with. To confirm if you have it, go to Settings->About phone your build number should say "CUPCAKE.CL14". If not, you don't have the update.
    03-18-2010 11:28 PM
  14. hepkitty's Avatar
    I'm also having issues with the GPS. Only it's not finding me at all....
    I just got my phone a few days ago. I looked to see what my build was and I'm "Cupcake.CJ05". I wonder if this is the root of all of the problems I'm having.
    I've tried to update the phone a few times now, and it tells me it can't connect.
    Oh well.....
    03-19-2010 08:47 AM
  15. robbies7897's Avatar
    I personally haven't had any issues with GPS. I just use google maps to find my location and it has been spot on every time. Not sure if its something to do with the firmware or not (CL14 out of box). Just thought I'd chime in lol.
    03-26-2010 02:09 AM
  16. kidafrika's Avatar
    Settings|Security & Location >> Turn off "Use wireless networks"

    I turned this off and instantly got way more accurate GPS location.
    03-27-2010 09:56 PM
  17. Tommy3141's Avatar
    GPS on my unit is terrible. I have never owned any GPS with reception this poor. Samsung has failed with this phone and also the Epic. Cool features, essentially no GPS. Samsung should be ashamed.
    09-03-2010 10:28 PM
  18. mouseglider's Avatar
    My GPS simply got worse little by little until there was none - Sprint gave me a factory refurb and now it is just superb! - and I tested against a new Evo which I think has the best gps and a new Epic at a Sprint store for about an hour - I downloaded GPS Test on the Sprint store phones as I already had it on my phone, and they all tested as expected - and what better test facility with no other variables since all there phones were within a foot from each other - I am happy as a clam :-)
    09-13-2010 09:06 PM
LINK TO POST COPIED TO CLIPBOARD