1. elementfiftyfour's Avatar
    Few days ago I tried to download a couple games to my phone from the marketplace. I can browse and check out the detailed info from the marketplace fine but when i attempt to download i get an indication popup that states "Download Unsuccessful."

    So far i have tried resetting the power, removing the battery for a few minutes, reformatted the SD card but nothing works as of yet.

    Any suggestions before i do a complete Factory Data Reset?
    12-17-2009 04:19 PM
  2. Andyvan#AC's Avatar
    I've been having the same problem. I flushed my caches (Download Manager, Google Apps, Market), and am now having problems authenticating to the google server when I try to enter the Market app.

    That authentication problem is probably the root cause of the download failures.

    I suspect that there's a problem between Sprint and Google, as the same account info works fine for logging in elsewhere (gmail, gcalendar, etc.).

    -- Andy
    12-27-2009 06:21 PM
LINK TO POST COPIED TO CLIPBOARD