1. YNWA-LFC's Avatar
    Wanted to get it to work so badly and I was quite upset when I realized that the F variant wouldn't be supported in the US. So I've tried all sorts of things... I installed the framework APK, the SPay APK, and it would never connect. I could open the app, scan the card but it would say something to the effect of "failed to connect, try later"
    I was able to install the 1.3 update to SPay, but not to the framework. SPay would tell me that I had an update (the new framework) the update would download but fail to install. After many tries the app asked me to send the error log to the developers. Well, I did it, and the I went in and started poking around. Mostly I was looking for errors, and/or the location of the new framework APK download. I wasn't able to find the download location, but I was able to find the actual URL where the APK was being downloaded from. I put that in Chrome, no go. Put the URL in Firefox Private Window, and it spit out an xml with yet another link. Pasted that link in Chrome, bam, APK downloaded.

    Sadly I couldn't install this framework update. It kept saying App not Installed. I tried with ADB as well, no go. It seems I needed root to be able to install it, which is a bit strange.

    So then I decided to upgrade to the Android 6.0 beta. Installed the BTU firmware, which changed the CSC code then registered for the beta program and went to sleep. While i was waiting for the new firmware to be available, this morning I did a factory reset, then installed the new Spay framework apk I had gotten earlier. Installed the Spay apk (1.3) I had and ran it. It asked me to install the new 1.6 version. Did that just fine. Rebooted the phone for good measure and upon reboot I got the 6.0 acceptance notification. Downloaded it, installed it, working great so far, then I added a card to Spay. It took it, I got the text verification, and now the card is "pending activation"

    recap:
    1. install BTU firmware as per: sammobile dot com /2015/12/23/how-to-install-android-6-0-beta-on-galaxy-s6-or-galaxy-s6-edge/
    2. Factory reset
    3. Install attached framework
    4. Install Spay apk
    5. open Spay and update
    6. add card.

    Now, step 1 MAY be questionable... I don't know. I did it for other reasons but it seemed to have worked so far.
    Also, and this is a speculation, I had used Debloater to get rid of lots of bloat and the reset brought them all back. I haven't debloated yet. So it may be the Debloater disabled apps that were preventing Spay form working before and the reset got them reenabled.

    I've seen a few others have "pending activation" messages so I'm hoping that'll clear up soon.
    Will report back once I get the confirmation and use Spay at a store.
    Attached is the new framework apk
    Attached Files
    12-24-2015 01:54 PM
  2. 20blks's Avatar
    I assume you're not in the US. Otherwise, why not just get a phone that's supported? That seems like a lot to go through
    12-24-2015 02:03 PM
  3. YNWA-LFC's Avatar
    I am in the US and I wanted an unlocked phone. I know it's a bit much... but what the hell. It's fun.
    20blks likes this.
    12-24-2015 02:08 PM
  4. YNWA-LFC's Avatar
    Sadly, the answer is no. I was able to add the cards, I got the confirmation message from both Chase and AmEx and then the app wanted to update itself. After the auto-update, which went through fine, my cards vanished and the app would no longer connect.

    The interesting thing is that the cards were there, in the cache, yet not visible in the app. I know this, because literally seconds after I cleared the Spay cache, I got emails from both Chase and AmEx saying that my cards had been removed.
    Subsequent uninstalls and reinstalls of the app have yielded no success. The 1.3 version of the APK installs, connects but it won't let me add any cards unless I update to the new 1.6 version, which fails to download every single time.
    Last time after several failed attempts to install the framework, I got an error log file, where I was able to isolate the URL where the update was being downloaded from. This time, despite repeated attempts, no error log.

    I'm not sure where this leaves me, but Samsung has really done a number with this, shutting out unlocked users, and the word "upset" doesn't even begin to describe the feelings I'm having towards the company.

    Regardless, this is still fun.

    It would be great if anyone can extract the APK of the new Spay 1.6 version and post it, though I suspect root might be needed which would kill Spay.
    12-28-2015 11:27 AM
  5. YNWA-LFC's Avatar
    Update:
    Found the APK 1.6.43

    Still no go. The app goes through the demo, spinning ring for a second then stays on the splash screen.
    I pulled a bug report and saw the following:

    setServiceType : SERVICE_TYPE_US
    getCountryISO : GB

    Suspicion is that when Samsung Pay is opened to other countries, new versions will be released to allow for the countryISO to be in the "allowed" list.
    neil_sugarbush likes this.
    12-28-2015 04:14 PM
  6. neil_sugarbush's Avatar
    I'm in the same boat and it blows. Bought the phone due to wanting an unlocked carrier neutral version and get jackholed by sammy in the process. Hopefully when sammy opens up samsung pay in Europe, the 925f will work here as well. Android pay works fairly well, but of course it has operational limitations.. Thanks for the work.
    12-29-2015 10:55 PM
  7. YNWA-LFC's Avatar
    Samsung will open their payment platform to other countries, it's just a matter of when. Just make sure your phone is on a CSC that will be supported, like one of the UK ones since the UK will most likely be among the first to get Samsung Pay in Europe.
    12-31-2015 01:05 PM

Similar Threads

  1. Will Samsung S Mouse (ET-MP900DBEGUJ) Work?
    By PDX97229 in forum Samsung Galaxy Tab S2
    Replies: 4
    Last Post: 12-26-2015, 01:18 PM
  2. Gifts of the Season (unboxing)
    By Alan FL in forum Samsung Galaxy Note 5
    Replies: 2
    Last Post: 12-24-2015, 03:03 PM
  3. Replies: 1
    Last Post: 12-24-2015, 02:51 PM
  4. Apply Asus contacts theme dark on galaxy s5
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-24-2015, 02:43 PM
  5. How do I remove myself from a group message on a Samsung s5 ?
    By Kimdelacreme in forum Ask a Question
    Replies: 1
    Last Post: 12-24-2015, 02:41 PM
LINK TO POST COPIED TO CLIPBOARD