1. RazzMaTazz's Avatar
    As described at the following link, my mom's Phoenix-0.2-ROM-based Replenish wouldn't boot but I was able to do a Nandroid restore after she mailed it to me.

    But ever since I got the phone back from her, none of my PCs can communicate with it via USB. In fact, when I connect it (using any of my known-good USB cables to any of my USB ports) none of my PCs (whether or not they had the driver installed) even see a USB device is connected. (No kerplunk sound. Nothing.) The phone charges from the PC, but there is no "USB Connected" notification. Two of my PC already had the Samsung driver because I used them to set up her phone 5 months ago. I tried reinstalling the driver, restarting the PC, and restarting the phone multiple times. And I've tried multiple USB ports and cables which I know are good. USB debugging is turned on.

    Anybody know how I can get this to connect via USB?

    I'm thinking about reflashing Phoenix ROM.
    11-14-2012 07:42 PM
  2. ciscogee's Avatar
    DL rom with the phone and unzip on sdcard or pull sdcard and plug in pc

    Sent from my SPH-M580BST using Tapatalk 2
    11-15-2012 10:03 AM
  3. RazzMaTazz's Avatar
    I tried:
    • Reinstalling Phoenix 0.2 ROM.
    • Reinstalling DRMLook's v2 kernel.
    • Doing a factory reset.

    Nothing fixed the USB problem. I can't think of anything else to try. I'm guessing there's a hardware problem.
    11-15-2012 12:17 PM
  4. ciscogee's Avatar
    Settings > wireless and networks > usb connections

    It may be just set to charge.

    Sent from my SPH-M580BST using Tapatalk 2
    RazzMaTazz likes this.
    11-15-2012 03:27 PM
  5. RazzMaTazz's Avatar
    Thanks. I thought of that. It was set to "ask" what to do, not to "charge". I tried changing it to every option, but none of them solved the problem.

    Anything else?

    The phone is only 5 months old and USB is pretty durable so it's hard to believe that the hardware is fried.
    11-16-2012 01:11 AM
  6. ciscogee's Avatar
    [strike]What kernel and rom are you using?[/strike] Its kinda hard to tell if its hardware because it charges.

    Sent from my SPH-M580BST using Tapatalk 2
    11-16-2012 02:34 PM
  7. RazzMaTazz's Avatar
    It's running Phoenix-ROM 0.2 and DRMLook's v2 kernel. But it's been running this setup for 5 months and it used to be able to connnect via USB.

    It's really hard to know why it doesn't work. I set up the phone in June and mailed it to my mom. I visited her in August and it was working fine (though I had to delete an app or two because she was getting low memory warnings). Then about a week ago it crashed and it wouldn't boot up, so she mailed it to me. Ever since then it won't communicate with any of my PCs or Mac. My mom doesn't use the USB for data transfer so I'm not sure when the USB port stopped working or if it's related to the system failure. It's not like she hacks it or abuses it or anything. It looks perfect and she said that she hasn't dropped it or anything.

    It's just hard to imagine why the USB data doesn't work but the USB power does. I've looked at the phone's USB-port contacts and they look shiny and nice. If the phone were a PC, I'd reload the USB driver, but I don't think there's any equivalent for an Android phone.
    11-16-2012 05:13 PM
  8. abakri's Avatar
    Hey man any luck ? I'm having the same problem on my Note 2

    Thanks. I thought of that. It was set to "ask" what to do, not to "charge". I tried changing it to every option, but none of them solved the problem.

    Anything else?

    The phone is only 5 months old and USB is pretty durable so it's hard to believe that the hardware is fried.
    01-14-2013 05:41 PM
  9. ciscogee's Avatar
    In cwm can u mount usb storage?
    01-18-2013 03:13 PM
  10. RazzMaTazz's Avatar
    Ciscogee- That would be an informative experiment. (I guess you're trying to see if it's definitely a hardware problem or a ROM-interaction problem.) My mom has her Replenish and she lives on the other side of the country, so I won't be able to try mounting USB under CWM until then.

    Abakri- My mom's phone was only a few months old when the USB broke. I agree that USB is typically very durable-- which makes this very puzzling. But I think it's either fried USB silicon or a bad connector.
    02-01-2013 11:07 PM
  11. Madeline Harpe's Avatar
    I am having the same problem. I have also used the USB data transfer on another PC before and have gone into settings (while the phone was not connected via usb) and checked the option to 'ask on connection to either charge or use usb mass storage' - tried to do this with both settings of 'mount' & ''unmounted' card in settings as well -
    all to no avail.The phone quickly goes to select charging or use USB mass storage, in which i tick; then quickly goes back to screen showing that phone is only "charging".
    My computer, Windows 7, does NOT pick up the device under 'my computer', thus recognizing it - I checked some settings on pc in device manager and for default 'auto play' settings, did a restart there .. . which did not help either. I also ruled out the culprit as being the USB cable itself by using more than just the one cable;

    I keep reading that in order to use the data transfer that the settings for the device (phone) need to be selected BEFORE connecting the usb cable to the pc and although I have gone back and redid just that after powering the phone off & removing the battery. Again- to no avail. For some reason I can't help but think there's something to do with the phone, along those lines ...

    So I went into the phone's software; "System Update's": > settings> about phone > system updates; and there are 4 different updates to choose, it did perform an update to "PRL" .. But >> the "profile update" when ticked came back with an error message stating The profile update could not be completed. Please try again later. If problem persists,
    you may need to contact Customer Service. Along with: " Error: Connection Error " and finally THIS has peaked some plausible indicative reasoning that may be key.
    Alright it successfully completed the 2nd time.

    I have the Samsung prevail with Boost. I did go into "The Boost Zone" (ID pac/on phone) and under 'help' has a diagnostics and service connections (updates and tips, etc.)
    that I am checking out now; It performs a check for voice and Data Connection - indicates that it is working properly.

    I can post back as to what I find out / solution wise.
    12-08-2013 05:32 AM
  12. RazzMaTazz's Avatar
    I have no idea why but when I visited my mom this past summer (who has the Replenish that couldn't connect via USB in the original post) it connected via USB. I have no idea why. Nothing changed. I'm guessing it's a hardware connector issue. If you can charge with a USB cable but you can't transfer data to/from your phone using the USB cable, then you could do so wirelessly via WiFi (FTP or Samba) using ES File Explorer, WiFi File Explorer, et al. Instructions for doing so with ES File Explorer follow.
    12-13-2013 04:40 PM

Similar Threads

  1. Rooted w No USB Data Connection
    By bmiller001 in forum Verizon HTC Thunderbolt
    Replies: 1
    Last Post: 06-27-2011, 11:06 PM
  2. no longer get the options when i plug my phone to a pc
    By markoujk in forum AT&T Inspire 4G
    Replies: 7
    Last Post: 04-30-2011, 08:17 PM
  3. Epic detects USB when connected to wall charger
    By cdjh in forum Sprint Epic 4G
    Replies: 22
    Last Post: 02-06-2011, 12:44 PM
  4. No longer getting 3g...any ideas?
    By cjwrite in forum Google / HTC Nexus One
    Replies: 4
    Last Post: 10-29-2010, 04:23 PM
  5. No longer getting the proper alert for incoming email
    By Primetimeplaya in forum HTC EVO 4G
    Replies: 2
    Last Post: 07-24-2010, 11:10 AM