1. Mark Mandel's Avatar
    SUMMARY: Bunch of apps disappeared leaving "ghost Android + SD" icon.
    When I turned on the display of my VErizon Samsung Stratosphere (model SCH-I405, h/w v. I405.05, f/w v. 2.3.6) for the n-th time this afternoon, a bunch of my apps suddenly had just a "ghost" (translucent gray) Android icon with a tiny "SD" in the corner. I've never seen that before, and I thought the SD card might have come loose. I powered down, but while I was struggling to to take the gadget out of its holder my thumb hit the on button, but I'm pretty sure I turned it off before opening it up. I took out the battery and the SD card, then put them back in & powered up. No change. I don't know what happened or how to fix it. HELP!
    05-14-2013 09:12 PM
  2. teamcopeland's Avatar
    A similar thing happened to my phone and I have tried several things but nothing fixes it.
    Most of my*downloaded*app icons suddenly disappeared from the apps listing and became unavailable for use.*When I use the manage apps button I noticed that they are listed but their icons are shown as generic "android SD icon" all the apps are listed but most have generic "android SD" icon. I can't open delete or move the apps.*Is there an easy way to restore all my apps?* The apps are not, I repeat not on my sd card as I've read several other posts saying to move apps from sd card but mine aren't on sd card. Any help would be welcome. Thanks in advance.
    09-03-2013 02:37 AM
  3. acejavelin's Avatar
    Reboot into recovery clear the cache partition, if that fails to work, backup and do a factory default... if you are rooted and have CWM Recovery, clear cache and Dalvik cache, it should clear the problem.
    09-03-2013 04:03 PM
  4. B. Diddy's Avatar
    What does it say on Google Play when you select the apps in question? Does it say "Open" or "Install"? If it says install, you could try that.
    09-03-2013 04:48 PM
  5. Christina Clark's Avatar
    It is just the shortcut icon that is messed up. You just need to get rid of the messed up icon by moving it to the trash. Go into your apps and drag out a new short cut. That worked for me.
    11-20-2014 01:38 PM
  6. justhemuffinman's Avatar
    Hey there! I had the same issue. The way I fixed it was by uninstalling the apps on the SD card, then 're-installed them. Works like a charm! Just make sure your phone storage settings are set to go directly to the SD card (if the app can move). Hope this helps someone.
    07-13-2016 02:12 PM

Similar Threads

  1. Moving Apps to SD Card - Icon Gone
    By BuMMeR-X in forum Droid RAZR MAXX
    Replies: 5
    Last Post: 11-04-2013, 05:52 PM
  2. Help Android Market app gone missing!
    By aknbad23 in forum AT&T Galaxy S II
    Replies: 12
    Last Post: 06-12-2013, 09:45 AM
  3. Replies: 3
    Last Post: 01-27-2013, 03:18 AM
  4. Apps missing from market (SD Gingerbread)
    By fje00 in forum Barnes & Noble Nook Color
    Replies: 3
    Last Post: 05-03-2011, 12:05 PM
  5. No option for Apps to be moved to SD card
    By lbarton001 in forum Motorola Xoom
    Replies: 3
    Last Post: 04-28-2011, 02:45 AM
LINK TO POST COPIED TO CLIPBOARD