1. AC Question's Avatar
    My phone was recently bricked and I had to get a new one, replacing a Droid Turbo 64GB with a factory refurbished Turbo. I cannot log in to Snapchat on new phone though. The error message I receive is "There was a problem connecting to the server. Please try again." This has been ongoing for about two weeks so it's not a temporary server issue. I can log in to my account from other devices, so it's not an account issue. I had no problems with my old Turbo. Here is what I have tried:

    Clearing the app cache, uninstalling, reinstalling
    Changing my account password
    Contacting Snapchat support - no reply
    Verifying that my date/time settings were correct
    verifying that my Google account settings were correct

    Any other ideas?
    Johanne Ekue likes this.
    06-29-2015 01:59 PM
  2. JJhendrix's Avatar
    I'm having the exact same problem with my Samsung S6 Active. I was using it fine one minute, the next it stopped sending snaps, then couldnt connect to server. Any help would be great!
    06-30-2015 11:24 PM
  3. JonoKO's Avatar
    Having the exact same issue with my google nexus 5.
    07-04-2015 10:53 AM
  4. thorunnisabel's Avatar
    I have the exact problem - I got LG G3.
    07-05-2015 11:47 AM
  5. The_Einre's Avatar
    I recently got a Galaxy S5 and ran into this problem after having the phone a couple days.

    The only fix I found was to put the phone into airplane mode, then turn Wifi back on and connect to an access point.
    This shouldn't be the ultimate solution, but it'll do for now until the real problem can be found.

    Hope this works for you (and all others having the same issue).
    Rhigay likes this.
    07-06-2015 01:02 AM
  6. brodie williams's Avatar
    My phone was recently bricked and I had to get a new one, replacing a Droid Turbo 64GB with a factory refurbished Turbo. I cannot log in to Snapchat on new phone though. The error message I receive is "There was a problem connecting to the server. Please try again." This has been ongoing for about two weeks so it's not a temporary server issue. I can log in to my account from other devices, so it's not an account issue. I had no problems with my old Turbo. Here is what I have tried:

    Clearing the app cache, uninstalling, reinstalling
    Changing my account password
    Contacting Snapchat support - no reply
    Verifying that my date/time settings were correct
    verifying that my Google account settings were correct

    Any other ideas?
    All i had to do was go into my google account sync it then i was able to sign in try that and let me know if it works for you to
    01-15-2016 03:56 PM
  7. ss11's Avatar
    I went though my background data restrictions and tried to allow all which I thought might relate to snapchat to see if that was the issue. I allowed Gallery, Camera and Google Account I believe and Snapchat started working right away. Hope it helps someone.
    01-25-2016 09:34 AM
  8. Rhigay's Avatar
    thank you so much it work

    put your phone into airplane mode with your wifi on and try to put your username and passwordit will definitely work
    03-28-2016 08:15 PM
  9. moayyad omari's Avatar
    I did so put my phone in airplane mode and conect wifi but snapchat still give me the same error message "can't connect to the server.please try again later
    What should I do.........
    04-06-2016 03:36 PM
  10. Chloe Barnes's Avatar
    My phone was recently bricked and I had to get a new one, replacing a Droid Turbo 64GB with a factory refurbished Turbo. I cannot log in to Snapchat on new phone though. The error message I receive is "There was a problem connecting to the server. Please try again." This has been ongoing for about two weeks so it's not a temporary server issue. I can log in to my account from other devices, so it's not an account issue. I had no problems with my old Turbo. Here is what I have tried:

    Clearing the app cache, uninstalling, reinstalling
    Changing my account password
    Contacting Snapchat support - no reply
    Verifying that my date/time settings were correct
    verifying that my Google account settings were correct

    Any other ideas?
    This happened to me too, I tried all of that too. But what I did is on the login screen, instead of your username, use your email. When I did that it logged me in perfectly fine. Good luck!
    07-01-2016 11:05 PM
  11. Trinity L's Avatar
    This happened to me too, I tried all of that too. But what I did is on the login screen, instead of your username, use your email. When I did that it logged me in perfectly fine. Good luck!
    Sti didnt work :/, ive tried every! It works on my friends phones.. Sony Xperia
    07-26-2016 09:52 PM
  12. Hannah433's Avatar
    This happened to me too, I tried all of that too. But what I did is on the login screen, instead of your username, use your email. When I did that it logged me in perfectly fine. Good luck!
    I tried that and I tried everything else I could possibly do! I can log in on anything but my phone I've Uninstalled and reinstalled, I've restarted my phone I've checked the date and time, I've took my battery out, I've done everything and its still not working!!!!! Someone help me
    08-30-2016 09:56 AM
  13. Hazzanator's Avatar
    Can you be more specific than sync it... where do I go to do that because nothing else works
    10-23-2016 06:18 AM
  14. Jasmine Blaha's Avatar
    I am experiencing the same issues too and I have done everything you have listed too. Have you found something that worked? It's very aggravating. It started doing this last night and I need it to be fixed.
    01-24-2017 01:02 PM
  15. Hanah_Moffett1's Avatar
    I have literally tried all of these and none of them are working It still says it cannot connect to a server, I have no idea what's wrong with it
    04-06-2017 10:25 AM
  16. Steven Boyd2's Avatar
    This surprisingly worked for me! Thanks
    05-11-2017 12:16 AM
  17. Jip Derkman's Avatar
    I have the same problem and tried everything. I have a Lenovo ZUK Z2 running on the MoKee custom rom. The problem started appearing after logging in on a friend's ipad. I can still login on my own iPad and on my android tablet. Its very annoying please help.
    08-08-2017 08:00 AM
  18. Porschalynn's Avatar
    It says can't connect to the server
    08-23-2017 11:34 PM
  19. Zaxoscool7's Avatar
    I had the same problem.
    Just boot your phone into recovery and clear cache.
    BUT DONT clear dalvik.
    09-01-2017 08:00 AM
  20. Joy2Buffalo's Avatar
    If logging in with email, (or, vice versa-reading other comments) log in with USER ID. It worked.
    11-10-2017 05:51 AM
  21. Lauraeno's Avatar
    Please did anyone finally get a working solution to this issue, I'm having the same issue and I've tried all available solutions, any help would be appreciated.
    04-30-2018 12:59 PM

Similar Threads

  1. Replies: 11
    Last Post: 12-09-2016, 02:24 AM
  2. Why can't I add new contacts to groups (KitKat)?
    By r2 control in forum Motorola Droid MAXX
    Replies: 3
    Last Post: 06-30-2015, 07:12 AM
  3. How to set myself invisible in my gmail app
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-29-2015, 08:27 PM
  4. Can I add static routes to Android devices via dhcp?
    By Montgomery Mark in forum Software Development and Hacking
    Replies: 0
    Last Post: 06-29-2015, 01:35 PM
  5. Why is my Galaxy S5 camera very sensitive to movement?
    By NCW73 in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 06-29-2015, 01:24 PM
LINK TO POST COPIED TO CLIPBOARD