1. Jerry Hildenbrand's Avatar
    Just got a new laptop, and while setting it all up (fun times!) I ran into an issue that it looks like a lot of folks are having -- the latest version of the Android SDK is busted when looking for a 64bit Java installation on Win7 64bit. When you try it, it tells you Java can't be found, and you should install it or edit the Java_Home system variable.

    Here's a much easier fix.
    Install the latest version of the JDK
    Download the zip version of the SDK for Windows (not the installer)
    Unzip it wherever you like
    replace the sdk\tools\lib\find_java.bat file with the attached file.
    Run the SDK setup as normal

    There's a bug in the r18 find_java.bat file, which causes it to look in the wrong location for java.exe and javaw.exe on 64bit Windows. I just attached the version from r16, which doesn't have the bug
    sblood86 and caretaker007 like this.
    04-12-2012 02:12 AM
  2. OldChicagoPete's Avatar
    Adding the JAVA_HOME environment variable worked for me, only took a few seconds. The correct value for me was C:\Program Files\Java\jdk1.7.0_03
    04-12-2012 09:30 AM
  3. harrisonford265's Avatar
    Thanks man for sharing such a useful information in past few days i was very annoyed by this problem on computer.
    04-16-2012 07:16 AM