05-09-2014 07:15 AM
36 12
tools
  1. lhinsz's Avatar
    This is awesome information for a newbie like me!! I am trying to learn all about my new Android and there is soooo much complicated discussions that a simple clear ADB description and use is a great start for me...
    10-31-2010 05:37 PM
  2. manikmayamusic's Avatar
    I can not enter the SDK in the windows through command prompt, should it connect with the device first before running the SDK?
    01-11-2011 01:55 AM
  3. cream_alexx's Avatar
    Thanks t0ast3d
    03-29-2011 05:08 AM
  4. Smittyn804's Avatar
    Thanks t0ast3d, this helped me getting familiar with using ADB. Trying to inform myself as much as possible without blindly rooting my TB or playing with files.
    04-28-2011 02:01 PM
  5. igotthepowers's Avatar
    guys - need your help here (evo 4G). i am guessing these instructions might need a bit of updating because the new "revolutionary" rooting method requires htc sync to be uninstalled. i do have the most current htc drivers, HTCDriver3.0.0.007, which i downloaded and installed previously. should i reinstall sync (hope not)? is there another dot i need to connect to get ADB to work with the revolutionary rooting method?

    i am getting the error message of "adb is not recognized as an internal or external command, operable program or batch file."

    THANKS!!!

    addendum - i uninstalled then reinstalled the HTC drivers using the executable file above, still no luck.

    further addenedum - i think this might be a driver problem. my device "android phone" appears with five different device functions and drivers. three of these are the basic USB composite device, USB mass storage device and F:\ (portable device). the ones that seem related to this issue are (1) "HTC android phone USB device" (disk drive) and (2) "My HTC" (android USB devices). the driver for (1) is a microsoft driver version 6.1.7600.16385 dated 6/21/2006. the driver for (2) is from HTC, version 2.0.7.3 dated 1/3/2011. perhaps this is a problem with the driver for #1? please help, thanks again!
    11-11-2011 10:42 AM
  6. igotthepowers's Avatar
    UPDATE - adb devices works when i open a command prompt on the subdirectory "platform-tools" and not "tools" as mentioned herein and in numerous other places. perhaps this is due to an updated google SDK package since all these directions were written?
    11-11-2011 12:39 PM
  7. HusamHaopsh's Avatar
    I'v been trying to find out a way to move Apps to SD card on my Note 2 WITHOUT ROOTING MY PHONE

    later on I found out about a way useing ADB (Andriod Debugging Bridge) which has an option that sets/changes the default install location.

    command line: adb shell pm set-install-location 2

    0 [auto]: Let system decide the best location
    1 [internal]: Install on internal device storage
    2 [external]: Install on external media

    which I did and rebooted the phone, tried to download a game to check if it works with no luck! it still uses the phone memory!
    I attached a snapshot of the command line, even when I check the status, the phone replies with the new changed value, so i know the phone system accepted the command, but it does not make the apps save to the SD card!

    does anyone know if it works? or if im missing a step here or there?
    (I did install all required software/drivers, turned on USB debugging, checked the option on Unknown sources, and rebooted the phone).
    thanks for any help!
    Attached Thumbnails ADB: Basics [Windows only]-adb.jpg  
    05-16-2013 05:51 AM
  8. Naz Alahi's Avatar
    when i try to use any shell command its show me this
    'adb' is not recognized as an internal or external command,
    operable program or batch file.
    10-26-2013 01:22 PM
  9. 5L Mustang's Avatar
    I have A NEXUS 4 My phone's display is broken and non responsive but I really need my contacts, notes on some note app I used and all the text messages from one person. Well I downloaded the ADT-bundle Now what do I do? I tried to put in some commands but get the same response NAZ ALAHI above my post. I'm a complete newb to this. I have my phone in recovery mode and plugged into my laptop? Please teach me how to pull my info from my phone!!!
    01-16-2014 01:33 AM
  10. BenAam's Avatar
    The ADB Download Link gives this message now:

    http://dl.google.com/android/android...06-windows.zip

    404. Thats an error.
    Thats all we know.
    03-09-2014 12:37 PM
  11. Ejaay Fernandez's Avatar
    Sir, can i ask what is the command for factory reset and what to do after doing the command ? or after the phone resets. Thanks if reply, and also, when to connect the phone to the computer ?
    05-09-2014 07:15 AM
36 12
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.