1. Continuum88's Avatar
    I tried installing Midnight Commander as described in this thread
    [APP] midnight-commander for Android (updated to, with APK Installer) - xda-developers

    I first downloaded Nativnux Installer, installed it, then started it, but the procedure didn't finish successfully. After clicking Install (in Nativnux Installer), the log was:
    mounting /system read-write ...
    installing ...
    tar: invalid tar magic
    I couldn't find any traces of mc anywhere. Do I have to download additional mc tar somewhere as well?
    The phone is rooted and it has BusyBox installed.

    Also, does anyone know if there's pico or nano editor available for Android?
    04-01-2013 04:25 AM
  2. Continuum88's Avatar
    I find it strange how easy it was to set up these things on iOS as opposed to Android. One would assume that Android would be the easy and open (and free...) one in this regard, but I'm not getting that impression now.

    What I need, altogether:
    - a working SSH server with root access and (Win)SCP support
    - a few command line tools that are not within BusyBox, including Midnight Commander and Pico/Nano
    04-05-2013 04:36 PM
  3. flusspferd's Avatar
    The other day I had the same problem.Here is a note on the lovely MC for a rooted tablet with USB keyboard attached.

    The traditional Midnight Commander file manager is a useful tool in learning the structure and function of Unix based systems.It has been ported from Linux to Android and can be downloaded as a .apk file from xda developers website ( [APP] midnight-commander for Android (updated to, with APK Installer) - xda-developers ).
    The installer did not work on my rooted inexpensive chineese tablet with usb ports, and apparently others had problems with install and keyboard keys according to the thread over at xda-developers.
    I wanted to reply to the thread explaining how to configure a USB keyboard but was not allowed as I had no experience points.I have always found Midnight Commander a gem with its inbuild symbolic link and text editor, so I post in this thread instead.

    With a rooted tablet with busybox and su installed but no superuser, and USB keyboard as accesory:
    On Windows computer:

    Download and rename NativnuxInstaller_1.1.apk to NativnuxInstaller_1.1.zip
    Extract mc- located in the zip file with 7-Zip or similar
    Rename the file to mc-
    Extract mc- from the .gz file by using 7-zip once more

    Via SD card copy and paste the .tar file to the root ( / ) of the device (I use "ES file manager" where root is indicates as "/ device", the app available at Google Play, with credits to ES company.)

    On the rooted Android device with busybox and su installed:
    Install and open the free "Android Terminal Emulator" by Jack Palevich from Google Play (thanks to mr. Palevich)
    Enter "su" (without quotation marks)
    Enter "mount -o remount,rw /system" (without quotation marks) *
    Enter "busybox tar xf mc-" (without quotation marks)

    If succesful you will return to the command prompt.

    Reboot the tablet, attach the usb keyboard, open the terminal and enter first "su" and then "mc" (without quotation marks)

    Probably the arrow keys will not work: "A", "B", etc. will be written instead, but Midnight Commander can learn:

    Go to the pulldown menu: press F9, then "O" (for Options) and then "K" (for Keyboard). Using TAB, select the first arrow key, then press "Space", then the corresponding arrow key twice. Repeat for all of the other arrow keys. Then hit Save

    We have now a blue Midnight Commander with the arrow keys working on the USB keyboard.With further configuration and editing probably also a mouse will work as this is a Linux system.

    * (addendum: It is not impossible the "system" folder on your android device is mounted as "read only". If encountering problems editing system files entering the "mount -o remount,rw /system" command (without quotation marks) before running the Midnignt Commander could be helpful allowing both Reading from and Writing to the "system" folder.To run such a command automatic it could typical be added to the end of the right one of the many existing configuration files.Just a second thought as it is some time since I last was into Linux).
    Attached Thumbnails Midnight Commander won't install-midnightcommander.jpg  
    Continuum88 likes this.
    11-17-2013 08:12 AM
  4. flusspferd's Avatar
    Extra notes:
    1. I remember getting the warning "awk, grep, tar not found" under one of the unsucessful attempts to install Midnight Commander.I am unsure if the message had it's origin from the installer wrapped around the .jet file or from MC itself.
    Anyway - it was also necessary to enter "busybox tar" and not only "tar" in the terminal to unpack the .tar archive, while the "ls" command ("list the directory") worked as expected.
    I read the commands "awk", "grep", "tar", "ls" and a bunch of others in embedded Linux systems (like android) are executed by the single busybox executable, while in Linux separate executables located in a /bin directory run the commands.
    In my instance I found that the command "ls" worked at the terminal prompt on my tablet because this was the only command who was linked by a symbolic link to busybox, while the other three commands was not.
    To set symbolic links with Midnight Commander and construct virtual files like "awk", "grep" and "tar" you may navigate to the folder /system/bin in both of the commanders panels, and then with arrow keys navigate the bar to "busybox" in one of the panels.Then press "F9" to activate dropdown lists before going to the File menu, and then press "s".
    A box with will open where a top line will refer to the existing file you want to set a link from (here /system/bin/busybox), and a bottom line will allow you to construct missing virtual symbolic files ( like /system/bin/awk ).Edit the bottom line and save the symlink, and repeat for missing commands in your /bin or /xbin directories.
    After this tar, awk, grep and other constructed traditional Unix commands will run from the terminal prompt without the need of having to type busybox as preamble, and probably this will make it more unproblematic for crosscompiled Linux applications to run on android.
    2. I find it necessary often to use the "mount" command as described earlier to allow writing to files in the various directories.I also found It nice when at the terminal prompt the up arrow prints the last command entered.
    3. A Nano editor for Android as .zip file is here After opening the compressed file and copying the /terminfo and /xbin files one by one to their respective directories it works fine if run from innside MC (credits to bgcngm for crosscompiling).
    11-18-2013 06:43 PM

Similar Threads

  1. Rooted last night, now App Updates won't install
    By cdolan22 in forum Verizon Droid Incredible
    Replies: 0
    Last Post: 10-28-2010, 03:36 PM
  2. Google apps won't install
    By flegma3124 in forum Motorola Droid
    Replies: 4
    Last Post: 09-24-2010, 03:49 AM
  3. Droid X Won't Install Froyo Even After Factory Default!
    By titot4u in forum Motorola Droid X
    Replies: 5
    Last Post: 09-22-2010, 12:31 PM
  4. apps won't install.
    By furbymac in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 0
    Last Post: 07-28-2010, 06:41 PM
  5. apps won't install.
    By furbymac in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 0
    Last Post: 07-28-2010, 06:32 PM