1. Lee Gee's Avatar
    Hey guys,

    Has anyone had any success with rooting a Motorola RAZOR I (XT890) with a 4.4.2 update? If so, How?

    Basically, I dropped my (rooted) GS4 in the toilet the other day whilst taking a ****. I'm gutted because the thing no longer works - won't switch on or anything. So, I begrudgingly had to revert to my old Moto XT890, the storage space is small and there are so many apps that are not compatible but I need an internet ready phone, so what else can i do (other than buy another one which is not what I want to do at all)?

    Anyway, I had only just rooted my GS4 phone about a month ago using Odin and after successfully rooting it, I was in the middle of trying to succeed in getting my computer to remote desktop to my GS4. The reason I want to connect my PC to my phone is because as you probably know, mobile phone networks provide an allowance for tethering (providing internet usage for other devices) and when you use up that allowance, no more internet!

    However, the network gives me unlimited internet usage on my android device itself through the network. The thing is, I hate using the internet on my phone because the damn screen is too small - which is why I want to spoof the connection by using my computer to magnify the screen from my phone to get my andriods free internet but on my computer screen. But my little pursuit of internet on my PC through my GS4 has been cut short because of the big mistake I made dropping it in the toilet so I'm trying to pursue doing it with my Moto RAZOR I now.

    Now the apps I need to try and get working on my phone are either Droid VNC server or Weak control, but they (like some other apps) were not compatible with my device and therefore I couldn't even install them from the playstore onto my device. So I thought I'd update my Android software which I hadn't done since I'd bought the device 2 years ago. It was on 4.1.2. so, I downloaded the update and it upgraded the Android software to 4.4.2.

    So, update completed, great. I then tried to download the apps and they were successfully installed. awesome (Or so i thought). Basically, both apps need root access to work properly. So I started looking for rooting methods for my device to get these apps working. ******* hell! I have literally been up all night trying every rooting method I've come across (about 5 or 6 methods using different tools) on both Google and Youtube and none of them work for me!

    Has anyone got any idea on how to root this damn phone? This has been ******* torture from start to finish.
    09-08-2015 12:54 AM
  2. Teejai80's Avatar
    Dam that does not sound like much fun! I guess you have tried the easy stuff like oneclickroot? https://www.oneclickroot.com/device/...-kitkat-4-4-2/

    Have you unlocked the bootloader? Unlock the Bootloader on Your RAZR i | Motorola RAZR i | XDA Forums

    Also try here RAZR i Root | Motorola RAZR i | XDA Forums

    Goodluck!
    09-08-2015 01:33 AM
  3. Lee Gee's Avatar
    Hi Teejai80,

    I hadnt actually tried that Andriod One Click Root app so thanks for that. However, that app assessed whether my phone could be rooted or not in its current state and it came back another 'no answer'. That being the case again, I now know that its down to a locked bootloader file that rooting needs access to which unfortunately comes with the upgrade from 4.1.2 Jellybean to 4.4.2 KitKat. So I am going to have to look into the 2nd link option you provided. What a pain hey?
    Teejai80 likes this.
    09-09-2015 02:33 PM
  4. Teejai80's Avatar
    Indeed, unlocking isn't too hard though. Just follow the steps and read as much as you can until you are comfortable with it.

    Sent from my Nexus 5 using Tapatalk
    09-09-2015 04:27 PM

Similar Threads

  1. Is YouTube compatible with Android Auto?
    By AC Question in forum Android Auto
    Replies: 3
    Last Post: 03-23-2016, 05:03 PM
  2. How do I attach a thumbnail from the screen?
    By AC Question in forum HTC One M8
    Replies: 1
    Last Post: 09-08-2015, 01:35 AM
  3. Replies: 1
    Last Post: 09-08-2015, 01:32 AM
  4. I forgot the password on my S3, how can I get into my phone?
    By AC Question in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 09-08-2015, 01:20 AM
LINK TO POST COPIED TO CLIPBOARD