1. dannywalls76's Avatar
    Hi all, I'm hoping that this is something I've missed during setup. I've just got my SW3 and it took me a while to get it paired with my Moto X Play. Bluetooth was fine but I couldn't get my watch to connect to the internet. Until I turned WiFi off on my phone and then it worked straight away but using my mobile data. Now I need to update the watch firmware and the download won't start unless I turn my phone's WiFi off.
    The watch connects to WiFi without a problem. Is this supposed to happen (I'm assuming not)? Any suggestions or solutions would be greatly appreciated.

    Posted via the Android Central App
    06-10-2016 09:15 AM
  2. Penguwin's Avatar
    Huh.... that is odd, can't say I've ever run into that one 😕 . Hate to give a generic answer here, but all I can think of is to reboot the watch and phone and try again. Hrmm, maybe even factory reset the watch by selecting unpair watch in the watch's settings.

    Best of luck.
    06-10-2016 12:13 PM
  3. dannywalls76's Avatar
    Everything seems to be working OK now it's all set up. I tried resetting the watch and restarting phone a few times and starting the pairing process again but the only way I could get it to update was via mobile data. Good job I've got a lot of inclusive data! Everything's connected up with WiFi now.

    Posted via the Android Central App
    Penguwin likes this.
    06-10-2016 06:36 PM
  4. Penguwin's Avatar
    Everything seems to be working OK now it's all set up. I tried resetting the watch and restarting phone a few times and starting the pairing process again but the only way I could get it to update was via mobile data. Good job I've got a lot of inclusive data! Everything's connected up with WiFi now.

    Posted via the Android Central App
    Good to hear it sounds like it sorted itself out.

    Enjoy your SW3! 😎
    06-11-2016 01:21 AM

Similar Threads

  1. Replies: 4
    Last Post: 06-22-2016, 09:24 AM
  2. How do I Manually update my HTC Desire 820?
    By Shinju R in forum HTC Desire 820
    Replies: 1
    Last Post: 06-13-2016, 02:42 PM
  3. Note 4 Updated last night and now I have no Data Connection?
    By Chuckles 135 in forum Samsung Galaxy Note 4
    Replies: 2
    Last Post: 06-10-2016, 04:11 PM
  4. Why can't I update my GS4 I9500 beyond 4.2.2?
    By AC Question in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 06-10-2016, 07:07 AM
  5. Problems with Video /Audio Sync in Galaxy J7, what can I do to fix this?
    By AC Question in forum Samsung Galaxy J Series
    Replies: 0
    Last Post: 06-10-2016, 05:22 AM
LINK TO POST COPIED TO CLIPBOARD