1. Brendan Winter's Avatar
    I purchased a new Xperia Acro S and, upon bringing it home and performing initial setup etc, installed Sony's PC Companion. I was then informed that an update (to Jelly Bean) was available. During the update process, I was instructed to disconnect the phone, turn it off and then reconnect while holding Volume Down button. I did this, with no result whatsoever - the phone simply started, the notification light went green then red, and a green battery indicator was shown onscreen. I tried rebooting both phone and PC, with no luck. Please help...
    06-30-2013 03:30 AM
  2. tussockcreek's Avatar
    Same here. really frustrating. they should have tested this themselves.

    Oh, went here and found this: Main: Problem Updating My Xperia acro S phone to Jellybean

    Which says do this:
    Just use this software and avoid confusion.
    SUS ( Sony Update Service) ... download and install it on pc and follow the on-screen instructions
    Update service - Sony Smartphones (Global UK English)

    I'm off to try it...

    ok, seems to have have the same problem. this holding the volume down key isn't working. It just gives "USB not recognised" message with both these methods!
    07-03-2013 12:26 AM
  3. acrosuser's Avatar
    Exactly the same problem I've having. Everything I've tried results in the same problem with the green battery indicator showing and no update running. I've tried updating using sony pc companion and when that didn't work, I downloaded and tried Sony updating service. NEITHER WORKS. Have tried contacting Sony but no response. So sorry I bought this phone.
    07-04-2013 08:03 PM
  4. Kit Sern Ee's Avatar
    Hey there you can try installing usb drivers for Xperia acro S ,or flash the ftf file directly using flashtool

    Zippyshare.com - flashtool-
    Here's the link after finish the installation, access your local disk c or d and search for program files and you can see the word flashtoool click on it and look for the driver folder and install everything given in the file. Hope this will help
    07-16-2013 06:41 AM
  5. Sinbad683's Avatar
    I'm experiencing the same exact problems with my acro S. I've downloaded the flash tool, but where can I get the FTF file?
    08-30-2013 05:28 AM
  6. Kit Sern Ee's Avatar
    just search it from xda
    11-24-2013 12:39 AM

Similar Threads

  1. To Root or Not to Root
    By op t must in forum Virgin Mobile Optimus V
    Replies: 12
    Last Post: 01-24-2015, 02:34 PM
  2. storage not calculating
    By papafrankm in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 4
    Last Post: 07-02-2013, 10:24 PM
  3. Easiest Way to install stock android to S4
    By thinkican in forum General Help and How To
    Replies: 2
    Last Post: 06-30-2013, 10:50 AM
  4. I need some ideas on how to fix my broken htc one m7 att
    By d00djoe in forum General Help and How To
    Replies: 0
    Last Post: 06-30-2013, 01:14 AM
  5. What is the easiest way to unroot the HTC evo design 4g?
    By BGoldsmith in forum HTC EVO Design 4G
    Replies: 0
    Last Post: 06-30-2013, 12:23 AM