1. AC Question's Avatar
    I have a sony Xperia t2 ultra which is upgraded to lollipop, my network data is working on 2g (showing 'E') not in 3g. I have already installed the internet settings and have a active 3g data plan. There was no problem in my old samsung galaxy ace which was gingerbread. Do I have to do any sort of settings???Please help to fix problem.
    05-04-2015 12:04 PM
  2. Rukbat's Avatar
    Bring the phone to the carrier. You may have no 3G signal where you are, 3G service may be down for a while, the phone may be defective, the SIM may be defective (they should replace that for free) - many things you might be able to fix, many things you can't fix. They can fix them all.
    03-22-2016 02:06 PM

Similar Threads

  1. Why can't I display a PS4 Remote Play when mirroring to another device?
    By GJ34 in forum Other Gaming Consoles and Devices
    Replies: 2
    Last Post: 08-27-2015, 02:20 PM
  2. Unlocking from a notification on lock screen behaves oddly
    By AlphaVictor87 in forum Samsung Galaxy S6
    Replies: 5
    Last Post: 05-06-2015, 05:50 PM
  3. App to warm up screen temperature on M9?
    By rsdroid in forum HTC One M9
    Replies: 2
    Last Post: 05-05-2015, 08:27 PM
  4. How can I get my alarm working on my Samsung Grand Prime?
    By Sunshine Man in forum Android 4.4 KitKat
    Replies: 1
    Last Post: 05-05-2015, 11:47 AM
  5. Why won't the status bar on my lock screen show icons?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-04-2015, 11:26 AM
LINK TO POST COPIED TO CLIPBOARD