1. blaford's Avatar
    So I've had my device rooted for a bit now but none of my old standbys for blocking ads have worked. What are the rest of you using?
    09-11-2014 02:03 PM
  2. anon(394005)'s Avatar
    I've been using the AdAway app (with the MVPS blocking hosts file) for years on all my Android devices. Google banned ad blocking apps like that from the Playstore a while ago though. But it's still available directly from the dev here: https://sufficientlysecure.org/index.php/adaway/
    09-11-2014 02:48 PM
  3. blaford's Avatar
    That's what I used for years. But it doesn't work on my xperia Z1s. I get ads in my browser and ads in my apps. It was so effortless before. In fact I'm pretty sure it doesn't work on my nexus 7 either.
    09-13-2014 11:28 AM
  4. anon(394005)'s Avatar
    Sounds like the hosts file isn't being updated. You're rooted correct? Does AdAway ask to be granted root access when it's launched? Is it listed in your Super user or SuperSU app as granted?

    Also, what hosts file source are you using? I just use the MVPS one (http://winhelp2002.mvps.org/hosts.txt) and don't see ads in the browser or apps on my Note 2, OG Note 10.1 and OG Nexus 7. They're all using a 4.1.x version of Jelly Bean yet, but I wouldn't think the OS version should matter as it's just a modification to the hosts file. Also in AdAway, under "Host sources" verify the hosts file has a check mark and the date is recent.
    09-13-2014 12:14 PM
  5. anon(394005)'s Avatar
    Found this that may help too: AdAway doesn't work on Android 4.4 https://github.com/dschuermann/ad-away/issues/476
    09-13-2014 12:25 PM
  6. blaford's Avatar
    So I tried to block ads manually with the MVPS hosts file, but I cannot rename the original hosts file even with root access. I try to change it to hosts.bak and it says operation failed.
    09-14-2014 10:01 AM
  7. anon(394005)'s Avatar
    Modifying the hosts file directly like that won't work. It has to be done via an app like AdAway which parses the source hosts file entries into a readable format for the Android OS. But it sounds like whatever app you're trying to use to rename the file doesn't have the proper root access. If it's ES File Explorer, you have to go into its root settings menu and ensure things like "Root Explorer" and "Mount File System as writable" are enabled.

    Also check your Super user or SuperSU app to see if AdAway or any other apps are listed as having been granted root access. If you don't have a Super user or SuperSU app or nothing is listed in them, you may not be properly rooted. Try a root checker app from the Playstore to verify.
    09-14-2014 11:29 AM
  8. blaford's Avatar
    It seems the trouble is that I'm unable to mount as RW. I can't do it with explorer apps, mount /system app, or even the terminal emulator. Every app I've tried is granted superuser permissions but I can't remount.

    I've tried rootchecker pro... Says I have root access. However it seems like there's some odd notations in the details. I'll try to upload pics.
    Attached Thumbnails What are you using to block ads?-screenshot_2014-09-14-13-40-37.jpg   What are you using to block ads?-screenshot_2014-09-14-13-40-21.jpg   What are you using to block ads?-screenshot_2014-09-14-13-39-54.jpg  
    09-14-2014 12:46 PM

Similar Threads

  1. Unwanted accented letters using external keyboard.
    By writermanuk in forum Legacy Android & Other OS's
    Replies: 8
    Last Post: 04-21-2015, 06:43 PM
  2. Lg g2 i want my display to light up when i have a text.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-11-2014, 04:45 PM
  3. how to root a Samsung Galaxy Tab 1
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 09-11-2014, 02:15 PM
  4. Copying playlists to Samsung s5
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-11-2014, 01:54 PM
  5. Replies: 0
    Last Post: 09-11-2014, 01:27 PM
LINK TO POST COPIED TO CLIPBOARD