1. maxburn's Avatar
    I have had the phone for a couple days now and it's been pretty good. I got it with a couple magnetic charging cables and that worked ok until today. Now the phone won't charge through the side port, when connected the charging indicator (software and hardware) blinks on and off.

    I'm not sure if it is related but I tried turning the phone off and I was going to reboot it to try and fix the above but I discovered the phone will not turn off, it will turn the screen on and display sony then turn the screen back off. A few seconds later it will turn on and display sony again. It will continue to cycle this way apparently forever. Seems strange to me but I've never turned the phone off.
    09-20-2014 08:21 AM
  2. maxburn's Avatar
    Found mention of the red hard reset button online but it didn't seem to fix anything. It will get the phone all the way off but on the next power on it will behave the same while charging and when powered off in android it will never shut off, just slow flashing sony.

    It also appears that the phone killed the charging port on my Anker charger that it was using. Other ports work on my other devices still but none of my chargers will charge the phone with the magnetic cable now.

    So I guess my phone is broken now. Beware of the magnetic charging port, it isn't as well thought out as apples.
    09-20-2014 08:34 AM
  3. maxburn's Avatar
    No one else has experienced this?
    09-27-2014 06:50 AM
  4. thatdennis's Avatar
    No one else has experienced this?
    No, that's a rare case.

    Did you use the Sony official charging dock? If not, then what brand/what type is it?

    It might be a side magnet faulty, I read somewhere of a guy's magnetic side port breaking off
    10-04-2014 08:35 AM
  5. maxburn's Avatar
    Nothing seemed broken physically but there was definitely something wrong electrically. That charging port never worked again and I returned the phone. Not sure what I'm going to go with next.
    10-04-2014 09:35 AM
  6. rob damiani's Avatar
    My z2 is the same ; While charging via magnetic charging cable,dock or even connected via Micro-USB, phone will not stay "off" it just automatically reboots. Very annoying. I'm running CyanogenMod FYI.
    10-11-2014 08:26 AM
  7. maxburn's Avatar
    That's not what mine was doing, mine was clearly broken as it wouldn't charge.
    10-11-2014 08:28 AM

Similar Threads

  1. One of my quad core processors is not working.
    By vitalin in forum Samsung Galaxy S5
    Replies: 15
    Last Post: 08-27-2017, 06:36 PM
  2. Charging sign shows but battery only goes down
    By Liron Shekel in forum Samsung Galaxy S4
    Replies: 5
    Last Post: 06-28-2016, 04:30 PM
  3. Anyone else NOT do the update yet?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-20-2014, 04:35 PM
  4. Replies: 0
    Last Post: 09-20-2014, 07:37 AM
  5. Google Play services not supported by device
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-20-2014, 07:33 AM
LINK TO POST COPIED TO CLIPBOARD