1. ktcred's Avatar
    Happy Friday!

    I upgraded my Sony Z3c this past Sunday to Marshmallow and all, but one item, has been great. The one item, however, is quite annoying. My outbound group messages transmit as single SMS / text messages to each recipient. All inbound messages are handled/grouped correctly. I've tried several troubleshooting steps with little luck and I'm going on the assumption that there is a bug in the update (see IMEI below....has to be that, right?). Are others having this issue and, furthermore, has anyone discovered a fix? Here are the details:

    Current Setup
    • Carrier: AT&T
    • Android Version: 6.0.1
    • Build Number: 23.5.A.0.575
    • Default Text Messaging App: Google Messenger 1.8.268
    • Device: Sony Z3 Compact


    Issue
    I can't send outbound group messages via Google Messenger's MMS. When I attempt to send a group message, they are sent as individual messages. Inbound messages are grouped, however. Further, I can use third party apps to send and receive group MMS messages

    Troubleshooting Steps and Results
    • Step: Check Google Messenger Settings for Group Messaging MMS option --> RESULT: There is no option to group messages via MMS. When I click Settings > Advanced, all I see options for are "Auto-retrieve" and "Roaming Auto-retrieve" as it relates to MMS. I thought there used to be an option to group via MMS and it is now missing.
    • Step: Try Alternative Messaging App - I tried chompSMS as well as Google Hangouts --> RESULT: Both of these *worked* as intended. I have no issue grouping messages, both inbound and outbound, via MMS. While this works 1) I want to know why it doesn't via Messenger and 2) I don't want to use these apps
    • Step: Call AT&T and Re-Register Device - I called to ensure everything was correctly configured --> RESULT: The re-registerd the device and everything checks out OK...sort of...see IMEI below that I personally discovered
    • Step: Cross Reference IMEI Information - I checked my phone to ensure all of my IMEI information checked out. --> RESULT: Something is messed up, but I'm not sure if this is the root cause. Settings > About Phone > Status > IMEI Information is missing one digit. It does not balance with what AT&T has (when I called) or what is under Settings > About Phone > Status > SIM Status > IMEI as well as *#06# in a keypad (which is basically the same thing). In short, my phone says my IMEI is 14 digits and my SIM card says it is 15 digits (which is correct...but I need to check my box to verify)


    Assumptions and Questions
    • I'm guessing that the IMEI mismatch is causing the issue
    • Anybody else seeing this on AT&T with the Z3c since the recent update
    • Any other leads or ideas?


    Thanks in advance for your help!

    EDIT: New troubleshooting step...

    I switched SIM cards with my wife's Nexus 5X. I still could not send out group texts via the Google Messenger application. (I had no problem on her phone with my SIM card, so we can remove AT&T as a culprit.) I also validated that her IMEI numbers matched exactly in the aforementioned status locations. Lastly, I did verify that her Google Messenger app has the "Group Messaging" option available in the settings, where it is missing in mine. We are both o messenger version 1.8.268. However, the sub version is different. I'm assuming there are different variants based on the device. Mine reads 2875715-36.phone and hers 2875715-40.phone.

    I'm back to the IMEI discrepancy. I'm going on the assumption that the messenger app hides the Group Messaging option automatically if it sees a discrepancy.
    06-10-2016 02:53 PM
  2. ORA1's Avatar
    both my IMEI numbers are the same , in SIM and IMEI status.
    My phone has no issues at all. Everything works like a dream so far.
    Love it.
    Not to say nothing will happen in the future, but i am positive
    06-11-2016 05:25 AM
  3. The_Original_Zon's Avatar
    Hi I am having the exact same issue.

    Current Setup
    Carrier: AT&T
    Android Version: 6.0.1
    Build Number: 32.2.A.0.305
    Default Text Messaging App: Google Messenger 2.0.069
    Device: Sony Xperia Z5 Premium

    I have also verified my MMS settings with AT&T and everything checks out. I also have tried multiple steps to troubleshoot with no success. I also do not see the "Group Messaging" menu under "Advanced." I like Messenger and would like to keep using it.

    I also see the IMEI discrepancy you're talking about but I feel like this is not causing the issue. Rather the build from Sony has a bug,

    I feel your pain, you're not alone.
    ktcred likes this.
    11-15-2016 06:44 PM
  4. ktcred's Avatar
    I've since upgraded to the Sony Z5 Compact and the issue remains. When I first unboxed the device, everything (i.e., the IMEI numbers) checked out OK. However, once I upgraded to 6.0.1, the last number of my IMEI disappeared, as described above. I'm using Textra and it hasn't been an issue. That said, I'm quite annoyed and it was fun to originally troubleshoot. I agree with you that this is a Sony bug of some sorts. Misery loves company, so thanks for the reply.
    11-15-2016 06:51 PM

Similar Threads

  1. June security patch + firmware update, Global G935F, rolling out
    By ironass in forum Samsung Galaxy S7 edge
    Replies: 62
    Last Post: 06-22-2016, 04:02 PM
  2. Lasso Capture not on Shield K 1
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-16-2016, 04:10 AM
  3. LG G5 NFC Issues
    By jojo1281 in forum LG G5
    Replies: 3
    Last Post: 06-14-2016, 05:01 AM
  4. How do you reduce data usage on Android phones?
    By Christine Lachance in forum General Help and How To
    Replies: 4
    Last Post: 06-13-2016, 01:08 AM
  5. Replies: 2
    Last Post: 06-10-2016, 11:20 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD