1. blahdre's Avatar
    I've had my xperia z3c for a while now and while i love the phone, I've been noticing that I haven't been receiving group texts/messages. I downloaded Textra and even tried Hangouts for a while but I still fail to get group messages from my coworkers (who are largely iPhone users). Has anyone had similar issues and if so, were you able to find a solution? I'm afraid that if I cant fix this, I'll have to switch to an iPhone myself or back to Windows Phone...
    12-15-2014 01:47 PM
  2. strav22's Avatar
    Its a known issue with the z3. The minute I got the z3, I turned off VOLTE and wifi calling. I'm not sure if the Z3c has these features.
    12-15-2014 02:54 PM
  3. blahdre's Avatar
    I dont think it does. When i go to Call Settings, the "Enable VOLTE" option isn't there...
    12-15-2014 02:59 PM
  4. strav22's Avatar
    I dont think it does. When i go to Call Settings, the "Enable VOLTE" option isn't there...
    Try this app: https://play.google.com/store/apps/d...apps.messaging

    I've read that it could be your APN settings. Not sure what the correct settimgs should be.

    Posted via the Android Central App
    12-15-2014 06:31 PM
  5. Ebaneeezor's Avatar
    I had the same issue - only fix is a workaround for now. I use google messenger as my default text app, not the sony one - and I prefer it, problem solved. (most at work have iPhones, same situation for me. Link below fixed it for me)

    https://play.google.com/store/apps/d...apps.messaging
    12-16-2014 05:12 AM

Similar Threads

  1. Quick Capture on my X not working properly?!!!
    By motofanforever in forum Moto X (2014)
    Replies: 5
    Last Post: 12-26-2014, 07:13 AM
  2. Why am I not receiving some text messages on my Droid Turbo?
    By Zalendar in forum Motorola Droid Turbo
    Replies: 2
    Last Post: 12-16-2014, 05:38 AM
  3. Replies: 1
    Last Post: 12-15-2014, 01:31 PM
  4. Replies: 1
    Last Post: 12-15-2014, 10:04 AM
  5. Replies: 0
    Last Post: 12-15-2014, 04:05 AM
LINK TO POST COPIED TO CLIPBOARD