1. AC Question's Avatar
    Hello,

    I have a Sony Xperia Z3 (have only had it a few weeks) and have a bit of a head scratching problem.

    From Friday onwards the phone has been regularly losing it's Network Connection, however a simple reboot of the phone seemed to rectify the problems I have been having. On further inspection it seems the actual Mobile Data aspect of the device is working fine however there seems to be no coverage for Voice calls or SMS, I've tried sending and receiving text messages, phone calls, you name it I've tried it and none of it has work. I've made sure that I have turned Wi Fi off, which i have as the phone seems to be fine when browsing the internet, using Facebook or Twitter.

    I have gone into Settings and tried to re-register it to the correct Network that is available to me and for some reason that fails. So naturally the next step will be to perform a Factory Reset. Before I do this, does anyone think that I could be missing something relatively simple? It's not in Airplane mode.

    Thanks in advance.
    03-08-2015 01:22 PM
  2. Rukbat's Avatar
    Bad 2G radio, bad 2G modem, who knows? It's under warranty, have it repaired or replaced.
    03-08-2015 01:41 PM
  3. Ashley Chamboko's Avatar
    I found the fix for the issue. Under Phone Info *#*#4636#*#*: The network type was disconnected, hence, switching from GSM/CDMA auto (PRL) (which had no affect) or any other for that matter, and then to GSM auto (PRL) and Voila, it was connected to GSM. Ran ping test and could resolve to hostname (google.com)
    08-14-2015 07:23 AM

Similar Threads

  1. GS6 Fingerprint Security-how does it work?
    By jcp007 in forum Samsung Galaxy S6
    Replies: 15
    Last Post: 03-25-2015, 08:11 AM
  2. Screen dims but doesn't go comletely off.
    By hal1 in forum Motorola Droid Turbo
    Replies: 9
    Last Post: 03-12-2015, 05:15 AM
  3. Why won't my Google Play store work?
    By luv8797 in forum Google Play Store
    Replies: 1
    Last Post: 03-09-2015, 01:05 AM
  4. Sounds, but the screen is black
    By storeygirl10 in forum Samsung Galaxy Tab S 10.5
    Replies: 2
    Last Post: 03-08-2015, 02:09 PM
  5. Why won't my gallery/ camera work properly?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-08-2015, 12:51 PM
LINK TO POST COPIED TO CLIPBOARD