1. AC Question's Avatar
    From the slide down menu at the top, pressing either wifi or Bluetooth doesn't turn them on. Going into settings and doing it there, Bluetooth turns on for a few seconds then automatically slides itself off again without me touching the screen; while wifi turns on and stays on but doesn't actually do any searching it appears to freeze, and if I go off the screen and come back to it straight away it has switched itself off again.
    I have run diagnostics and says they are both working fine, however gps can't switch one (don't know if that's related).
    I have the newest software that came out last week.
    I have tried restarting phone over and over to no effect.
    Any help would be greatly appreciated
    Thanks
    04-20-2015 04:44 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try a cache partition wipe: https://support.t-mobile.com/docs/DOC-16654
  3. B. Diddy's Avatar
    Welcome to Android Central! Try a cache partition wipe: https://support.t-mobile.com/docs/DOC-16654
    04-20-2015 12:34 PM
  4. e_potter13's Avatar
    Hi,

    Thank you for the response, this unfortunately has not solved the issue and I still cannot turn wifi/Bluetooth on. Any other suggestions?

    Thanks
    04-21-2015 08:51 AM
  5. B. Diddy's Avatar
    Ok, try Safe Mode, in case some 3rd party app is causing some kind of interference: https://support.t-mobile.com/docs/DOC-16643
    04-21-2015 10:26 AM
  6. e_potter13's Avatar
    Still can't turn either on in safe mode. Thanks for your continued help!
    04-21-2015 02:29 PM
  7. B. Diddy's Avatar
    Did this only start after the recent system update?
    04-21-2015 09:07 PM
  8. e_potter13's Avatar
    Yes, I think it worked for a couple of days after before breaking.
    I did download the app Yik-Yak, but deleted it before speaking to you in case it was causing the issue but no luck.
    04-22-2015 04:34 AM
  9. B. Diddy's Avatar
    I wonder if the update itself is glitchy, or if it's a temporary system glitch. At this point, the only other thing I can suggest is a full factory reset. Make sure you backup or sync all of your data first. You can backup app data by using Helium.
    04-22-2015 10:38 AM
  10. e_potter13's Avatar
    Hi, sorry I've been a while. I didn't want to rush into reset.
    I have now done the reset to no prevail, and actually if anything it's worse as now I have to waste all my monthly data to redowload everything.
    Do you have any further suggestions that would help me out or do you think I need to replace my phone?
    Thanks
    06-05-2015 07:28 AM
  11. Sivakumar Seshadri's Avatar
    Even I am facing the same problem, i have done several things its clear its a software update issue as it was working perfectly before

    i have tried the followoing

    1. factory reset two times
    2. wipe cache partition
    3. removing all apps installed other than the standard ones
    4. diagnostics
    5. enabled developer mode and USB debugging and tried all settlings

    when nothign worked i reverted it back to factory reset and still its not working

    its now more than 3 weeks i have done a lollipop upgrade and after that it started, the phone is working fine on 3G but i am wasting data

    i called up sony customer care they have no solution as well,
    06-19-2015 03:31 AM
  12. Sebastian Kaliszuk's Avatar
    This happened to me this morning and I used factory setting but nothing has changed. I'm still unable to connect to the Wi-Fi or use Bluetooth. Let me know if you find the solution
    06-20-2015 05:19 AM
  13. Jonathan Farrugia's Avatar
    I have the same problem and factory reset does not work. talked to a sony customer care and told me to connect to the sony pc companion and try to fix it from there. still didn't tried this option but will in the next few days.
    06-22-2015 10:39 AM
  14. Sergio Sonego's Avatar
    this happened to me twice:
    first time: when i upgraded to lollipop via OTA. after this wifi dropped constantly. the solution was a complete reinstall of the OS with sony pc companion.

    second time: after some weeks wifi issues again, this time i could not start up wifi (it says "activating wifi" and stays so)...
    took it to a service, and they told me the wifi-bluetooth chip is burned :-(

    i really like this phone, it suits all my needs, i am thinking to buy another same one, but afraid of this issue... i do not like samsung :-P

    do you use usb charger or magnetic charger (i use a non official magnetic charger). i wonder if this could have burned the chip...
    07-15-2015 04:56 PM
  15. MisterRico's Avatar
    2 weeks ago I got the same problem, I believe after some Android update. I have D6633 build 23.1.1.E.0.1. I tried everything saw in different forum and finally after asked RMA, shipped my phone to a Sony Care Center. Today my phone came back, I tried, same problem. I checked the rapport, said not repaired. Now I am waiting Sony reply my emails.
    07-21-2015 07:18 AM
  16. abhijitkhandare's Avatar
    Hi I had the same issue a Week back with my Sony Xperia Z3 compact -- Model # D5833.

    An auto software update in lollipop and the Wifi and Bluetooth stopped working.

    After speaking the the customer service expert (on chat) --Xperia Support center-- initially he advised me
    1. To start the phone in a safe mode -- (press the power button for 3-4 secs you get the option) but that didnt help.
    2. Next he asked me to do a repair through Sony Companion which I had installed on my laptop --- did it --reinstalled the whole software after wiping the complete software including cache--but to no avail.
    3. Finally when he had no solutions left.. he asked me to show it at the authorized Sony service center as it was under warranty.

    I followed his instructions as did not want to experiment with my 7 months old handset, went next day to the Sony authorized Service Centre India (Mumbai) (17th Aug'2015) they said its a software problem and needed a day to rectify. But when I called them the next day to check on my phone status, they shared its a hardware problem and have sent across to another center which will do the hardware repair and will take maximum a week.

    So the week is going to end after a couple of days....I will keep you guys posted on the update.

    The suggestion which I would like to share is, if you are having a similar problem run and go to the authorized service centre and leave the rest to the experts, without experimenting yourself.

    So once I will receive my handset in a weeks time ....I will share you the status....on the exact issue with the device.

    Yes....So I am back with the actual solution to this....the update is from the authorized service centre

    After taking the phone to the authorized Sony Service centre (India - Mumbai), they shared it is a hardware issue with some of the batches, with the recent update of lollipop via OTA is making the hardware (Motherboard) to crash.

    Since my phone is under warranty they will be replacing the Motherboard which is the only solution to this. Even downgrading it to Kitkat and repairing it via sony PC companion didn’t help.

    so they would be replacing the Motherboard (Please note my phone is under warranty). For people with phone warranty elapsed, have to shell out from their pockets.

    People with the same issue dont waste your time by working on the software go to the authorized Sony service centre and fix your hardware.

    Though I love my Xperia Z3c......I think these are some of the batches of motherboards which Sony has to look into as I came across a lot of similar issues on many forums especially with the new update hampering the hardware .......Sony Experts and Customer Care .....please make a note of this.....as you will loose on good (Elite) customer loyalty.....
    08-26-2015 03:39 AM
  17. syedali120's Avatar
    Hi,

    I had this same problem with my z3 yesterday. I managed to fix it by luck when I was getting ready to transfer the content from the z3 back to the z2.

    If you have the Sony xperia transfer mobile app on the phone, launch it.

    1. Select xperia as your other device. It don't matter if you don't have another phone because your not going to complete the process.

    2. Select "Direct" for transfer method

    3. Select "send" for Device mode

    4. Hit next

    5. Select cable for connect device. When you do this, the phone should then say that it is going to use Bluetooth to compleat the rest of the transfer, say OK and that should switch the WiFi and Bluetooth back on.

    It did for me. I hope it works for you to. If it don't, I must have got lucky with mine.

    Good luck.
    12-20-2015 02:50 PM
  18. saitiecombat012's Avatar
    i have the same issue about this problem di i used hard reset to fix it? i would'nt try it.
    07-24-2016 08:54 PM
  19. feruz atan's Avatar
    this method doesnt work on my xperia.

    Hello Sony.......anybody still there in the office?
    10-13-2016 10:55 PM
  20. Subsessed's Avatar
    this method doesnt work on my xperia.

    Hello Sony.......anybody still there in the office?
    Sony will only advice you to contact Service centre... Then they will only advise you to try doing the PC Xperia companion, reinstall.

    If PCC fails, and you still have issues. It's highly plausible, that the issue is hardware related. Meaning, it can be fixed under Warranty. Or you'll need to pay Sony to repair it, if your warranty lapsed, or was voided through a DYI repair.
    01-29-2017 09:01 PM

Similar Threads

  1. Z3 storage
    By bytemarx in forum Sony Xperia Z3
    Replies: 6
    Last Post: 06-29-2015, 07:37 PM
  2. How can I get contacts from my hotmail onto my Android phone?
    By AC Question in forum General Help and How To
    Replies: 3
    Last Post: 04-20-2015, 08:26 PM
  3. Replies: 5
    Last Post: 04-20-2015, 05:23 AM
  4. Replies: 1
    Last Post: 04-20-2015, 04:26 AM
  5. Replies: 0
    Last Post: 04-20-2015, 03:15 AM
LINK TO POST COPIED TO CLIPBOARD