1. Jli72's Avatar
    I got a Z3 D6603 with no LTE. Only network option i have is 2g/Edge which sucks. Any help would greatly be appreciated.
    11-18-2015 09:16 PM
  2. MSFTisMIA's Avatar
    Mine gets LTE just fine. Did you manually enter in the right settings?

    Posted via Xperia Z3
    11-26-2015 07:15 AM
  3. BenL's Avatar
    Under the Network settings, make sure that for "Internet Settings" you have T-mobile selected.
    Also under Network settings. make sure that you have LTE selected under Mobile Network Settings -> Prefered Network Type.
    11-28-2015 02:42 PM

Similar Threads

  1. Replies: 2
    Last Post: 12-04-2015, 03:00 PM
  2. No "Wave to Silence" in Moto Actions
    By kuyawil in forum Motorola Droid Turbo 2
    Replies: 3
    Last Post: 11-19-2015, 05:32 AM
  3. Xperia M5 MMS Opening Wrong Picture, why?
    By AC Question in forum Sony Xperia Series
    Replies: 0
    Last Post: 11-18-2015, 08:11 PM
  4. Replies: 0
    Last Post: 11-18-2015, 06:54 PM
  5. Replies: 0
    Last Post: 11-18-2015, 06:03 PM
LINK TO POST COPIED TO CLIPBOARD