1. uscpsycho's Avatar
    Every time I sync my calendar I either get "The application Google services Framework (process com.google.process.gapps) has stopped unexpectedly." or sometimes "The process com.google.process.gapps has stopped unexpectedly. Please try again."

    After sync fails when I go to the manual sync screen I see this alert: "Sync is currently experiencing problems. It will be back shortly."

    I've had this happen before and clearing user data used to do the trick. Not this time. So I tried deleting every single item in my online Google calendar as well as every item on my phone. Having a clean slate with no events didn't help but a totally new problem seems to have been triggered by this mass deletion.

    Now after a failed sync I get an error in the toolbar that says "Too many calendar deletes" and when I click on it I see:

    Delete limit exceeded
    There are 331 deleted items for Calendar, account xxx@gmail.com. What would you like to do?
    • Delete the items.
    • Undo the deletes.
    • Do nothing for now.

    None of the three options fix the sync problem. Nothing I can think of fixes the problem. The sync problem started in EI22 but persisted after updating to EL30. I've never rooted my phone and would like to avoid rooting or doing a reset that would cause me to lose all my data.

    I very heavily rely on my phone's calendar and am totally lost without it. Any suggestions?
    naillady541 likes this.
    01-27-2012 06:51 AM
  2. ShaLea's Avatar
    i had the same problem periodically on EI22 but only w/9 deletes. I would hit delete items and nothing happened. I ended up doing a factory reset, deleting all of my apps, and the problem stopped.

    I hope this doesn't happen w/EL30.

    What calendar app are u using? I'm primarily using Business Calendar. Could it be a glitch in the App?
    01-27-2012 09:10 AM
  3. uscpsycho's Avatar
    I use Business Calendar as well. I regularly got the "The application Google services Framework (process com.google.process.gapps) has stopped unexpectedly." error, but clearing data always fixed it.

    This time the error hit me shortly after I started syncing my Google Calendar with iCal. Not sure if that had anything to do with it but I was definitely making Google work hard, my calendar was syncing with Outlook, Android and iCal. But I don't see why this should result in a terminal error on my phone.

    I'm starting to get the feeling that only a factory reset will save me too. Which means I might finally cave in and root my phone so that I can do a proper backup/restore. My concern is that if I backup/restore some corrupt file will make it's way back and the problem will come right back.
    01-27-2012 02:38 PM
  4. uscpsycho's Avatar
    Well I rooted my phone and fixed the problem without having to do a factory restore. Relief!

    After rooting I used Titanium Backup (the free version) and did the following:

    Business Calendar -> Wipe data
    Calendar -> Wipe data
    Calendar Storage -> Wipe data
    Google calendar sync -> Wipe data

    After doing that calendar sync started working fine and the errors disappeared.
    tonny.madsen likes this.
    02-20-2012 11:24 PM
  5. lordfire00's Avatar
    Most errors are caused by corrupt data.

    Sent from my SPH-D700 using Tapatalk
    03-07-2012 02:28 AM
  6. Christopher Scollo's Avatar
    Go to Settings > Applications > Manage Applications > All > Calendar Storage > Clear data.
    04-01-2013 04:54 AM
  7. Nathan B2's Avatar
    Lots of people have suggested doing clear calendar storage, but won't that delete the contents of the calendar and actually defeat the purpose of sync'ing successfully? I think the reason normal Calendar sync doesn't work is because Android is a 'trash' OS riddled with bugs just like Windows.

    I'm looking forward to Firefox OS.
    07-28-2014 06:42 AM
  8. p_p_s's Avatar
    After Settings > Applications > Manage Applications > All > Calendar Storage > Clear data and Settings > Applications > Manage Applications > All > Calendar > Clear data, the issue was still there. I needed to go to Calendar > Settings > Accounts (All calendars) > Google xxx(at)gmail.com ... > and uncheck Holidays in United States.
    05-25-2015 06:43 AM