1. csdude55's Avatar
    I've had a 4S for several years with no problems, and I convinced my MIL to get one. Naturally, there are problems! LOL Just to make me look like an *****.

    When I plug the phone in, the upper right light comes on, the brightness increases, and it flips to WiFi automatically, so it's recognizing that it has been plugged in. But the battery doesn't charge. When I go to Settings > Status, it shows "Discharging".

    It's worth noting that when I plug it in, there's no "per-lunk" beep like there is in my phone.

    I've tried changing batteries, with no apparent change. I also tried three different chargers (the one that came with her phone, one that came with my Kindle that's plugged in to the wall, and the one I use on my phone that's plugged in to my computer's USB), and they all worked the same... which is to say, not at all.

    My MIL mentioned that she had it charging in her car one day and it got REAL hot; after that is when the problem started. So in the hopes that this was still a software issue (a rogue app killing the CPU or something), I did a complete factory reset. But, I wasn't shocked that this didn't solve the problem, either; it was just a Hail Mary.

    So, after ruling out software, the charger, and the battery, this leads me to the physical port being the problem. I went over it closely, and everything seems to match up with the port on my phone (the working one). The connectors aren't bent, and I couldn't find anything shorting them. I blew in to it with compressed air, but that didn't seem to make a difference.

    I'm guessing that there's a switch in the port that turns on the light, etc, when it's plugged in, but that doesn't guarantee that a viable connection has been made? That would explain why it seems to be charging when it's not.

    My next guess is that when her car charger made it get so hot, it fried something in the port circuit board. If that's the case, is the port something I can buy online and replace myself? This phone is a refurb, and AFAIK it only had a 30 day warranty, which has now expired, so sending it back isn't an option.

    Or, do you guys have any other suggestions?
    06-06-2014 04:25 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Your reasoning is sound--I would also suspect the charging port. I think you're right, one of the connections might have been fried. Hard to know if replacing the port would help, because maybe the circuit that fried is downstream somewhere, rather than in the port. You might consider bringing it to a cellphone repair shop to get a quote.
    06-06-2014 12:19 PM

Similar Threads

  1. Replies: 2
    Last Post: 06-07-2014, 07:42 PM
  2. Does the Samsung Galaxy S4 Active fit in a regular S4 case?
    By SylviaBollinger in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 06-06-2014, 03:59 PM
  3. Replies: 0
    Last Post: 06-06-2014, 01:00 AM
  4. The phones I've used to get here
    By Torisen1 in forum Sony Xperia Z2
    Replies: 0
    Last Post: 06-05-2014, 10:54 PM