1. slope72's Avatar
    After my 2.2 update, the Android Market has been seriously wonky on my Epic. When I view "My Apps" in the Market and try to click through to any of the apps from there, i get a popup saying "The requested item could not be found". It doesn't happen with ALL the apps, but there doesn't appear to be any clear rhyme or reason as to what's causing this. The apps are all there on my phone and working properly, I just cant' pull them up through My Apps in the Market. This means that I can't update a bunch of my apps, rate them, or do any of the things you do through the Market app.

    Any suggestions? I already tried clearing the cache and data in My Applications.
    03-31-2011 08:48 PM
  2. vansmack's Avatar
    Mine took a few days to update. I upgraded to EC05 on 3/26 and my Android Market app didn't full populate all of my apps until 3/30 or 3/31.

    Not sure what the problem was, but it's fine now. If you search for them though, I was able to update them. Interestingly enough, it said "installed" when I found the app - it just wasn't listed in "My apps" for a few days.
    04-01-2011 01:48 PM
  3. slope72's Avatar
    Well, my apps are listed in My Apps. I just can't tap them for more information or to update.
    04-01-2011 02:09 PM
  4. rickurb's Avatar
    I am having the same issue. All my installed apps show up when I list "My Apps" in the Market. However, If I press on the app (in My Apps) it does not always list the app details(only around 50% work). I just get "Not Found...The requested item could not be found". It's almost like my apps are out of sync somehow with the Market files. I have cleared the Market App cache, cleared data, uninstalled the Market update and let it reload again. Still, not working. I used the the Odin without wipe update from EB13 to EC05. I was wondering if this could have caused the problem.
    04-04-2011 12:54 PM
  5. duanebb's Avatar
    It looks like the market is not working correctly.
    Anybody know for sure?

    NEVERMIND - I cleard cache and data and was able to get it working correctly.
    04-04-2011 02:58 PM
  6. slope72's Avatar
    I'm the OP. I have a stock, unmodded Epic. My Market is still not working correctly after two weeks with Froyo. About 80% of my apps turn up the "Not Found" error when I tap them from My Apps. If there are multiple updates to my apps, I can USUALLY update without problems by tapping "Update All" (although usually one app fails to update correctly). If there is just one app to update, however, I can't do it bc tapping on it returns the "Not found" error.

    This is turning into a serious problem for me. Please don't tell me I have to wipe my phone.... that was always the only answer to problems with my old Palm Pre.
    04-04-2011 06:09 PM
  7. rickurb's Avatar
    I also have no problem syncing to AppBrain and bringing up app details from there, However, when I click on the Market from AppBrain I get "Not Found...The requested item could not be found" for various apps. My wifes Epic does not have this problem and I updated both of ours to ECO5 the same way. I can't think of anything else to try. Like Slope says, the main problem is not being able to update apps from the market.
    04-04-2011 07:07 PM
  8. shonangreg's Avatar
    I've been having the same problem for a few weeks (aldiko was the first or second app for this to happen to with me). It does seem to be random as to which apps are not found. After a reboot, google maps was found whereas before it wasn't, for example.

    I have just found that while in market, a long push on an app, then selecting "update" is working every time.

    For reference:
    - Xperia X10 (Japanese version)
    - android 2.1
    - rooted with superoneclick
    - I've used "Market Enabler" but I think it was set back to the original location correctly
    - appbrain (though it wasn't used in this round of updates)
    04-07-2011 09:00 AM
  9. rickurb's Avatar
    The long press method works for my updates also. Thanks for the tip. I wish there was a real fix for this problem.
    04-07-2011 07:09 PM
  10. shonangreg's Avatar
    This method does not allow for evaluations of the applications, though. One of my apps, namazu, just gave me a 30-second warning of last night's earthquake, telling the distance and magnitude. When it hit here, I knew how bad it would become and could relax and just observe. Fantastic usefulness.

    However, when trying to give it five starts and feedback, the market said the app was nowhere to be found :-(
    04-07-2011 08:15 PM
  11. jeadly's Avatar
    Yup, same thing here. Stock Epic, OTA Froyo update.

    Sometimes searching for the app results in it showing the page when it refuses to display from the My Apps list. Sometimes not though. Seems really random.
    04-08-2011 09:48 AM
  12. dvo777's Avatar
    In the Market / Google Play app go to Settings. There is a content filtering pulldown. Check "Show all apps" or "Mature" in order to allow showing all apps.
    The terms used by Google for the maturity settings appear pretty unclear.
    11-08-2012 03:30 PM
  13. ratsttam's Avatar
    Way to bring that one back from the dead. The last post was from 4/2011, it is now 11/2012, and in the meantime there was another update from 2.2 to 2.3. But certainly good info for anyone just now upgrading their Epic 4g to 2.2
    fjitb likes this.
    11-09-2012 11:30 AM
  14. fjitb's Avatar
    caught those dates too and was like wtf, lol
    11-09-2012 11:37 AM
LINK TO POST COPIED TO CLIPBOARD