05-09-2011 06:24 AM
39 12
tools
  1. slope72's Avatar
    Stock, unrooted Epic here and I'm getting the same problem. Just started on May 1.
    05-04-2011 09:06 AM
  2. RandomKing's Avatar
    Stock, unrooted Epic here and I'm getting the same problem. Just started on May 1.
    I went ahead and manually changed the date through all the months... It appears that only May doesn't display right. Damned if I know why...
    05-04-2011 09:58 AM
  3. Paul627g's Avatar
    Look at it this way, we have a whole month of something to complain about and even more to look forward to next month when this should be gone...

    I'll just keep running Honeycomb Fusion 2.0 theme and not have to worry about it.
    05-04-2011 10:27 AM
  4. boomerbubba's Avatar
    I went ahead and manually changed the date through all the months... It appears that only May doesn't display right. Damned if I know why...
    Are the other months spelled-out, or abbreviated?

    Edit: Never mind. I tried it myself. The other month names are abbreviated -- for exampe, "Apr. 01"

    So the cause of the bug is pretty obvious: The reason May dates do not display properly in the window is that the letter W takes up more space than any other capital letter except W in most fonts, and no months begin with W. So May dates don't fit in the window provided and the app tries to wrap the text.

    An aggravating problem is that unlike other months, May is not an abbreviation. Yet the screen-lock app stupidly includes a period after May.

    It's a close fit. The proportiately spaced rendering of "May. 01" does not fit, but "Mar. 01" does fit. That's because the lowercase "r" is narrower than the lowercase "y" in this font. So just dropping the period, which is really superfluous, might solve the problem.
    05-04-2011 10:28 AM
  5. hybrid85's Avatar
    I noticed this too... I had been playing around with different lock screen apps then went back to the stock one and noticed the date was getting chopped off. I thought I somehow screwed up the data so I went in settings to look if I could change the way the date was displayed but that didnt help. I ended up doing what Jaggrey did and just set my lock screen to the pattern. Doesnt fix the problem, only provides an alternative lock screen with a date and time that I can actually see.
    05-04-2011 01:03 PM
  6. lafountain's Avatar
    I manually changed my date to April temporarily and it worked fine. Switched back to the actual date and it was cutoff again, so it has something to do with May.

    Stock unrooted as well by the way.
    05-04-2011 02:30 PM
  7. boomerbubba's Avatar
    I manually changed my date to April temporarily and it worked fine. Switched back to the actual date and it was cutoff again, so it has something to do with May.
    Yes. The root cause is pretty obvious. See above.
    05-04-2011 03:04 PM
  8. carraser891's Avatar
    you guys should just switch to the stock pattern unlock. It shows the date and looks better (i think)
    05-04-2011 06:07 PM
  9. boomerbubba's Avatar
    you guys should just switch to the stock pattern unlock. It shows the date and looks better (i think)
    As a matter of fact, that's what I normally use. But I do it for reasons of security -- even though it is very aggravating to swipe the pattern many times a day to access the device. The whole-phone lock mechanism is the strongest protection there is for personal data stored on board.
    05-04-2011 07:44 PM
  10. chris41g's Avatar
    05-05-2011 04:13 PM
  11. TexasEpic4G's Avatar
    THX = that worked ! TouchWiz Lock Screen Fix Stock and SRF
    05-05-2011 09:05 PM
  12. LiGhTMaGiCk's Avatar
    I assume one must be rooted to use this? Sucks for me I'm still too scared to root my phone yet.
    05-05-2011 10:25 PM
  13. Bmwillz's Avatar
    Same here
    05-05-2011 10:28 PM
  14. KC2UUZ's Avatar
    It's a May bug. Has to be. April was fine. Should we have expected anything even near perfect from Sam?
    05-09-2011 06:24 AM
39 12
LINK TO POST COPIED TO CLIPBOARD