1. NewNexusUser99's Avatar
    Hi Android Central,

    I recently purchased a used Galaxy Nexus (Sprint) on the internet and I am not able to "successfully" update it to Jelly Bean. After clearing the data and force closing the apps.... a newly available 173.8 mb software update appears.

    After downloading the update, pressing restart & install, etc. my phone seems to shut down and install the update (i.e., a green Android icon appears with its belly open as the OTA update appears to install).

    But, after the phone completes the update and then reboots, it still says that I have Android 4.0.4! Nothing changes! Am I doing something wrong?

    Or is it possible that the previous owner of the phone may have tinkered with something causing my Galaxy Nexus not to properly install the JB update?

    I repeated the process of downloading and installing the 173.8 mb OTA update numerous times but am still left with 4.0.4 each time after reboot. Is there something wrong?

    How do I install Jelly Bean on my Nexus? Also, is there an alternative method that safely bypasses the OTA update?


    Terrance H.

    Android version

    Baseband version
    L700.05 V.FG01 / L700.FG01

    Kernel version
    android-build@apa28 #1
    SMP PREEMPT Fri Jan 27 17:44:51 PST 2012

    Build number
    10-13-2012 06:02 PM
  2. .The Word Alive.'s Avatar
    I would try a data factory reset. Other than that I wouldn't really know what to do.

    Sent from my Galaxy Nexus using Android Central Forums
    10-13-2012 06:14 PM
  3. gnr_2's Avatar
    Try updating all the Sprint stuff first.

    Sent from my Sprint Galaxy Nexus
    10-13-2012 06:45 PM
  4. ratsttam's Avatar
    You can always follow the directions to download and install via ODIN, it will force it onto JB and remove any traces of former tinkering.
    The updates will fail if rooted/unlocked, or if some of the factory software has been tampered with (remove stock apps, push other apps into system/apps folder.
    Just a couple things to consider.

    Now, Does you phone say "Google" in the middle, with an unlocked padlock under it, or is it just the "Google" logo in the middle of the screen. The presence of the padlock says it's been opened up and more than likely tinkered with.
    10-16-2012 03:05 PM
  5. NewNexusUser99's Avatar
    The phone just says "Google". Also, I noticed that the OTA "update & install" to Jelly Bean fails... with a red triangle indicator on the screen (above the green Android belly).

    I opened the Galaxy Nexus in recovery mode and attempted to install the update (to FH05.zip) from the cache. The attempt fails as well. But, in recovery mode, there seems to be more information:

    Finding update package...
    Opening update package...
    Verifying update package...
    Installing update...
    Verifying current system...
    assert failed: apply

    battery vidz_patach_check "EMMC;/dev/block/platform/omap/omap_hsm
    E:Error in /tmp/sideload/package.zip
    (Status 7)
    Installation aborted.

    The above is the gist of what it says when the update is aborted. I tried wiping the cache but still get the same error on subsequent attempts.


    I'm not sure what the previous story on the phone is! I bought it used and am using it as a media player of sorts (not the phone). Today, I can also see that the phone is definitely locked (in Recovery Mode, it says that the phone is locked). Strange? I don't think it is a stolen phone as I bought it with the box.

    I am considering just sticking with ICS. I also think it is possible that the previous owner(s) may have attempted to tinker around with the device then ended up throwing in the towel.

    The "assert failed" issue seems to be a problem that has happened with others. I'm not an expert : (

    Is the ODIN route still a good idea?
    10-17-2012 07:09 PM
  6. ratsttam's Avatar
    One of the great things about the Nexus, is that it can be easilly unlocked, and RELOCKED. From the error you're getting, I'm going to go on a limb and say that there is a file missing or added to the system folder. It could have been a small tweak (common to fix issues). If your recovery is Clockwork or TWRP you can just flash a different rom, including "stock" ones.
    I came from the Epic 4g, so ODIN and I became really good friends, and is what I chose to use when I wanted to make sure my Nexus was completely wiped back to stock using the stock images.
    10-18-2012 07:50 AM

Similar Threads

  1. Is the Wifi update to Jelly Bean a work around?
    By pauldroidr2d2 in forum Verizon Galaxy Nexus
    Replies: 1
    Last Post: 10-01-2012, 05:50 AM
  2. Lost flash by updating to Jelly Bean?
    By jonsnowden in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 2
    Last Post: 09-21-2012, 10:04 PM
  3. Tried updating to Jelly Bean -- Stuck on Google screen / Bootloop
    By dmmarck in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 32
    Last Post: 08-29-2012, 12:09 AM
  4. Please Help, won't boot after trying Froyo update
    By Redneckbutlerboy in forum AT&T Captivate Rooting, ROMs, and Hacks
    Replies: 15
    Last Post: 12-12-2010, 07:40 PM
  5. Email Won't Open After 2.2 Update...
    By Pitbull#AC in forum Motorola Droid
    Replies: 1
    Last Post: 08-20-2010, 10:33 AM