1. mtkohl85's Avatar
    I upgraded to the Sprint Galaxy Nexus yesterday. Being smart, I went ahead and unlocked the bootloader via fastboot before ever booting the phone. Activated the new phone, booted the phone, got started setting it up, and later flashed CWM, and then SuperUser. Everything was working tip-top until....

    Tonight, decided to wipe/restore my Nexus S 4G, with the intent to use it for tinkering later. Flashed factory images, booted up, everything was fine. Proceeded to flash CWM, then SuperUser. But being not-so-smart, I realized that I had left my GNex plugged in to my computer (Mac) to charge. So it is possible that, when flashing CWM to the NS4G, the GNex was also attached and possibly in fastboot. I can't say for certain.

    For whatever reason, I was unable to power on my GNex at all. I pulled the battery, then powered-on, all seemed fine. But when trying to make phone calls (voicemail, etc), the radio seemed to "die" (I'd add that I have an Airave in the house...buggy as hell). Also, my phone app was acting very bizarre. Unsure of what was going on, and concerned about a bad flash intended for the other phone, I looked into whether or not my radios were broken. As we all know, el-goog has not posted factory images for this phone, so I searched and found the leaked images and downloaded the two radio files. Note: I downloaded the FD02 radio files, as these appeared to be most recent. Also, at this time, I checked my radio versions, and both were FH05 (or was it FD05?). I thought this was strange, as both were FD02 when I first got the phone, as confirmed at the bootloader screen when I first unlocked...I wrote down all the version info at the time, just in case.

    So I did two things. First, flashed the FD02 radio files (I suspect now that this was a mistake). The GNex was still being wonky, so I decided to load up CWM Recovery and wipe the cache. Rebooted, and all of a sudden things seem ok. Phone appears to be working fine. However, I then noticed that my build version is JRO03U.L700FH05...and then it hit me...my GNex shipped with 4.0.4 ICS, and immediately updated to 4.1.1 JB. I suspect that the FD02 radio files belong to the 4.0.4 ICS software (I don't recall the build number). I am assuming that the last 4 digits of my build number should match the radios.

    So a couple of things...
    1) has anyone every tried to issue fastboot command with two devices connected? Are there obvious consequences to doing so? I wonder now if it was really a non-issue, as I don't think both phones were in fastboot mode at the time...but cant say for sure.
    2) can anyone confirm that the FD02 radio files were indeed for the previous build (4.0.4)? This would mean that I'm running JB with out-dated radios.
    3) Assuming # 2 is true, are the FH05 radio files available, anywhere? Everything I've found seems to indicated that FD02 is the latest.

    I'm definitely feeling like a dumba$$...first, for having both phones attached (which I think was of no consequence now), and then for flashing old radios (even though they seem to work for now). If only Google would post the factory images That was always my safety net with the NS4G.
    10-17-2012 01:02 AM
  2. jlopez1286's Avatar
    I've never had 2 phones connected so idk if fastboot is possible on 2 phones at the same time... now regarding the radios, I'm running 4.1.2 with FH05 , I remember that been the latest. You should be able to get them over at XDA. Thats where i got mine. Good Luck..
    10-17-2012 08:32 AM
  3. mtkohl85's Avatar
    Thanks for the response. I was able to find the thread over on XDA that has the images, so this morning I flashed the FH05 radios (and again wiped the cache), then rebooted, and everything seems good. Both radios are at FH05 now.

    Regarding flashing of the radio files....I found it interesting that some sources claim you can flash both radios with the same partition name, as in:
    fastboot flash radio radio-lte.img AND
    fastboot flash radio radio-cdma.img

    I tried this myself, and it does not work. It left me with "nothing" for the LTE radio. As I discovered at another source, the partitions are specific to the radio, i.e.
    fastboot flash radio radio-lte.img AND
    fastboot flash radio-cdma radio-cdma.img

    This worked for me. I'd also read somewhere that you were supposed to flash them in a certain order, maybe it was CDMA first (I don't recall now). So maybe you can do it one of two ways, either use the radio specific partition names, or make sure you flash them in the correct order using just "radio" as the partition name.

    Since I was curious about having two devices connected via fastboot, I went ahead and booted both phones to fastboot mode, connected both to the computer, and executed "fastboot devices"
    and sure enough both devices showed up (the NS4G first, the GNex second). I then issued
    "fastboot reboot-bootloader" and the NS4G bootloader rebooted, with nothing happening on the GNex. I then issued
    "fastboot reboot" and the NS4G rebooted.

    Since the NS4G was now booted to Android, I issued
    "fastboot reboot-bootloader" a second time, and the GNex bootloader rebooted. I then issued
    "fastboot reboot" a second time, and the GNex rebooted as normal.

    So it appears (from my very limited test sample) that the first device found via fastboot is the one that will receive commands. I can't say whether or not the "first one connected" makes any difference. But it would confirm that yesterday, since my NS4G was receiving commands as intended, that the GNex was not, and there was probably no big problem with the GNex that was caused by having both phones connected.

    Learning something every day!
    10-17-2012 11:30 AM
  4. Paul627g's Avatar
    If I remember correctly you need to flash the CDMA radio first then follow up with the LTE radio...
    10-17-2012 11:49 AM
  5. mtkohl85's Avatar
    That might be what I read before. Are you saying that, as far as you know, you'd flash both radios with "fastboot flash radio <radioname>.img"? (and just flash the CDMA one first). If that's true, it appears there are a couple of different ways to do it....either flash cdma first, or use the cdma-specific partition name in the command. Maybe I'll try it later when I have some down time (since flashing the radios doesn't impact my device much).

    I can confirm, though, that the latter approach (cdma-specific partition name) works, at least for the CDMA radio, as I have strong voice and data over 3G. Since there is no LTE coverage where I live (Denver), I cant say if that is working or not.
    10-18-2012 12:59 PM
  6. jlopez1286's Avatar
    i remember flashing them in ZIP format through recovery.
    10-19-2012 02:35 PM
  7. jean15paul's Avatar
    I was going to point you to the sticky at the top of this forum where you can get the latest FH05 radios http://forums.androidcentral.com/spr...boot-imgs.html But it sounds like you don't need that anymore.

    From everyguide I've read, you're supposed to flash CDMA 1st and LTE 2nd, but I've seen 1 occasion where someone said they did it the opposite way and everything worked find. I've seen a number of conflicting guides regarding flashing the radios with the same partition name. I don't understand why there's conflicting info and reports out there, but my advice is do it whatever way it works for you. If you don't want to deal with these issues, there are radio zip files out there that you flash through recovery that should automate the process.

    So is your GNex working properly now, or is it still acting wonky? If it's still acting up, I'd recommend taking it all the way back to stock (either using ODIN or by flashing all the .img files in fastboot) just because you don't know what you have right now since it might have received some inadvertant fastboot commands. That's just my 2 cents, and I'm no expert, so take it or leave it. Here's the return to stock thread again, http://forums.androidcentral.com/spr...boot-imgs.html

    Good luck
    10-23-2012 01:22 PM
  8. mtkohl85's Avatar
    Thanks for the response jean15paul.

    Yeah, it's frustrating to see conflicting info, and more bizarre when you have two methods that work. For me, I flashed using the unique radio partition names ("radio" for LTE, and "radio-cdma" for the other). One of these days, when I get bored, I will try flashing both using just "radio", and see which order actually "sticks". I suppose if the factory images ever get posted on the Google developer page, we can just look at the flash-all.sh script and see the "correct" way.

    Based on all everything I've seen with my own device, I do not believe that I borked my GNex while sending commands intended for the other device. My GNex is behaving properly (after re-flashing the radios to FH05), so I'm confident in what's there now. I suspect now that the real culprit was my Airave, which frankly hasn't played nice with this phone at all. All told, this was an interesting learning experience. And I've got my functional (rooted) GNex for normal use, and my old NS4G (rooted) for tinkering.
    10-24-2012 10:48 PM

Similar Threads

  1. Replies: 2
    Last Post: 03-06-2011, 10:31 AM
  2. bluetooth doesnt stay connected when phone sleeps
    By m a x i m u s in forum HTC EVO 4G
    Replies: 0
    Last Post: 11-30-2010, 07:52 PM
  3. phone setting when sending video to TV
    By herbmmm in forum Verizon Droid Incredible
    Replies: 0
    Last Post: 10-01-2010, 05:04 PM
  4. When phone connected to wifi, file sharing with pc?
    By rjdangerous in forum General Help and How To
    Replies: 2
    Last Post: 07-02-2010, 08:47 AM
  5. Cannot access phone harddrive when connecting to computer?
    By trmoney24 in forum Verizon Droid Incredible
    Replies: 14
    Last Post: 05-07-2010, 11:02 AM