1. Awake's Avatar
    Is caused by svoice. In settings I unchecked, Auto speaker, Home button key and wakeup command. Not sure which one of the 3 was causing the lag so I unchecked all of them. I have zero lag now.

    Sent from my SPH-L900 using Android Central Forums
    10-30-2012 10:10 AM
  2. hopefulfarm's Avatar
    Where exactly is all this?
    10-30-2012 10:19 AM
  3. Awake's Avatar
    Where exactly is all this?
    Open svoice hit menu then settings.

    Sent from my SPH-L900 using Android Central Forums
    hopefulfarm likes this.
    10-30-2012 10:35 AM
  4. hopefulfarm's Avatar
    I removed the home button key, then tested. That's not it.

    Then I did the auto speaker. That didn't do it.

    Then I did wakeup command. That's not entirely fixing it either. Mine still has at least a 1-2 second lag occasionally IF I use the home button. If I use the power button, that did fix it. So I think it's the wakeup command, which makes sense.

    It doesn't fix the lag using the home button but greatly improved it for me.
    10-30-2012 10:45 AM
  5. stillhere153's Avatar
    I only have the lag when connected to a wifi network
    10-30-2012 11:41 AM
  6. koertje1's Avatar
    I noticed a slight improvement at first, but now it's back to around 2-3 seconds no matter which button I use to wake it up. I confirmed the settings were still not selected as well. I just really hope it will be completely fixed in a software update sometime. Hopefully will add the multi-screen function too
    10-31-2012 08:00 AM
  7. cruiserandmax's Avatar
    If you guys that are experiencing the lag have microSD cards installed, cluld you try rebooting the phone without the card installed and see if that gets rid of the lag? This was the cause of the exact same problem on the GSII.
    10-31-2012 08:28 AM
  8. hopefulfarm's Avatar
    Ok. I shut my phone off and pulled my micro sd card.

    Played with my phone, then put it to sleep, let it sleep for about 1 minute. My phone is 99% charged, connected to WiFi.

    Results: Improved but still not instantaneous. Still a lag using the home button, sometimes it's fast, sometimes it's back to the same lag. Using power button is pretty fast now.
    10-31-2012 09:24 AM
  9. koertje1's Avatar
    It made little to no difference for me. Definitely not a big enough difference for me to run without the SD card. As a point of reference, I did still have my SVoice settings disabled
    10-31-2012 12:37 PM
  10. Slingbox's Avatar
    It made little to no difference for me. Definitely not a big enough difference for me to run without the SD card. As a point of reference, I did still have my SVoice settings disabled
    Same here.
    Those that think disabling S voice is cure to wake lag on this device are on the wrong road to resolving issue.

    To all Sprint GN2 owners!
    International & T-mobile versions don't have wake lag.
    You can kick back pay no attention to bug expect fix or you can call Sprint & Samsung file trouble tickets bring bug to their attention so fix will come
    Please don't be lazy , Take 15 min of your busy life and make the call.....Email ...Tweet them.

    Direct them to QBking video , it pretty much says it all

    10-31-2012 01:01 PM
  11. allenooi's Avatar
    I think it is happened to all SGN2. Mine is from Malaysia and I am also having the exact same issue as well. The lag is really makes me mad! And yes, the S Voice settings and removing the micro SD card are not helping at all.
    11-01-2012 01:06 AM
  12. hopefulfarm's Avatar
    I tweeted Sprint. I'm sure they'll ignore me, they always do.
    11-01-2012 08:01 AM
  13. uofmike's Avatar
    Ok, I fixed mine, however it may not work for everyone. I have the Samsung flip case for my phone and the only reason I had a lock screen was so I couldn't turn my phone on while it was in my pocket or while I'm taking it out of my pocket (swipe to unlock anywhere on the screen and the screen lighting up when getting a text are such a stupid combination for people that keep their phones in their pockets). But with that case on I didn't see a reason for the lock screen, so I set my lock screen to "none" and VIOLA it responds almost instantly when turning it on. They may just be a coincidence but my home button response when exiting apps has been much snappier as well as my keyboard (android 4.2 keyboard)
    11-02-2012 08:21 AM
  14. gn2ab1's Avatar
    Any fix for this yet that doesn't involved throwing security out the window? (last post suggests to disable lock screen...)

    My results:
    Disabling the 3 S-Voice things and S-Voice entirely had no effect.
    Removing SD card seemed to improve slightly, but going from a 1.5 sec delay to 1 sec delay is still unacceptable. My HTC One-X+ and iPhone 4 both come on well under 1 second.
    04-23-2013 06:22 AM

Similar Threads

  1. Sprint HTC Hero Ring Lag
    By ReproOne in forum HTC Hero
    Replies: 12
    Last Post: 01-17-2010, 04:59 PM
  2. Keyboard Lag
    By Ruben in forum HTC Droid Eris
    Replies: 4
    Last Post: 12-26-2009, 04:00 PM
  3. Eris lagging
    By LoveToTalkSports in forum HTC Droid Eris
    Replies: 1
    Last Post: 12-25-2009, 03:57 AM
  4. lag issue
    By o4liberty in forum HTC Droid Eris
    Replies: 2
    Last Post: 12-21-2009, 01:17 PM
  5. "Ring Lag" and what to do about it
    By Fabrian in forum HTC Hero
    Replies: 7
    Last Post: 11-19-2009, 05:12 PM