1. evobassfish's Avatar
    So I figured what was causing the lag/freezing, turns out some apps are not optimized for 4.3. I uninstalled the updates to all of google services apps and now my phone is back to normal.

    Posted via Android Central App
    01-02-2014 10:28 PM
  2. Golfdriver97's Avatar
    Interesting fix. Thanks for sharing.
    01-02-2014 10:33 PM
  3. everton1913's Avatar
    My problem is not with apps but when making calls on the phone (note 2) i have to wait for about 15 to 20 seconds for the call to go through or the contact list to populate.
    01-09-2014 08:58 AM
  4. radiohawk's Avatar
    My problem is not with apps but when making calls on the phone (note 2) i have to wait for about 15 to 20 seconds for the call to go through or the contact list to populate.
    I have continued to prevent the update to 4.3, but I have the same lag with phone calls... Have wondered if maybe tower upgrades might be the culprit, Sprint service has been sporadic for some time now while LTE is now here off and on

    Posted via Android Central App
    01-10-2014 12:17 AM

Similar Threads

  1. Sprint Galaxy S3 - Call volume very low after 4.3 update
    By gossamer#AC in forum Sprint Galaxy S III
    Replies: 15
    Last Post: 05-17-2014, 08:49 AM
  2. Galaxy S3 - WIFI not enabling after 4.3 update
    By Nemesis-X in forum Samsung Galaxy S3
    Replies: 6
    Last Post: 02-22-2014, 10:00 PM
  3. After updating phone wi-fi connections will shutdown
    By dragonlx in forum Verizon Galaxy S III
    Replies: 13
    Last Post: 02-03-2014, 11:15 AM
  4. Lost pictures and videos after 'codec' problem
    By craigt64 in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 01-03-2014, 11:29 AM
  5. Verizon Galaxy S3 - S task lost grouping after update
    By valkster1 in forum Verizon Galaxy S III
    Replies: 0
    Last Post: 01-02-2014, 09:28 PM
LINK TO POST COPIED TO CLIPBOARD