09-22-2011 10:52 PM
26 12
tools
  1. skeeve's Avatar
    Hey guys, got my SGSIIE4GT today (like 2 hours ago!) and I was just wondering if anybody else was noticing that it takes a long time to charge. This is my first ever charge so it's waaaaaay too soon to be calling this a problem, not trying to start any rumors or anything. Just... hey it's new and I'm freaking out about everything haha. Anybody have a similar story about their first or subsequent charging speed?

    p.s. I initially was charging through my computer's usb port and it actually seemed to lose a small amount of battery (although it was syncing at the time so that doesn't really mean anything). I have had it plugged into the wall now for about 30 minutes and the percentage hasn't changed at all.

    ANTI-TROLL-SHIELD-ACTIVATED
    Once again I would like to state as clearly as possible that I am very well aware that first charges can be weird with phones and I do not intend to start any kind of rumors about this phone. It is entirely possible that the one I received is deffective somehow (or the cable might even be, I'll try another one when I get home if this hasn't changed). And it's entirely possible and likely that NOTHING is wrong. I was just wondering if anybody had a similar experience.

    Thanks!
    09-16-2011 01:41 PM
  2. skeeve's Avatar
    Status update: Exactly 30 minutes in, 1% higher battery.
    09-16-2011 01:42 PM
  3. BRIVERS73's Avatar
    Maybe it's a Samsung thing because for the three days that I had the original Epic it was slow to charge as well.
    09-16-2011 01:46 PM
  4. Latteart's Avatar
    You computer will actually charge at half the rate a wall charger will. This also has the biggest stock battery out I believe so it will appear to take longer. You get .5amp from USB and 1amp from wall is how I believe its worded.

    A USB controller or hub is required to power one unit load (100 mA, a low power load). It can optionally power up to 5 unit loads (500 mA, a high power load).

    http://www.girr.org/mac_stuff/usb_stuff.html That link is all about USB charging and power ratings versus Wall charging.
    09-16-2011 01:46 PM
  5. solid_s_1117's Avatar
    Status update: Exactly 30 minutes in, 1% higher battery.
    I would definitely say that's a problem. I've noticed a considerable amount of lag while charging, but the actual charge time seems normal thus far for such a large battery.
    09-16-2011 01:50 PM
  6. skeeve's Avatar
    It's gone up +1% in the last 10 minutes so it seems to be accelerating. Unless I see this persisting over, say, the weekend, I don't think it's time to call it a problem yet. I also don't have a lot of cell service right now so the it's probably draining a little more from the battery than usual. We'll see Still hopeful!
    09-16-2011 01:56 PM
  7. Kwyjibo's Avatar
    Mine is charging pretty slow, probably because the battery is larger, but nowhere near that slow, at least 25-30 percent in an hour, so it sounds like you may have a problem worth looking into.
    09-16-2011 01:57 PM
  8. skeeve's Avatar
    Another 2% now, so it's definitely accelerating.
    09-16-2011 02:09 PM
  9. enormous's Avatar
    Mine seemed to be charging pretty slowly as well. Does yours show "USB Connected - MTP-Connected" in your notifications when charging? Mine does when I'm charging using a 1A rated USB wall charger from Monoprice, but when I use the stock Charger it does NOT show, and just charges. Much faster!
    09-16-2011 02:10 PM
  10. locationman52's Avatar
    Using the plug, mine charged fully from 47% in about 2 hours. This was with syncing an Exchange and other accounts.
    09-16-2011 02:12 PM
  11. skeeve's Avatar
    I'm using the stock plug it came with and it is showing the MTP connected in the notification... hmmm gimme a sec.
    09-16-2011 02:22 PM
  12. skeeve's Avatar
    Rebooted and still showing that. Do you have any notification at all while charging with the included wall adapter?
    09-16-2011 02:28 PM
  13. Dissident's Avatar
    Mine took 2 hours to reach full charge. It was off and plugged into the wall.
    09-16-2011 02:35 PM
  14. skeeve's Avatar
    Just to clarify so nobody gets paranoid, I manually rebooted my phone.
    Also, my EVO took a long time to charge at work, although I never tried it with anything other than the usb connection so that's probably not a fair comparison. I turned it off (too distracting while I should be working anyway) and I'll update on how it's charged in about 2 hours when I leave.

    Still interested if others get an MTP or any other kind of notification while charging with the included (or any) wall adapter. Thanks!
    09-16-2011 02:40 PM
  15. Slingbox's Avatar
    I burned mine down to 5% put it on charger 20 min ago now at 21%.
    09-16-2011 02:49 PM
  16. skeeve's Avatar
    I'm wondering if maybe the outlets here are particularly slow. I'm using an outlet that's not directly in the wall... I promise that when I get to test out all the possible reasons I'll update here.
    09-16-2011 02:56 PM
  17. BRIVERS73's Avatar
    Mine been on & off a charge all day as I've been giving it my undivided attention but it's slowly creeping up to a full charge
    09-16-2011 03:23 PM
  18. Cory Streater's Avatar
    No troll shield required. All Galaxy phones take forever to charge, including the original Galaxy series. I think it gets better, but still takes a long time.
    Slingbox likes this.
    09-16-2011 03:36 PM
  19. nkd's Avatar
    it took me about 2 hours to fully charged it last night. For the biggest stock battery that's not bad.
    09-16-2011 03:40 PM
  20. tuna83's Avatar
    I had a much larger battery on my evo. It charged far quicker. I have a 1000 mah car charger so ill see if that changes anything. It is super slow though.
    09-16-2011 03:55 PM
  21. JayWill's Avatar
    Hmm mine seems to be charging just fine. Maybe my expectations are just low or something.
    09-16-2011 03:58 PM
  22. Slingbox's Avatar
    Device at 5% 2 Hour 24min of charging I'm at 75%
    By the looks 30 min should top it off
    09-16-2011 04:17 PM
  23. YBCold's Avatar
    Mine is a little slow too butI haven't put it down since I plugged it in

    Sent from my SPH-D710 using Tapatalk
    09-16-2011 05:02 PM
  24. SumTinLikaNinja's Avatar
    Mine charged in about an hour and an half for the initial charge, while the device was off.
    09-16-2011 08:19 PM
  25. skeeve's Avatar
    Sorry for the delay. It was totally the outlets at work. Even my car charger was faster. Much better charging speed now. I don't know thatI could compare it to any other phone but it's perfectly acceptable. Anybody else blown away by this battery life?!
    09-17-2011 07:00 PM
26 12
LINK TO POST COPIED TO CLIPBOARD