1. Mikest's Avatar
    So I'm trying to connect this bad boy to my Macbook Pro to transfer some files and it doesn't seem to be recognizing the phone. I plug the phone in and it says MTP-Connected and I get the USB icon in the notifications bar, but theres no option to mount the drive. What am I missing? Thanks.
    09-16-2011 09:16 PM
  2. bad1550's Avatar
    I am having the same problem.

    How can we add music?

    Is it necessary to purchase a micro sd card?
    09-16-2011 09:22 PM
  3. chazglenn3's Avatar
    On my PC the phone shows in the "My Computer" window as a device...SPH-D710 I think it said. Clicking on that opens a windows with "phone" and "card" as the two storage choices. I'm not a Mac guy...sorry.
    09-16-2011 09:22 PM
  4. BRIVERS73's Avatar
    I kept having the same problem but it seem to have worked itself out as It is connected as a usb now.
    09-16-2011 09:32 PM
  5. Mikest's Avatar
    I've tried rebooting the phone and the macbook pro. Tried a different micro USB cable and then I tried a different USB port. Still no joy.

    Just to add more info to the problem I'm running OSX 10.6.8, intel based mac. yada yada why!!
    09-16-2011 09:39 PM
  6. bad1550's Avatar
    I've had no luck with Snow Leopard and Lion is not supported
    09-16-2011 09:53 PM
  7. Mikest's Avatar
    The plot thickens. Tried connecting to a friends Windows 7 64 bit machine. It recognized the phone but there was no way to eject the device safely.
    09-16-2011 09:58 PM
  8. bad1550's Avatar
    Finally was able to get it to work.

    Using the samsung app Got it to sync music on Mac

    Thx
    09-16-2011 10:15 PM
  9. noshooz's Avatar
    It looks like an SD card is necessary to do USB transfer. I found Settings -> Wireless & Networks -> USB utilities. There's an option to "Connect storage to PC." It only works if an SD card is present.
    froggbee likes this.
    09-16-2011 10:16 PM
  10. Mikest's Avatar
    You have to go to settings>applications> development > debugging. Enable it and its as good as gold.
    pirarre likes this.
    09-16-2011 10:22 PM
  11. noshooz's Avatar
    You have to go to settings>applications> development > debugging. Enable it and its as good as gold.
    Duh!! I knew that... It works. I was able to see the contents, labeled as NO NAME on my MacBook Pro running Lion.
    09-16-2011 10:31 PM
  12. Mikest's Avatar
    09-16-2011 10:31 PM
  13. chefsage's Avatar
    You have to go to settings>applications> development > debugging. Enable it and its as good as gold.
    GOLDEN!!!! Thank you SOOOO much, I don't know why I didn't think of this, but you just saved me a few hours of frustration. I've got so much crap on this SD card from my previous phone...it will be nice to empty it!
    07-30-2012 01:28 PM
  14. wkufan92's Avatar
    What am I missing? When I click on Settings, Application, there is no development listed.
    07-30-2012 02:15 PM
  15. Hawaiian_Geek's Avatar
    What am I missing? When I click on Settings, Application, there is no development listed.
    under applications look for development....open it up and uncheck USB debugging....make sure you're doing this without the usb cable plugged into the phone.....then reconnect the USB cable and it should work properly after that.....
    07-30-2012 11:38 PM
  16. lcGlacier's Avatar
    I have a Galaxy S3 and a Mac running OS X 10.8.1 and am able to sync media (music/photos), folders via the Missing Sync for Android. I have to connect the phone first and then launch Missing Sync and then it works fine with MTP.

    I do not work for them. Sync Android with Outlook, iTunes, PC or Mac over Wi-Fi, Bluetooth and USB
    09-06-2012 04:18 PM
LINK TO POST COPIED TO CLIPBOARD