10-19-2011 06:08 PM
105 1234 ...
tools
  1. DaveInFL's Avatar
    I've been experiencing the same thing... One thing i did notice is that when i'm on Wi-fi and connected to a network, the device is continually scanning for networks. Is this normal for other Android devices (i'm a WebOS transplant)?
    Perhaps that is the issue. No idea how to stop it doing that apart from turning WiFi off.
    09-21-2011 11:20 AM
  2. bboykin87's Avatar
    I have this same issue too with android os having crazy high usage %. I don't have beautiful widgets installed so I don't think that is the cause. I've had ok battery life, but I don't think it's where it should be.


    Sent from my SPH-D710 using Tapatalk
    09-21-2011 11:41 AM
  3. gmich's Avatar
    I've had the same issue--Android OS ranges between 30% and 68%, usually in the 30s. But my battery life is still good. I easily get through a whole day with moderate use. Yesterday I got 20 hours.

    But the high Android OS draw still bothers me. I'm tending to agree with those above who think it's related to the wireless. Mine always seems to be scanning for a network--even when it's already connected to one! Could that be the issue?
    09-21-2011 12:33 PM
  4. Eric16's Avatar
    I am always at home I work at home so I always have wifi connected its faster than the 3G and most of the time better on my battery than 3G. When I leave the house I make sure to turn off my wifi widget and I never turn on 3G while Im driving or whatever until I need the net for something then I will get the 3G widget then turn it off after Im done. Im also getting android os in the 30's 40s. My 3D was always in the single digits and nothing is different here at home or whatever from then having the 3D till the ET so I have no idea. Some ppl on XDA and even on here posting screenshots of them getting single digits in the android os. Like someone said earlier Im still getting great battery its just more annoying than anything.
    09-21-2011 01:37 PM
  5. expertzero1's Avatar
    update:

    So after 2 days, the % of android os, has gone down into the 20% and under. Removed go launcher ex etc, and closing unnecessary apps when im not using it.

    Also updated the prl, profile, and firmware, if that helps, not sure.

    I think it was go launcher ex or whatever that was sucking the battery dry
    09-21-2011 02:02 PM
  6. bboykin87's Avatar
    I'm curious to know how many people who have the high Android os usage also have the motion settings enabled. I remember a similar problem with CM7 on the evo having sensor wake issues related to the flip to silence setting, I just turned the motion settings off, and I'll see how it affects the %

    Sent from my SPH-D710 using Tapatalk
    09-21-2011 04:10 PM
  7. Eric16's Avatar
    I'm curious to know how many people who have the high Android os usage also have the motion settings enabled. I remember a similar problem with CM7 on the evo having sensor wake issues related to the flip to silence setting, I just turned the motion settings off, and I'll see how it affects the %

    Sent from my SPH-D710 using Tapatalk
    yes I remember seeing that to, I have mine enabled Im pretty sure but I dont think I have used it more than once. I like to view my webpages portrait mode I hardly ever turn my phone
    09-21-2011 04:26 PM
  8. youngjediboy's Avatar
    I turned off Motion Activation and now the battery for Android OS is at 85%...
    I DO have Go Launcher EX running though with a theme and some page effects. Would that really use that much battery though?
    09-21-2011 05:27 PM
  9. expertzero1's Avatar
    i removed go launcher ex, and my battery usage is under 20%
    09-21-2011 05:42 PM
  10. error4o4's Avatar
    Going to try disabling go launcher ex and see if it helps.

    Also have Widget Locker installed, keeping it enable though. refuse to go back to default unlocker. (Worst decision visually on this phone, fire someone samsung)
    09-21-2011 11:20 PM
  11. expertzero1's Avatar
    yeah i have only widget launcher running, most apps i close after finish using them
    09-21-2011 11:55 PM
  12. error4o4's Avatar
    Since removing Go Launcher EX i am still over 55% android OS.

    I've never seen this with any of my previous 3 android phones

    Only thing left is to hard-reset and wipe it. Sigh.
    09-22-2011 09:50 AM
  13. BIGCOIN#AC's Avatar
    This is a screen shot of the issue. Note that the phone was charged again after noticing it was at 60%.

    Sent from my SPH-D710 using Tapatalk
    My OS is stable at 18% (shruggs shoulder)
    09-22-2011 10:18 AM
  14. bboykin87's Avatar
    People please don't freak out. The phone breaks down what your phones doing in percentage out of 100%. If you add everything that screen is showing you it should come up to 100%. Just passing thing I've learned from having a android for so many years.
    Yeah but at the end of the day with my phone only having 30% battery left, android os shouldn't be responsible for 50% of the 70% lost!

    That would mean it's responsible for roughly 1/3 of my total battery usage if I ran it until it died.

    With motion settings off today, I still have android os at 50%, I'm going to do a factory reset and see if that helps.

    Sent from my SPH-D710 using Tapatalk
    09-22-2011 02:01 PM
  15. killadon's Avatar
    People please don't freak out. The phone breaks down what your phones doing in percentage out of 100%. If you add everything that screen is showing you it should come up to 100%. Just passing thing I've learned from having a android for so many years.
    09-22-2011 02:09 PM
  16. killadon's Avatar
    It's like your computer. If you open up task manager with what you think is nothing running you'll that there is still activity going that you don't see. All operating system run this way. Now I think you might have mistaken what I said before. It breaking down in a 100% rating of what your phone has been using the battery for. Let's say it only shows 5 things. It breaks those 5 things down in a percentage (example wallpaper 5%) now that's not saying 5% of your battery was used. It's say 5% of the 5 things things showing has used your battery. How much was actually used. No one knows. I hope I explains that a little better this time.
    09-22-2011 07:09 PM
  17. gravyhead's Avatar
    9 Hours to dead here. Android OS uses 60% of my CPU, hardly used it at all, outside of a few emails and browsing a bit.

    xda seems to see this bug pop lots of different ways. Some say wifi sharing, some say widgets, some say ... ?

    I'll dig more into it tonight. Hopefully I'll find something.
    09-22-2011 07:14 PM
  18. Nrbelex's Avatar
    Just wanted to point out this is being discussed in two threads over at XDA:

    "Android OS" consuming battery - xda-developers

    Battery Life Bug - Heads Up - xda-developers

    Might help in pinning it down, but it seems like a long-standing bug for Samsung devices which was supposed to have been fixed in 2.3.4

    I should also note some people report success restarting the phone after unplugging from the charger. e.g. Wake up (after letting it charge all night), unplug the phone, restart, go on your merry way. I find that while this might help, "Android OS" is still a top CPU user/ battery drainer.
    09-22-2011 07:18 PM
  19. chill.117's Avatar
    What running applications do you guys have when you first start your phone? I'm fairly new to android, so this probably has nothing to do with Android OS, but is there a way to stop social hub and some of the other apps from constantly running at start up?
    09-23-2011 09:20 AM
  20. spridell's Avatar
    I have had the phone sitting idle for the last 15 hours and the OS is taking up 35%.

    This is a brand new phone with no apps installed. Only what came with the phone.

    Seems to me its a software problem that Samsung has to fix.
    09-23-2011 09:32 AM
  21. mylgt1's Avatar
    Got my phone yesterday and played with it all day doing tons of downloads and my Android os never went above 10 and this morning with the phone being idle all night it's at 34!!!
    09-23-2011 10:01 AM
  22. Flyboy1100's Avatar
    For those people with really high OS Usage, do you have the Motion stuff turned on? I seem to remember CM7 had a bug with that and it would cause a partial wake lock and drain the battery really fast.

    My battery is pretty much dead today after 9 hours, and only about 2 hours of use, with motion turned on, I have turned it off now to see if that fixes the issue.
    09-23-2011 04:03 PM
  23. youngjediboy's Avatar
    For those people with really high OS Usage, do you have the Motion stuff turned on? I seem to remember CM7 had a bug with that and it would cause a partial wake lock and drain the battery really fast.

    My battery is pretty much dead today after 9 hours, and only about 2 hours of use, with motion turned on, I have turned it off now to see if that fixes the issue.
    I turned off Motion and it doesn't seem to make a big difference. I made another thread about having poor battery life and I saw suggestions to turn off any live wallpapers and Go Launcher, so that's what I did and will see how the battery holds up today.

    Also with nothing running right now I'm getting 97% Android OS and 2% Cell standby. Those are the ONLY things on my list right now...
    09-23-2011 04:17 PM
  24. JayWill's Avatar
    A new thread over at XDA suggests it may have something to do with Google's sync activities.
    09-23-2011 04:29 PM
  25. error4o4's Avatar
    For those people with really high OS Usage, do you have the Motion stuff turned on? I seem to remember CM7 had a bug with that and it would cause a partial wake lock and drain the battery really fast.

    My battery is pretty much dead today after 9 hours, and only about 2 hours of use, with motion turned on, I have turned it off now to see if that fixes the issue.
    Negative, turned that off right at the get-go. Never liked those features on any phone.
    09-23-2011 05:38 PM
105 1234 ...
LINK TO POST COPIED TO CLIPBOARD