1. taylormah's Avatar
    I inserted my 2 year old class 4 8GB sandisk card which I used to use with win-mobile treo, but it did not detect the card. So I inserted the card in PC and did a quick format in FAT32, but still same results. In settings->storage, under sd card it says 'Unavailable' under "Total space" and "Available space", but these buttons are enabled and still clickable (they dont do anything however upon clicking), while the "Mount SD" and "Format SD" are disabled/unclickable. This remains the case no matter even if I insert the sd card in the slot, meaning that phone is not even realizing that I inserted the sd card, but then I noticed that whenever I remove the sd card, in the status bar, "SD card removed" or something similar message flashes for a half a second. Any ideas?


    09-20-2011 05:44 AM
  2. h4ldol's Avatar
    This may not be helpful, but I just bought a 32GB sandisk microSDHC card and it works fine and did not require formatting -- it was just recognized from the get go. Maybe the card is a microSD card and perhaps the E4GT is only compatible with microSDHC cards?
    09-20-2011 01:00 PM
  3. taylormah's Avatar
    No the card is a SDHC card . I dont know what to do. Maybe a hard reset is needed. Will do that tomorrow if nothing works out.
    09-20-2011 03:30 PM
  4. SixOne9's Avatar
    Try resetting the phone. If that doesn't work then it's most likely a defective memory card. I purchased a 16g card on amazon for $20 shipped and it works fine.
    09-20-2011 04:11 PM
  5. taylormah's Avatar
    I just tried a 1GB standard microSD card, (not microSDHC), and it detected it just fine. I noticed that this card had FAT file system, while my 8GB card is formatted with FAT32. Could file system be it? What is the recommended file system to use with android devices?
    09-20-2011 06:12 PM
  6. youngjediboy's Avatar
    I think FAT32 is the most common file system with these cards, so I can't see why it wouldn't work. So I'm guessing you had connected both cards to a computer and they are recognized fine by the computer, is that right? It's very strange if both cards can be read by your Treo and on a computer but only the older one works on the Epic Touch.
    09-20-2011 06:38 PM
  7. GusRandall's Avatar
    I had the same problem when I I first booted the SGSII with the 16GB card I originally had in my Evo. But the SGSII has hot-swappable SD so I left the phone on, pulled the back off, removed the card and then reinserted. The phone picked it right up with all my files/directories intact.
    09-20-2011 06:57 PM
LINK TO POST COPIED TO CLIPBOARD