1. HollyDolly's Avatar
    I have tried calling my phone, and have gotten the same feedback from others...but it takes about 6 rings on the caller's side for the SG2 to even begin ringing. And then it rings a lot! And when the phone finally stops ringing on the SG2, the caller hears even more rings (about 6-8 more) before voicemail even picks up.

    At this rate, people will have already hung up and given up on voicemail.

    Anyone else have this issue? Or a fix?
    10-02-2011 12:29 AM
  2. expertzero1's Avatar
    I have tried calling my phone, and have gotten the same feedback from others...but it takes about 6 rings on the caller's side for the SG2 to even begin ringing. And then it rings a lot! And when the phone finally stops ringing on the SG2, the caller hears even more rings (about 6-8 more) before voicemail even picks up.

    At this rate, people will have already hung up and given up on voicemail.

    Anyone else have this issue? Or a fix?
    um idk but im drunk but a system wipe or somethign@!
    10-02-2011 12:35 AM
  3. HollyDolly's Avatar
    Anyone? (though I'm thinking it's a reception issue yet again)
    10-02-2011 03:28 PM
  4. nairbem's Avatar
    Yes, I have experienced the same problem you described. I recently purchased Sony Xperia P for myself and Xperia GO for my wife. Both phones have had the same problem. I must say we are a little disappointed with the Android system having been a loyal Nokia customers. I guess we should have stayed loyal to Nokia and purchased the Lumia 600 and/or the 700 series phones. I am still searching the web for a solution to not only that problem but also the delay in dialing out. We will see.
    05-17-2013 07:26 PM
  5. nairbem's Avatar
    Dude. This is what I have found out and tried. Very likely it is the apps/widget you have installed that is the culprit. I first re-booted my Xperia into safe mode (without loading all the bells and whistles), and try ringing your cellphone. Very likely your cellphone will ring immediately as it receives the incoming signal. The culprit to the problem both my wife's and mine experienced is one of the contact widget I installed just a few days ago. I have it deleted from our phones and that solves the problem. The phones dial out normally and quicker as well... Hope this helps, dude...
    05-17-2013 08:20 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD