01-06-2017 06:47 PM
42 12
  1. subcritical's Avatar
    Try the Android app called "Media Button Router". It solved this extremely annoying problem on my Samsung Note 2.
    feeserface likes this.
    04-30-2013 08:06 AM
  2. BGood2's Avatar
    Wow, "Media Button Router" is pretty awesome! Thanks for the recommendation as I had never heard of it!
    05-30-2013 10:48 AM
  3. Se1988's Avatar
    Try the Android app called "Media Button Router". It solved this extremely annoying problem on my Samsung Note 2.
    It's just that using media button router with spotify disables the lockscreen widget and the wired headset play/pause button.
    07-08-2013 06:08 PM
  4. vishsarda's Avatar
    I liked the above mentioned app, but I am looking for something opposite, is there anyway to not stop music or anything else to stop when I turn bluetooth off? Please let me know if someone finds it...
    08-30-2013 01:41 PM
  5. ekalanga's Avatar
    Thanks a lot for this tip - Settings > Bluetooth... select device... disable Media Audio. It was so annoying I contemplated trashing my Plantorincs M165 used on Nexus 5. All I need it for is talk-on-the-go, not music. You saved me a great head ache.

    04-05-2014 07:42 PM
  6. jmicks8's Avatar
    This is what I do to prevent autoplay. Hope this is useful to someone...
    For those who use Tasker and are rooted, you can create a profile which is enabled on Bluetooth connect, or more specifically, SYNC (for Ford owners like me)
    -Create a task
    -add a script action
    -touch run shell
    -in the command line add the code "pm disable <package here>"
    so my command looks like "pm disable com.andrew.apollo"
    -check the box for Use Root.
    -save your task

    When connected to SYNC, Apollo is disabled and will not autoplay.

    If you want it to be re-enabled on Bluetooth disconnect, add an exit task: Task>Script Action>Run Shell
    -in the command line add the code "pm enable <package here>"
    -check Use Root
    -save your task
    04-18-2014 09:31 AM
  7. Chrono16's Avatar
    I figured out recently how to play music from a USB through the audio system of my Honda Civic 2013 model. One has to select AUX on the dash in order to activate the car's sound system. Problem is: I use my phone's bluetooth to make and receive phone calls while driving, AND, when AUX is now selected the default music player of the S4 activates itself. This is truly annoying and requires one to first open the phone, select the music payer and stop the music. Everytime.

    I searched high and low and along the way realized that one can access the bluetooth settings on the phone. However, take note, the only way you can solve the autostarting problem is while you are in your car and bluetooth is connected to it. Once that has been done, select phone SETTINGS > CONNECTIONS and then keep your finger on BLUETOOTH a while. The devices that are paired to your phone will appear in a list. On my phone there is a settings icon on the smae line where my Honda as a paired partner appears. Select that icon and 2 options will be listed: "CALL AUDIO" and "MEDIA AUDIO". (You can get here if your phone is not connected to a paired partner BUT, the 2 blocks will NOT BE TICKED.) Both of these options will be ticked. Untick MEDIA AUDIO. Exit.

    You have solved the problem!

    My description may vary from one Android phone to another but you should be able to sort it out. Bottomline is: this is not a glitch in Android software or your car's system. Sad that Android/Samsung does not issue a statement because this is driving people crazy.
    05-07-2014 03:46 PM
  8. WinCPP's Avatar
    Unchecking 'MEDIA AUDIO' stops all sorts of media streaming. Music player and Google Maps both stream as media to the car system. I use car's audio system to play out the voice navigation commands from Google Maps on my Android phone, but I don't want to play the songs. Unchecking the 'media audio' check box stops both of them.

    I think either Android / Samsung or the car audio system manufacturers need to come out clean on this. Someone has goofed up really badly in software implementation.
    06-02-2014 11:12 AM
  9. thylorion's Avatar
    I found a solution to this problem, actually I more like stumbled upon it. It's more like a work around, but you are going to need two apps to make this work. The first app is Disable AutoPlay and the second one is Media Button Router. I am sure that many of you have already tried both of these separately.

    In the Disable AutoPlay app, you either have a choice "Disable Media Button" or to "Enable Media Button." Either one will work, I have already tested them both.

    Next in the Media Button Router App, you must make sure "Enable" is checked. It does not matter if anything else is checked until you get down to the heading labeled "Apps To Show In The Selector." "DisableAutoPlay" actually shows up here, although I don't think it should maybe it is some kind of bug, but make sure that this app is checked and ONLY this app is checked, all other apps should be unchecked.

    I noticed when I turn on my car, my stereo will read "Tr01" for about a second than goes into standby because "Tr01," so nothing happens. In this case I have not actually prevented AutoPlay from starting, it does its job, but can't play audio because "Tr01" does not exist and when it fails to play the audio it thinks it has reached the end of the current folder (at least that is my theory). This allowed me to use my navigation app, make phone calls and use my favorite music player app when I choose to do so. I believe it will also let you play your podcasts, although I have not tried that.
    VTerp likes this.
    06-25-2014 03:52 PM
  10. seventeenseconds's Avatar
    Older thread, but it's the #1 Google search result for "android stop bluetooth autoplay", so I'm hoping this info helps others. I found an app not mentioned (at least I didn't see it) in this thread. Bluetooth Connect & Play -- it has the option to "Stop music from playing" instead of just picking from a specific app (can do that as well though) which is exactly what I wanted. I didn't want any apps to automatically play. I have a couple that will which have no options to disable them from doing so. This app has done a brilliant job of taming them on my Note 3 and allowing me to decide. It also has another great feature to set the "media" volume to anything you like (max in my case) upon connecting, then restore the setting on disconnecting. Solved another huge annoyance of mine!

    There seems to be some devices that don't work well with the app, but it's been awesome for me so far. Hopefully this helps others trying to solve the same issues.
    GuidZilla likes this.
    05-23-2015 01:59 PM
  11. dylancam90's Avatar
    This was a problem with my EVO, especially with WinAmp and Listen having no option to ignore BT headset controls, so they'd automatically launch and start playing whenever my Sync system was detected. (I DESPISE any app which presumes it knows what's best for me and just does what it wants to be "helpful" w/o given a means to turn it off.)

    Well, I wanted to listen to some podcasts with Pocket Casts and the moment I switched to Bluetooth, it started the Music app and playing ringtones I'd copied over. I can't see anywhere in the app or in the phone's BT settings to disable it. I Googled and found a TWO-YEARS RUNNING thread on the Android Bug Tracking site complaining about this issue on just about every phone. Someone suggested using an app called Headset Blocker, but it appears that when I receive a phone call, it doesn't stop Pocket Casts, so I've got to hunt around for where I'd left off.

    If I wanted my hardware and software to boss how I use my phone around, I would've bought an Apple product. Any ideas on how to stop this. I'm not quite ready to root yet. Thanks.
    Hey, I'm bumping this because it's pretty old and I'm wondering if anything new has come out to stop this. I have a Ford focus 2012 and have heard elsewhere that the problem might be with the car and not the phone. I got a Note 3 running stock lollipop and was wondering if you could point me in the right direction. Thank you.

    Sent from my SM-N900V using Tapatalk
    06-09-2015 02:50 PM
  12. rogueFactor's Avatar

    ***The TYPICAL issue experienced that when pairing with a car your music starts playing and it is whatever your music app has detected as songs, be it a voicemail, (that seriously bad song you made into an even worse ringtone, voice recordings, the "Life is good theme" is the common one with LG phones.

    If you're like me and remove all the crap songs that come with your phone you get the pop-up saying "no songs to play". The problem is it keeps trying to look for songs to play. I've since gone a step further and "disabled" this app since i have other music / media apps.

    I've had the same issue since ICS and have had the same issue on lollipop. This fixes the issue on at least these Devices LG G2, ONEPLUS ONE, LG G3. It Took me about 40 minutes sitting in my car to figure this out and which app is the culprit.

    If you can't get to my profile go into all apps in Android scroll down to your music apps and it should be the one with the purple icon mine reads 4.4.something. uncheck "SHOW NOTIFICATIONS". Now you don't have to disable your Bluetooth media player and you don't get the annoying pop up.

    Hey, I'm bumping this because it's pretty old and I'm wondering if anything new has come out to stop this. I have a Ford focus 2012 and have heard elsewhere that the problem might be with the car and not the phone. I got a Note 3 running stock lollipop and was wondering if you could point me in the right direction. Thank you.
    Sent from my SM-N900V using Tapatalk
    08-12-2015 11:44 AM
  13. Nick Rollins's Avatar
    Samsung S series phone and Ford Sync.

    Mine was working great would just connect to BT and then wait for me to pick an app to start audio.
    Then today it started playing voice mail from google play music - UGH autostart from where. No fun to try and fix while driving.
    Found this thread played with my phone and ended up in all applications then google play music - disable the app , turn off notifications.
    retested with sync all better. Back to normal and not auto starting music app.

    Happy again.
    08-20-2015 07:02 PM
  14. THeChonguis's Avatar
    Hi, Im new here.

    If you are having trouble with autoplay when connecting BT to your car its most likely the car system that automatically sends a play command to the phone, and not your phone thats the root cause. So in the car case all you need to do is un-check the "BT-Audio AutoPlay" in your car sytem. Well, thats assuming your car actually gives you that option, mine do but maybee not all. So no rooting or apps needed on your fone for that.

    So now Im finally free from that somewhat annoying LG song greeting me every morning in the car.
    -Also happy again.
    08-21-2015 03:30 AM
  15. rogueFactor's Avatar
    The root cause is ALLOWING the request from the In-car system to X Android Device(read: a trusted device in the system's trusted device list. -in this case a Toyota.)
    08-21-2015 07:28 PM
  16. andruser's Avatar
    This may not be what you want to hear but the only way that I know to avoid this...

    is to download another music player that you like, make sure to turn the auto launch settings off, then disable the regular stock music player in settings/apps.

    You should find out that the auto play issue will cease to exist

    I know how you feel.. The sound of the downloaded player will be just as Crystal but now you will have better control, at least until there's an update on your stock player.
    The stock player that i got with the phone just does what it wants and regardless of the constant suggestions to please add the option to turn off auto-play when Bluetooth is connected, it just Remains the same with no updates. Sometimes I want to listen to YouTube and it just jumps in and automatically unpauses playing music I don't want to hear.

    Please if anybody has any better Solutions, please do put it down here..

    12-18-2016 03:47 PM
  17. yougogirl17's Avatar
    I have been having this problem recently with my Samsung S6 and my 2014 Honda CRV... just fixed it by going into the applications sections of the settings menu...choosing music... force stopping it and hitting the more button in the upper right corner...which gave me the option to Uninstall updates... did that... and Wahoo no auto starting my Christmas music everything I enter the car!
    01-06-2017 06:47 PM
42 12