View Poll Results: Do you experience significant loss of signal?

Voters
52. You may not vote on this poll
  • Yes, I have significant loss of signal problems with this phone making it difficult to use.

    22 42.31%
  • No, I do NOT have significant / noticeable loss of signal problems with this phone.

    30 57.69%
  1. beezar's Avatar
    D.P.G had asked someone to post a poll, so here it is. I was about to pull the trigger on the Epic 4G Touch, but just read the problems with loss of signal on here and other forums. Just wondering how prevalent it is, and is it due to a bad batch of phones, or is this a widespread problem.
    10-09-2011 01:37 PM
  2. YBCold's Avatar
    Must be a certain batch of phones, cause there are several people that are not having issues with Los.

    Sent from my GS2 E4GT using Tapatalk!
    10-09-2011 01:48 PM
  3. KoukiFC3S's Avatar
    I haven't had any problems with signal here. Might just be my area, because my Nexus S 4G also worked great.
    10-09-2011 01:54 PM
  4. blitz118's Avatar
    D.P.G had asked someone to post a poll, so here it is. I was about to pull the trigger on the Epic 4G Touch, but just read the problems with loss of signal on here and other forums. Just wondering how prevalent it is, and is it due to a bad batch of phones, or is this a widespread problem.
    I've had the LOS once and Sprint was working on the towers in my area at the time. I have not
    experienced it again and I've had no other issues with the phone.
    10-09-2011 01:54 PM
  5. Ogre840's Avatar
    I started out with *decent* signal at first (fewer bars than my EVO, but I assumed it was just this had more total bars to fill), but it has declined more and more. Now I have 1 spot on my desk at work that texts will actually send at, even if I have 1 bar at other spots (the spot jumps up to 3 bars).

    At home, my signal is also degraded since I first got my phone. I use wifi at home, but it doesn't stay connected once my screen goes off, so I have to turn it off and back on each time, and for some reason I can't connect to the market when using wifi, so I have to update off the weak and slow signal if I need to update or download apps.

    The phone is great, and hopefully they do fix the signal issues (and soon) otherwise I'm starting to feel like this was a $200 waste of money sadly...

    *edit*
    Also I'd like to mention my girlfriend has the original Epic, and her signal is fine at home.
    10-09-2011 02:04 PM
  6. niannello's Avatar
    i think that the bars dont display the correct signal, because i have have 0 bars and i can make and receive calls just fine. and if i look long enough, the bars will be 0 and then jump to 5 in a sec, then drop back down in the same spot.
    10-09-2011 02:33 PM
  7. sko580's Avatar
    same as Blitz. According to Sprint there was a service issue in the NYC area. This occurred about three weeks ago. About a week and a half ago, things were improving and since then has been constant.
    10-09-2011 02:36 PM
  8. difrent7's Avatar
    I love this phone but I do have a lot of dropped calls and I am coming from a Nexus S 4g which never had dropped calls. I haven't had LOS where i need to restart the phone but just calls constantly drop on my end.
    10-09-2011 04:34 PM
  9. deedub's Avatar
    3G on my phone is rock solid all of the time. 4G, where available, has been fine too.
    10-09-2011 05:28 PM
  10. yankees177's Avatar
    I dont get great signal and definately had a better signal on my EVO. As far as wifi goes I am definately getting a significant signal loss. I have noticed that if I hold the SGS2 in my hand and browse the web it is slower than if I put it on the table and browse. It reminds me very much of the iphone problem. I did a speed test holding it vs putting it down and it was 50% faster using wifi if i put it down vs held it. The signal bars also drop while I am holding it.
    10-12-2011 01:09 PM
  11. remidog870's Avatar
    I can confirm the same findings as Yankees with my phone. Love the phone, but hoping the signal issues can be addressed.


    I dont get great signal and definately had a better signal on my EVO. As far as wifi goes I am definately getting a significant signal loss. I have noticed that if I hold the SGS2 in my hand and browse the web it is slower than if I put it on the table and browse. It reminds me very much of the iphone problem. I did a speed test holding it vs putting it down and it was 50% faster using wifi if i put it down vs held it. The signal bars also drop while I am holding it.
    10-13-2011 05:30 AM
LINK TO POST COPIED TO CLIPBOARD