1. GCMS's Avatar
    I'm not getting my voicemails anymore. Instead i'm getting a text message from a 9016 number that say Android has sent you a sprint voice message and prompts me to call a number to hear it. What's that all about? And how do i get back my normal Voicemail notification and being able to hear my voicemails normally?
    10-11-2011 09:54 AM
  2. onthehunt's Avatar
    Are you using Handcent text app? If so, the workaround is that you don't select Handcent as the default app when installing it. Had the same voice mail issue happen with my Evo 3D with Handcent. Removed Handcent and voice mail worked normal again.
    10-11-2011 10:57 AM
  3. GCMS's Avatar
    Are you using Handcent text app? If so, the workaround is that you don't select Handcent as the default app when installing it. Had the same voice mail issue happen with my Evo 3D with Handcent. Removed Handcent and voice mail worked normal again.
    I actually have GoSms, same concept?
    10-11-2011 10:58 AM
  4. onthehunt's Avatar
    I haven't used GoSms so I am not sure if it does the same thing to visual voice mail like with Handcent. Hopefully, someone who uses GoSms has an answer for you.
    10-11-2011 11:18 AM
  5. JayWill's Avatar
    Yes, same issue with Go SMS that happens with Handcent. This happened to me too, until I searched around and figured it out. It has to do with your notification setting in Go SMS. Here's what you need to do ...

    Open Go SMS, Menu > Settings > Advanced > Receive Settings > uncheck Disable other message notification

    Gigiddy!

    Edit - Hmmm. I realized that doing this results in double sms notifications though. You can turn the system sms notification SOUND off, but the message will still appear in your notifications bar. Guess I'm not quite there yet, but at least the above fixes the visual voicemail issue.
    GCMS likes this.
    10-11-2011 11:24 AM
  6. GCMS's Avatar
    Yes, same issue with Go SMS that happens with Handcent. This happened to me too, until I searched around and figured it out. It has to do with your notification setting in Go SMS. Here's what you need to do ...

    Open Go SMS, Menu > Settings > Advanced > Receive Settings > uncheck Disable other message notification

    Gigiddy!

    Edit - Hmmm. I realized that doing this results in double sms notifications though. You can turn the system sms notification SOUND off, but the message will still appear in your notifications bar. Guess I'm not quite there yet, but at least the above fixes the visual voicemail issue.
    Problem solved! Thanks alot! I'm getting all the voicemails i never received. Haven't experienced double sms notifications though.
    10-11-2011 12:30 PM
  7. JayWill's Avatar
    Problem solved! Thanks alot! I'm getting all the voicemails i never received. Haven't experienced double sms notifications though.
    Hmmm I'm still getting double notifications (one from the stock sms app and one from GoSMS). I'm sure it's a setting somewhere that I have to find.
    10-11-2011 03:15 PM
  8. GCMS's Avatar
    Hmmm I'm still getting double notifications (one from the stock sms app and one from GoSMS). I'm sure it's a setting somewhere that I have to find.
    Check that, i am too. I'm wondering if it's because Gosms or handcent needs to be set to default?
    10-11-2011 03:30 PM
  9. JayWill's Avatar
    Check that, i am too. I'm wondering if it's because Gosms or handcent needs to be set to default?
    Ahhh okay duurrrrrr. I new it was something simple. Instead of having GoSMS turn off other app notifications, you just want to turn them off in the app itself.

    So open the stock sms app (Messaging) from your app drawer and uncheck Notifications.
    GCMS likes this.
    10-11-2011 03:37 PM
  10. GCMS's Avatar
    Ahhh okay duurrrrrr. I new it was something simple. Instead of having GoSMS turn off other app notifications, you just want to turn them off in the app itself.

    So open the stock sms app (Messaging) from your app drawer and uncheck Notifications.
    Fixed! Good team work, thanks again!
    JayWill likes this.
    10-11-2011 03:39 PM
  11. onthehunt's Avatar
    Check that, i am too. I'm wondering if it's because Gosms or handcent needs to be set to default?
    As mentioned earlier, DO NOT set 3rd party text apps as the default, because this will cause visual voice mail message to be sent to text message. You will have the same issue again.
    10-12-2011 10:39 AM
LINK TO POST COPIED TO CLIPBOARD