1. s.lee1993's Avatar
    Hi all, i am new to the forums.
    Ive had my epic 4g touch since launch but it seems like recently my phone just keeps using all the battery. i turn off all the apps and clear the memory and keep my phone on my desk, However i lose 10-15 percent battery per hour. I am in my dorm room and the signal is weak. Could that be the problem? also the phone gets very hot when i charge it and sometimes it automatically stops charging due to the phone being too hot

    Also i put my phone in airplane mode for 2 hours and it the battery percentage stayed the same. Im pretty sure its a signal issue. What can i do?
    10-20-2011 10:03 PM
  2. DirkBelig's Avatar
    That's what I think is killing mine at work. My office is like a Kryptonite Faraday cage where I get 0-1 bars most of the time, get constant data timeouts, etc. My EVO blew goats there too so it's Sprint, not the phones.

    Where it doubly kills the battery is that the phone stays awake according to the battery stats, even when it's just sitting there. My theory is that apps which are trying to poll or refresh are burning constantly until they connect and the lack of data connectivity sucks battery.
    10-20-2011 10:20 PM
  3. Rockser2g#AC's Avatar
    The thing that helped me was to switch roaming to Sprint only. It made a huge difference in my battery life, even with a bad signal.
    10-20-2011 11:05 PM
  4. kentah's Avatar
    I have really weak signal at work which isn't surprising since I basically work in a building inside of another building (it's a large manufacturing facility). I actually use a Tasker profile to turn on airplane mode whenever my screen is off and turn the radio on whenever I turn the screen back on. Of course I won't receive calls or texts when it's in my pocket but when I'm at work don't really care. I have it turn the radios on at lunch (could have it do it every thirty minutes or something too).

    It's kind of extreme but this way, my battery easily lasts the day. You should see my speed tests from work. I usually get between 2 and 20k download speeds, pretty sad.
    10-21-2011 12:17 AM
  5. sndplace's Avatar
    Yep this happens to me at work when i need to be in the office. The low signal take up battery power but charging your phone should not heat up. It does this no matter how you charge your phone? through the wall charger? Usb computer charger? Have you tried different USB cables and chargers? This thread talks about over heating issues. http://forums.androidcentral.com/spr...erheating.html
    10-21-2011 06:00 AM
  6. DirkBelig's Avatar
    Look at the attached shot. After about 6-1/2 hours off the charger while I slept it had 91% due to data coming thru wifi and solid phone connection.

    Then I went to work and after only 3 hours, I'm down to 50%, have no bars, my signal is yellow, and the phone is constantly awake. Seems to me there is a direct correlation between data connectivity and battery life.

    I'm going to put it into Airplane Mode now at 46% and see what that does.

    UPDATE: I was actually at 45% when I posted this and after 80 minutes of Airplane Mode, it's dropped to 40% It's still showing a lot of awake time, but battery drain has dropped from 45% in three hours to 5% in half the time. It's also cool to the touch (78F) and not toasty in the 100+F neighborhood. Time to switch back on and charge it. I'm missing calls.
    10-21-2011 10:44 AM
  7. JayWill's Avatar
    Things could improve for you Dirk when Sprint finally moves CDMA to the 800mhz band in your area. I don't know when that will happen of course, but it is part of the their Network Vision plans. Our phone is equipped to operate on that band, and it offers greater building penetration.

    Still, 5% over 80mins is too high in airplane mode. I'm wondering if your phone is still waking up to poll data servers for the syncs you have set up, then timing out after not being able to establish a connection. You'd think airplane mode would shut those things off, but maybe not. I wonder if you could use an app like Tasker to shut those things down as part of a profile you can set up and switch to while you're at work, then switch to a default when you go outside or something.
    10-21-2011 04:10 PM
  8. DirkBelig's Avatar
    I didn't think to mass close everything when I did the test. The key point is that turning off the radios stopped the hemorrhaging. This isn't a be-all fix or even proof of concept as much as an experiment to test a theory.
    10-21-2011 04:25 PM
  9. DirkBelig's Avatar
    OK, here's a few more data points to ponder. I charged up the phone at home and after an hour or so off, it only lost 2-3%, if that. I went to my girlfriend's place and sacked out. Before turning in I used System Panel to kill all processes.

    I got up 9 hours later and the battery is 54%. As the first shot shows, nothing is running. The second shows the weaker signal on her side of town, but also that the wifi turned itself off - is this the disconnect bug people are talking about? - and the phone started being awake a lot. Unless a ghost or one of the cats was using it, I have no idea what is causing this.
    10-22-2011 12:03 PM
  10. DirkBelig's Avatar
    Here's last night's bleedout and it's even worse. Unlike the night before, a ton of stuff turned on and stayed awake. This is simply unacceptable, no matter how awesome the phone is.

    Adding to the fun is the GPS going haywire yesterday, losing lock and thinking (guessing) I was in Iowa (I'm in suburban Detroit) or only locking onto one satellite until I rebooted. I'm taking a trip this week and neither behavior is very reassuring.
    10-23-2011 12:37 PM
  11. Chuck Shine's Avatar
    It appears that your problem is caused by leaving your WIFI and Bluetooth radios on all the time (and possibly your GPS). You should turn these off until you need to use them, then turn them off again after using them. You can at least set your WIFI to "sleep" when the screen is off. The long blue horizontal line in your screen captures shows that your WIFI never sleeps.
    10-23-2011 11:04 PM
  12. HollyDolly's Avatar
    Seems to me there is a direct correlation between data connectivity and battery life.
    I believe it is. I had the same issue with poor signal=battery drain, which was most everywhere indoors...which makes the phone useless to me.
    10-24-2011 01:17 AM
  13. taylormah's Avatar
    Referring back to another thread on these forums, try formatting your internal and external storage after backing them up ofcourse and see if that helps. Also, change your wifi sleep policy to turn-off-with-screen for few hours, and then if you want, switch it back to "never" again. That would be done under settings->wireless->wifi settings->(click menu)->advanced. Looking at your usage screens, you have the notorious "Android OS" bug. I personally have not tried it yet, but formatting internal/external storage may be a possible solution for you.You can further follow this xda thread on this issue. I got this link from the above linked androidcentral thread itself.
    10-24-2011 03:17 AM
  14. DirkBelig's Avatar
    Last night I tried putting it into Airplane Mode. I used it a bit with the wifi turned back on, then went to sleep. Woke up about 5-1/2 hours later and spent an hour reading and then back to sleep until an hour ago.

    I have now switched wifi to sleep when screen is off. I don't have an external SD card in yet. I've seen that xda thread before and it seems inconclusive as to whether formatting everything is a proper fix.
    10-24-2011 12:21 PM
  15. DirkBelig's Avatar
    OFFS! I set the wifi to sleep but it didn't look like it was taking, so I rebooted the phone and it came back reading 30% less battery! This screenshot is after a 40-minute walk using My Tracks and turning the GPS back on.

    WTFF is going on here? Thanks for the help so far, all.
    10-24-2011 02:31 PM
  16. s.lee1993's Avatar
    Thank you everyone for the suggestions. Ive tested all of them except for formatting the sd card and the internal memory. I found out that changing the roaming to "sprint only" and putting wifi to "sleep when screen is off" really helped to improve the battery life.
    10-25-2011 01:37 PM

Tags for this Thread